View Issue Details

IDProjectCategoryView StatusLast Update
0032011Open CASCADEOCCT:Configurationpublic2021-12-17 08:09
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionfixed 
Target Version7.6.0Fixed in Version7.6.0 
Summary0032011: Configuration - add batch files to build OCCT for macOS and iOS targets
DescriptionThe proposal is to add batch files for macOS target in order to facilitate build with CMake.
TagsNo tags attached.
Test case numberNot required

Relationships

parent of 0032738 verifiedkgv Open CASCADE Configuration, scripts - handle ABI list within iOS building script adm/scripts/ios_build.sh 
related to 0030999 closedbugmaster Community Configuration - CMake fails to build on IOS 

Activities

git

2020-12-20 19:52

administrator   ~0097815

Branch CR32011 has been created by kgv.

SHA-1: 7fbd9a865aa0b93cae79581a990c189af32c486c


Detailed log of new commits:

Author: kgv
Date: Sun Dec 20 19:52:40 2020 +0300

    0032011: Configuration - add batch files to build OCCT for macOS target
    
    Added script adm/scripts/macos_build.sh and template macos_custom.bat.template
    intended for automating building routines targeting macOS platform.

git

2020-12-20 19:57

administrator   ~0097816

Branch CR32011 has been updated forcibly by kgv.

SHA-1: 82bf147588a912197c13b395db17673d1f3d1e95

git

2020-12-20 20:45

administrator   ~0097817

Branch CR32011 has been updated forcibly by kgv.

SHA-1: 0e9959f607e9e43ade02349fa516fb0294af32c7

git

2020-12-20 21:13

administrator   ~0097818

Branch CR32011 has been updated forcibly by kgv.

SHA-1: 7de0ab7f31aa1059776a05d2315499e3050704e5

git

2020-12-20 21:57

administrator   ~0097819

Branch CR32011 has been updated forcibly by kgv.

SHA-1: a6e5f756460724176833683f80335786f5a2e3cc

kgv

2020-12-23 11:18

developer   ~0097876

Please raise the patch
- OCCT branch: CR32011.

bugmaster

2020-12-26 12:15

administrator   ~0097914

Combination -
OCCT branch : WEEK-52
master SHA - 41046145c4a15f5cedf5f3c5877952ee00d568b4
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : WEEK-52 SHA - 290e5c74e8fef71947cadf90acb8e43c81ed10a1
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17722.770000000193 / 17710.950000000055 [+0.07%]
Products
Total CPU difference: 12416.490000000109 / 12412.520000000126 [+0.03%]
Windows-64-VC14:
OCCT
Total CPU difference: 19321.5625 / 19274.6875 [+0.24%]
Products
Total CPU difference: 13844.421875 / 13853.046875 [-0.06%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2020-12-26 14:53

administrator   ~0097950

Branch CR32011 has been deleted by inv.

SHA-1: a6e5f756460724176833683f80335786f5a2e3cc

Related Changesets

occt: master 8d8971e7

2020-12-20 16:52:40

kgv


Committer: bugmaster Details Diff
0032011: Configuration - add batch files to build OCCT for macOS and iOS targets

Added script adm/scripts/macos_build.sh and template macos_custom.bat.template
intended for automating building routines targeting macOS platform.

Added script adm/scripts/ios_build.sh and template ios_custom.bat.template
intended for automating building routines targeting iOS platform.
Affected Issues
0032011
add - adm/scripts/ios_build.sh Diff File
add - adm/scripts/ios_custom.sh.template Diff File
add - adm/scripts/macos_build.sh Diff File
add - adm/scripts/macos_custom.sh.template Diff File

Issue History

Date Modified Username Field Change
2020-12-20 19:50 kgv New Issue
2020-12-20 19:50 kgv Assigned To => bugmaster
2020-12-20 19:52 git Note Added: 0097815
2020-12-20 19:57 git Note Added: 0097816
2020-12-20 20:45 git Note Added: 0097817
2020-12-20 21:05 kgv Summary Configuration - add batch files to build OCCT for macOS target => Configuration - add batch files to build OCCT for macOS and iOS targets
2020-12-20 21:13 git Note Added: 0097818
2020-12-20 21:57 git Note Added: 0097819
2020-12-23 11:18 kgv Note Added: 0097876
2020-12-23 11:18 kgv Status new => resolved
2020-12-23 11:18 kgv Status resolved => reviewed
2020-12-26 12:15 bugmaster Note Added: 0097914
2020-12-26 12:15 bugmaster Status reviewed => tested
2020-12-26 12:20 bugmaster Test case number => Not required
2020-12-26 14:40 bugmaster Changeset attached => occt master 8d8971e7
2020-12-26 14:40 bugmaster Status tested => verified
2020-12-26 14:40 bugmaster Resolution open => fixed
2020-12-26 14:53 git Note Added: 0097950
2021-02-20 20:28 kgv Relationship added related to 0030999
2021-12-17 08:09 kgv Relationship added parent of 0032738