View Issue Details

IDProjectCategoryView StatusLast Update
0031946Open CASCADEOCCT:Modeling Datapublic2021-09-20 10:59
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionfixed 
Target Version7.6.0Fixed in Version7.6.0 
Summary0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
DescriptionCurrently BinTools_ShapeSet::SetFormatNb() and several other tools rely on indexes in code for version checks. It is proposed defining version enumerations which would allow to provide version description and to use named constants instead of magic numbers in the code.

In addition, it is proposed extending "save" and "binsave" commands in Draw Harness to allow saving shapes in older (supported) version formats.
Steps To ReproduceNot required
TagsNo tags attached.
Test case numberbugs/moddata_3/bug31946

Relationships

related to 0031136 closedbugmaster Open CASCADE Modeling Data - BinXCAF persistence loses normals from triangulation-only Faces 
related to 0029217 closedbugmaster Open CASCADE Application Framework - undocumented API method XmlLDrivers::SetStorageVersion() 
related to 0029723 closedbugmaster Open CASCADE Modeling Data - Get rid of second writing format (additional save of UV points) 
related to 0031990 closedbugmaster Open CASCADE Coding, Draw Harness - Replace C-like pointers to function in Draw_SaveAndRestore class to virtual function 
related to 0028378 newmsv Open CASCADE Documentation - Add information about binary brep 

Activities

git

2020-11-17 20:22

administrator   ~0096848

Branch CR31946 has been created by kgv.

SHA-1: 68e4521a0079a36f77d7dcd0dc8fe1408bbbaaad


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.

git

2020-11-17 20:54

administrator   ~0096850

Branch CR31946 has been updated forcibly by kgv.

SHA-1: a3ee0abc12ba3d3d15df9f7525eee5846d332e98

git

2020-11-18 00:29

administrator   ~0096856

Branch CR31946 has been updated by kgv.

SHA-1: f352b9dec1a199638211415bb9047e88a7b8678a


Detailed log of new commits:

Author: kgv
Date: Wed Nov 18 00:06:25 2020 +0300

    # extend version comments

git

2020-11-19 19:08

administrator   ~0096904

Branch CR31946_1 has been created by asuraven.

SHA-1: 095782e8917f4243c1cce285af9c1804d3e35b27


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.
    
    Add new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters

git

2020-11-20 18:23

administrator   ~0096922

Branch CR31946_1 has been updated by asuraven.

SHA-1: 9c7bc9e287957a7336e04960ede447096aaea103


Detailed log of new commits:

Author: asuraven
Date: Fri Nov 20 18:23:07 2020 +0300

    * Add -noTriangles option for save & binsave commands to prevent triangulation storing
    
    * Add -noTriangles option test

asuraven

2020-11-20 18:26

developer   ~0096923

@kgv @msv
I added the changes in a separate commit.
Please make your remarks

kgv

2020-11-20 18:45

developer   ~0096924

+    else if (aParam == "-notriangles")
+    {
+      isWithTriangles = Standard_False;
+    }

Please use Draw::ParseOnOff() to allow optional exact on/off value while using this parameter.

+ Standard_Boolean isWithTriangles,

theWithTriangles

 help save {
   Use: save variable [filename] [-version Version=2]
   Allowed options are:
    -version a number of format version to save;
             available versions are 1 and 2.
+   -noTriangles to save shape without triangles.
+                Ignored (always written) if face defines only triangulation (no surface).

Please extend syntax description above and specify default value.

+  //! Writes <Sh> on <S> in an ASCII format with <isWithTriangles> option 
+  //! and use <theVersion> version.
+  Standard_EXPORT static void Write (const TopoDS_Shape& Sh, Standard_OStream& S,
+                                     const Standard_Boolean isWithTriangles,
+                                     TopTools_FormatVersion theVersion,
+                                     const Message_ProgressRange& theProgress = Message_ProgressRange());
...
+  //! Writes <theShape> on <theStream> with <isWithTriangles> option 
+  //! and use <theVersion> version in binary format.
+  Standard_EXPORT static void Write(const TopoDS_Shape& theShape, Standard_OStream& theStream,
+                                    const Standard_Boolean isWithTriangles,
+                                    BinTools_FormatVersion theVersion,
+                                    const Message_ProgressRange& theRange = Message_ProgressRange());
...

Please use a valid Doxygen syntax (@param, @return) for new methods, follow OCCT coding rules for old arguments (not just new ones), and update description of existing co-named methods - including default parameters values (version, triangulation storage).

-                                     const Message_ProgressRange& theRange = Message_ProgressRange());
+                                     const Message_ProgressRange& theRangee = Message_ProgressRange());

theRangee

-  BinLDrivers_FormatVersion_VERSION_10,    //!< (OCCT 7.2.0) ReadTOC changed to handle 64-bit file length [#0028736]
+  BinLDrivers_FormatVersion_VERSION_10,    //!< Process user defined guid

Please restore my modifications in the patch.

msv

2020-11-20 23:32

developer   ~0096925

I have no remarks in addition to KGV's.

git

2020-11-23 20:21

administrator   ~0097014

Branch CR31946_1 has been updated by asuraven.

SHA-1: 25380a3023b54a7e2a01575380fe9fb5bae91c83


Detailed log of new commits:

Author: asuraven
Date: Mon Nov 23 20:21:19 2020 +0300

    * remarks fixing

git

2020-11-24 16:58

administrator   ~0097038

Branch CR31946_1 has been deleted by asuraven.

SHA-1: 25380a3023b54a7e2a01575380fe9fb5bae91c83

git

2020-11-24 16:58

administrator   ~0097039

Branch CR31946_1 has been created by asuraven.

SHA-1: e5ba4f5f59b8774e8520d5ca621b9dcd4f9149f0


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.
    
    Add new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters

Author: asuraven
Date: Fri Nov 20 18:23:07 2020 +0300

    * Add -noTriangles option for save & binsave commands to prevent triangulation storing
    
    * Add -noTriangles option test

Author: asuraven
Date: Mon Nov 23 20:21:19 2020 +0300

    * remarks fixing

git

2020-11-25 09:39

administrator   ~0097051

Branch CR31946_2 has been created by asuraven.

SHA-1: 548bfca54e977fe497c214c2db82ef8ded2c1269


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.
    
    Add new optional -noTriangles option for save/binsave commands to prevent triangulation storing
    
    Add new BinTools::Write & BrepTools::Write overloaded function with version & theWithTriangles parameters

kgv

2020-11-25 10:24

developer   ~0097053

Following to discussion with Andrey Betenev, TopTools_FormatVersion_VERSION_2 extends TopTools_FormatVersion_VERSION_1 by reading/writing extra properties. In such context, it would useful:
- Check if not-writing these extra properties into V2 file would create a readable file. If yes - add a new flag similar to withTriangles for writing/not writing these properties.
- Analyze what is the use of properties added by V2 and conclude if these should be written by default or not. As current default is V1 in text format (save the XML persistence which uses V2 for some reason) and we have not straggled from issues in testing bugs for many years, the additions of V2 looks doubtful - hence, necessary to double check.
- Provide an interface returning a minimal format version suitable for required set of properties to write (e.g. triangulation + V2 properties + normals). So that the user will choose not a version but meaningful properties necessary to write. Commands "save" and "binsave" will adopt this interface for choosing version (it might be still useful having an explicit "-version" option, but for debugging purposes).
- Make similar analysis for BinTools_FormatVersion as it basically should be the same as TopTools_FormatVersion, but has an extra version bump.

kgv

2020-11-25 10:29

developer   ~0097054

-  BinTools_FormatVersion_VERSION_3 = 3, //!< (OCCT 6.2.1) Correctly processes geometry with points on Curve,
-                                        //!  or point on Surface, or points on curve of surface [#0009745]
+  BinTools_FormatVersion_VERSION_3 = 3,
...
-  XmlLDrivers_FormatVersion_VERSION_9,     //!< (OCCT 7.2.0) No format changes [#0028691]
+  XmlLDrivers_FormatVersion_VERSION_9,

Please restore these comments as well (and they should be probably further improved).

kgv

2020-11-25 11:16

developer   ~0097056

According to 0029723, it looks like feature of writing UV points is rather useless and can be deprecated in new versions of format persistence...

git

2020-11-25 14:17

administrator   ~0097063

Branch CR31946_1 has been updated by asuraven.

SHA-1: 386b11ac90f6a8a6e0f6e36e873460dab1438537


Detailed log of new commits:

Author: asuraven
Date: Wed Nov 25 14:17:26 2020 +0300

    * fix

git

2020-11-25 14:50

administrator   ~0097065

Branch CR31946_1 has been updated by asuraven.

SHA-1: 7434a86a273423ffb939db936200ed3e2913d891


Detailed log of new commits:

Author: kgv
Date: Wed Nov 18 00:06:25 2020 +0300

    # extend version comments

git

2020-11-25 14:54

administrator   ~0097066

Branch CR31946_2 has been deleted by asuraven.

SHA-1: 548bfca54e977fe497c214c2db82ef8ded2c1269

git

2020-11-25 14:54

administrator   ~0097067

Branch CR31946_2 has been created by asuraven.

SHA-1: cd42aa846170f1ca4b633e781ad8482074d3ed0a


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.
    
    Add new optional -noTriangles parameter for save/binsave commands to prevent triangulation storing
    
    Add new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters
    
    Extend version comments

git

2020-12-07 15:22

administrator   ~0097413

Branch CR31946_1 has been deleted by asuraven.

SHA-1: 7434a86a273423ffb939db936200ed3e2913d891

git

2020-12-07 15:22

administrator   ~0097414

Branch CR31946_1 has been created by asuraven.

SHA-1: 818755ad1726af1a278c2e91f4c23f4c29a99ee7


Detailed log of new commits:

Author: asuraven
Date: Mon Dec 7 15:21:49 2020 +0300

    # correction according to issue 29127

Author: kgv
Date: Wed Nov 18 00:06:25 2020 +0300

    # extend version comments

Author: asuraven
Date: Fri Nov 20 18:23:07 2020 +0300

    * Add -noTriangles option for save & binsave commands to prevent triangulation storing
    
    * Add -noTriangles option test

Author: asuraven
Date: Mon Nov 23 20:21:19 2020 +0300

    * remarks fixing

Author: asuraven
Date: Wed Nov 25 14:17:26 2020 +0300

    * fix

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.
    
    Add new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters

git

2020-12-07 16:39

administrator   ~0097415

Branch CR31946_1 has been deleted by asuraven.

SHA-1: 818755ad1726af1a278c2e91f4c23f4c29a99ee7

git

2020-12-07 16:42

administrator   ~0097416

Branch CR31946_1 has been created by asuraven.

SHA-1: cbc4472f40480eba1c886a04bc9e9aa9b9865dd0


Detailed log of new commits:

Author: asuraven
Date: Mon Dec 7 15:21:49 2020 +0300

    # correction according to issue 29127

Author: kgv
Date: Wed Nov 18 00:06:25 2020 +0300

    # extend version comments

Author: asuraven
Date: Fri Nov 20 18:23:07 2020 +0300

    * Add -noTriangles option for save & binsave commands to prevent triangulation storing
    
    * Add -noTriangles option test

Author: asuraven
Date: Mon Nov 23 20:21:19 2020 +0300

    * remarks fixing

Author: asuraven
Date: Wed Nov 25 14:17:26 2020 +0300

    * fix

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinLDrivers_FormatVersion, BinTools_FormatVersion, TopTools_FormatVersion
    and XmlLDrivers_FormatVersion for more clear version tracking in the code.
    
    Add new optional -version parameter for save/binsave draw commands.
    
    Add new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters

git

2020-12-07 18:39

administrator   ~0097418

Branch CR31946_2 has been deleted by asuraven.

SHA-1: cd42aa846170f1ca4b633e781ad8482074d3ed0a

git

2020-12-07 18:39

administrator   ~0097419

Branch CR31946_2 has been created by asuraven.

SHA-1: 1ae53372413ea978c68d1207011bb1d91631b14c


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinTools_FormatVersion & TopTools_FormatVersion for more clear version tracking in the code.
    Added new optional -version parameter for save/binsave draw commands.
    Added new optional -noTriangles parameter for save/binsave draw commands to prevent triangulation storing.
    Added new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters

kgv

2020-12-09 14:21

developer   ~0097442

Command "bsave" is a general C++ implementation of "save" for working with any drawable object in Draw Harness implementing "Draw_SaveAndRestore" interface.
So that saving into .brep format is only one of many implementations of this interface, and passing version and other brep-specific flags looks confusing in this context.

It is proposed discarding Draw_SaveAndRestore interface changes and keep save/bsave implementation as is - e.g. saving text BRep with default parameters.

Instead, it is proposed defining new commands "writebrep" and "readbrep" (following name convention for XDE formats readstl/writestl/readobj/readgltf/writegltf saving/reading B-Rep shape not into XCAF document) with the following details:
- "writebrep" will extend implementation of existing command "binsave".
- "writebrep" will write into text format by default, with optional "[-binary on/off]" flag.
- "writebrep" will have optional -version/-noTriangles arguments. Description of the command will document supported versions and defaults for binary/text persistence.
- "binsave" will be an alias to "writebrep" saving into binary format.
- "readbrep" will extend implementation of existing command "binrestore" and will choose automatically binary/text reader.

git

2020-12-14 17:11

administrator   ~0097582

Branch CR31946_3 has been created by asuraven.

SHA-1: dd9c4ebcd80f5e2e859a5b22fa132c314a44dc6f


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinTools_FormatVersion & TopTools_FormatVersion for more clear version tracking in the code.
    Added new readbrep/writebrep DRAW commands.
    Added optional "[-binary on/off]" flag for writebrep command. writebrep write into text format by default, default value for "-binary" is "off"
    Added optional -version parameter for writebrep command.
    Added optional -noTriangles parameter writebrep command to prevent triangulation storing.
    "writebrep" now extends implementation of existing command "binsave".
    "binsave" now uses as alias to "writebrep" saving into binary format.
    "readbrep" now extends implementation of existing command "binrestore" and chooses automatically binary/text reader.
    Added new BinTools::Write & BrepTools::Write overloaded function with version & isWithTriangles parameters

asuraven

2020-12-15 12:23

developer   ~0097606

Tests results: http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31946_3-master-ASURAVEN/view/COMPARE/

git

2020-12-15 14:13

administrator   ~0097611

Branch CR31946_3 has been updated by kgv.

SHA-1: 1d1cb85d08e80a7550ba0ad6fb5742660af46099


Detailed log of new commits:

Author: kgv
Date: Tue Dec 15 14:13:58 2020 +0300

    # kgv remarks it.1
    
    # various cosmetics; fixed doxygen syntax and description;
    # fixed pedantic C++ syntax errors
    # revert BRepTools::Write() writing into V2 instead of V1;
    # revert BinMNaming_NamingDriver::Paste() version check - seems to be misprint

git

2020-12-15 15:25

administrator   ~0097613

Branch CR31946_3 has been updated by kgv.

SHA-1: e1643e6be2906833f75c7d3f7504775d23ec0e16


Detailed log of new commits:

Author: kgv
Date: Tue Dec 15 15:26:16 2020 +0300

    # kgv remarks it.2 - clean up writebrep/readbrep commands

git

2020-12-15 15:31

administrator   ~0097614

Branch CR31946_4 has been created by kgv.

SHA-1: 24a1abfdd7311963844fdea9a2c333559043f24b


Detailed log of new commits:

Author: asuraven
Date: Tue Nov 3 17:22:14 2020 +0300

    0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools
    
    Added enumerations BinTools_FormatVersion & TopTools_FormatVersion for more clear version tracking in the code.
    Added new BinTools::Write() & BRepTools::Write() overloaded functions with version & isWithTriangles parameters.
    
    Added new "readbrep"/"writebrep" DRAW commands handling reading and writing of both Binary and ASCII .brep formats
    and providing arguments to setup writing of triangulation data and of format version.
    "binrestore" is made an alias to new command "readbrep".
    "binsave" now is an alias to new "writebrep" saving into binary format by default ("writebrep" writes into ASCII format by default).

git

2020-12-15 15:43

administrator   ~0097615

Branch CR31946_3 has been updated by kgv.

SHA-1: 29fde496795d9b3e58b1721f45debdeef010f638


Detailed log of new commits:

Author: kgv
Date: Tue Dec 15 15:43:49 2020 +0300

    # fix test case bloating filesystem with generated files

git

2020-12-15 15:44

administrator   ~0097616

Branch CR31946_4 has been updated forcibly by kgv.

SHA-1: cd7262f58d031cf7522160476110d01600cfb660

kgv

2020-12-15 17:46

developer   ~0097617

Please raise the patch
- OCCT branch: CR31946_4.

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR31946_4-master-KGV/

bugmaster

2020-12-19 14:49

administrator   ~0097745

Combination -
OCCT branch : IR-2020-12-18
master SHA - 04114fd201c20efe9fbe85f00bec9a99ae3747ad
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-12-18 SHA - 290e5c74e8fef71947cadf90acb8e43c81ed10a1
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17709.570000000054 / 17744.450000000124 [-0.20%]
Products
Total CPU difference: 12258.480000000121 / 12330.210000000125 [-0.58%]
Windows-64-VC14:
OCCT
Total CPU difference: 19272.796875 / 19429.1875 [-0.80%]
Products
Total CPU difference: 13712.859375 / 13755.5 [-0.31%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2020-12-19 15:22

administrator   ~0097775

Branch CR31946_4 has been deleted by inv.

SHA-1: cd7262f58d031cf7522160476110d01600cfb660

git

2020-12-19 15:22

administrator   ~0097776

Branch CR31946_3 has been deleted by inv.

SHA-1: 29fde496795d9b3e58b1721f45debdeef010f638

git

2020-12-19 15:23

administrator   ~0097793

Branch CR31946_2 has been deleted by inv.

SHA-1: 1ae53372413ea978c68d1207011bb1d91631b14c

git

2020-12-19 15:23

administrator   ~0097795

Branch CR31946_1 has been deleted by inv.

SHA-1: cbc4472f40480eba1c886a04bc9e9aa9b9865dd0

git

2020-12-19 15:23

administrator   ~0097802

Branch CR31946 has been deleted by inv.

SHA-1: f352b9dec1a199638211415bb9047e88a7b8678a

Related Changesets

occt: master 14eea829

2020-11-03 14:22:14

asuraven


Committer: bugmaster Details Diff
0031946: Modeling Data - replace version numbers with enumerations in TopTools and BinTools

Added enumerations BinTools_FormatVersion & TopTools_FormatVersion for more clear version tracking in the code.
Added new BinTools::Write() & BRepTools::Write() overloaded functions with version & isWithTriangles parameters.

Added new "readbrep"/"writebrep" DRAW commands handling reading and writing of both Binary and ASCII .brep formats
and providing arguments to setup writing of triangulation data and of format version.
"binrestore" is made an alias to new command "readbrep".
"binsave" now is an alias to new "writebrep" saving into binary format by default ("writebrep" writes into ASCII format by default).
Affected Issues
0031946
mod - src/BinLDrivers/BinLDrivers_DocumentRetrievalDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd.hxx Diff File
mod - src/BinMDataStd/BinMDataStd_AsciiStringDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_ByteArrayDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_ExtStringArrayDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_GenericExtStringDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_IntegerArrayDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_IntegerDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_IntPackedMapDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_RealArrayDriver.cxx Diff File
mod - src/BinMDataStd/BinMDataStd_RealDriver.cxx Diff File
mod - src/BinMNaming/BinMNaming_NamedShapeDriver.cxx Diff File
mod - src/BinMNaming/BinMNaming_NamingDriver.cxx Diff File
mod - src/BinMXCAFDoc/BinMXCAFDoc_LocationDriver.cxx Diff File
mod - src/BinTools/BinTools.cxx Diff File
mod - src/BinTools/BinTools.hxx Diff File
add - src/BinTools/BinTools_FormatVersion.hxx Diff File
mod - src/BinTools/BinTools_ShapeSet.cxx Diff File
mod - src/BinTools/BinTools_ShapeSet.hxx Diff File
mod - src/BinTools/FILES Diff File
mod - src/BRepTools/BRepTools.cxx Diff File
mod - src/BRepTools/BRepTools.hxx Diff File
mod - src/BRepTools/BRepTools_ShapeSet.cxx Diff File
mod - src/BRepTools/BRepTools_ShapeSet.hxx Diff File
mod - src/DBRep/DBRep.cxx Diff File
mod - src/Draw/Draw_VariableCommands.cxx Diff File
mod - src/Storage/Storage_HeaderData.hxx Diff File
mod - src/TopTools/FILES Diff File
add - src/TopTools/TopTools_FormatVersion.hxx Diff File
mod - src/TopTools/TopTools_ShapeSet.cxx Diff File
mod - src/TopTools/TopTools_ShapeSet.hxx Diff File
mod - src/XmlLDrivers/XmlLDrivers_DocumentRetrievalDriver.cxx Diff File
mod - src/XmlLDrivers/XmlLDrivers_DocumentStorageDriver.cxx Diff File
mod - src/XmlMDataStd/XmlMDataStd_ByteArrayDriver.cxx Diff File
mod - src/XmlMDataStd/XmlMDataStd_ExtStringArrayDriver.cxx Diff File
mod - src/XmlMDataStd/XmlMDataStd_IntegerArrayDriver.cxx Diff File
mod - src/XmlMDataStd/XmlMDataStd_IntPackedMapDriver.cxx Diff File
mod - src/XmlMDataStd/XmlMDataStd_RealArrayDriver.cxx Diff File
mod - src/XmlMDataStd/XmlMDataStd_TreeNodeDriver.cxx Diff File
mod - src/XmlMDF/XmlMDF.cxx Diff File
mod - src/XmlMNaming/XmlMNaming_NamedShapeDriver.cxx Diff File
mod - src/XmlMNaming/XmlMNaming_NamingDriver.cxx Diff File
mod - src/XmlMXCAFDoc/XmlMXCAFDoc_LocationDriver.cxx Diff File
add - tests/bugs/moddata_3/bug31946 Diff File

Issue History

Date Modified Username Field Change
2020-11-17 20:15 kgv New Issue
2020-11-17 20:15 kgv Assigned To => msv
2020-11-17 20:16 kgv Relationship added related to 0031136
2020-11-17 20:22 git Note Added: 0096848
2020-11-17 20:22 kgv Assigned To msv => asuraven
2020-11-17 20:22 kgv Status new => assigned
2020-11-17 20:54 git Note Added: 0096850
2020-11-18 00:29 git Note Added: 0096856
2020-11-18 00:31 kgv Relationship added related to 0029217
2020-11-19 19:08 git Note Added: 0096904
2020-11-20 18:23 git Note Added: 0096922
2020-11-20 18:26 asuraven Note Added: 0096923
2020-11-20 18:45 kgv Note Added: 0096924
2020-11-20 23:32 msv Note Added: 0096925
2020-11-23 20:21 git Note Added: 0097014
2020-11-24 16:58 git Note Added: 0097038
2020-11-24 16:58 git Note Added: 0097039
2020-11-25 09:39 git Note Added: 0097051
2020-11-25 10:24 kgv Note Added: 0097053
2020-11-25 10:29 kgv Note Added: 0097054
2020-11-25 10:36 emv Relationship added related to 0029723
2020-11-25 11:16 kgv Note Added: 0097056
2020-11-25 14:17 git Note Added: 0097063
2020-11-25 14:50 git Note Added: 0097065
2020-11-25 14:54 git Note Added: 0097066
2020-11-25 14:54 git Note Added: 0097067
2020-11-25 18:53 asuraven File Added: Format versions compare.docx
2020-11-27 17:45 asuraven File Deleted: Format versions compare.docx
2020-12-07 15:22 git Note Added: 0097413
2020-12-07 15:22 git Note Added: 0097414
2020-12-07 16:39 git Note Added: 0097415
2020-12-07 16:42 git Note Added: 0097416
2020-12-07 18:39 git Note Added: 0097418
2020-12-07 18:39 git Note Added: 0097419
2020-12-09 14:21 kgv Note Added: 0097442
2020-12-09 16:06 asuraven Relationship added related to 0031990
2020-12-14 17:11 git Note Added: 0097582
2020-12-15 12:23 asuraven Note Added: 0097606
2020-12-15 12:23 asuraven Assigned To asuraven => msv
2020-12-15 12:23 asuraven Status assigned => resolved
2020-12-15 12:23 asuraven Steps to Reproduce Updated
2020-12-15 13:56 asuraven Assigned To msv => kgv
2020-12-15 14:13 git Note Added: 0097611
2020-12-15 15:25 git Note Added: 0097613
2020-12-15 15:31 git Note Added: 0097614
2020-12-15 15:43 git Note Added: 0097615
2020-12-15 15:44 git Note Added: 0097616
2020-12-15 17:46 kgv Note Added: 0097617
2020-12-15 17:46 kgv Assigned To kgv => bugmaster
2020-12-15 17:46 kgv Status resolved => reviewed
2020-12-19 14:49 bugmaster Note Added: 0097745
2020-12-19 14:49 bugmaster Status reviewed => tested
2020-12-19 14:57 bugmaster Test case number => bugs/moddata_3/bug31946
2020-12-19 15:06 bugmaster Changeset attached => occt master 14eea829
2020-12-19 15:06 bugmaster Status tested => verified
2020-12-19 15:06 bugmaster Resolution open => fixed
2020-12-19 15:22 git Note Added: 0097775
2020-12-19 15:22 git Note Added: 0097776
2020-12-19 15:23 git Note Added: 0097793
2020-12-19 15:23 git Note Added: 0097795
2020-12-19 15:23 git Note Added: 0097802
2021-09-20 10:59 kgv Relationship added related to 0028378