MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031888Open CASCADE[OCCT] OCCT:Configurationpublic2020-10-29 17:092020-12-02 17:13
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.5.0Fixed in Version[OCCT] 7.5.0 
Summary0031888: Configuration, qmake - linkage error due to missing .cpp file in TKMesh
Descriptionadm/qmake fails due to delabella.cpp source file not being added to the project.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
child of 0030339closedapn Open CASCADE Configuration - add project files for qmake 

-  Notes
(0096384)
git (administrator)
2020-10-29 17:14

Branch CR31888 has been created by kgv.

SHA-1: 337b27320364332278fc3169dc7ebe431be1e492


Detailed log of new commits:

Author: kgv
Date: Thu Oct 29 17:18:10 2020 +0300

    0031888: Configuration, qmake - linkage error due to missing .cpp file in TKMesh
    
    OccToolkit.pri now handles also .cpp file extension.
(0096385)
kgv (developer)
2020-10-29 17:30

Please raise the fix (tested locally)
- OCCT branch: CR31888.
(0096425)
bugmaster (administrator)
2020-10-31 12:48

Combination -
OCCT branch : OCCT-750
master SHA - a8b9d7eb277d4ce8949427b7c6ab6af92422ae83
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : OCCT-750 SHA - d1791aa18ab401708974b4c974aba57dc55acaa7
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17977.46000000013 / 17994.53000000008 [-0.09%]
Products
Total CPU difference: 12143.270000000102 / 12171.670000000115 [-0.23%]
Windows-64-VC14:
OCCT
Total CPU difference: 19728.796875 / 19728.265625 [+0.00%]
Products
Total CPU difference: 13560.6875 / 13538.390625 [+0.16%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0096564)
git (administrator)
2020-11-05 15:59

Branch CR31888 has been deleted by inv.

SHA-1: 337b27320364332278fc3169dc7ebe431be1e492

- Related Changesets
occt: master a8b9d7eb
Timestamp: 2020-10-29 14:18:10
Author: kgv
Committer: bugmaster
Details ] Diff ]
0031888: Configuration, qmake - linkage error due to missing .cpp file in TKMesh

OccToolkit.pri now handles also .cpp file extension.
mod - adm/qmake/OccToolkit.pri Diff ] File ]

- Issue History
Date Modified Username Field Change
2020-10-29 17:09 kgv New Issue
2020-10-29 17:09 kgv Assigned To => bugmaster
2020-10-29 17:09 kgv Relationship added child of 0028089
2020-10-29 17:09 kgv Relationship added child of 0030339
2020-10-29 17:14 git Note Added: 0096384
2020-10-29 17:30 kgv Note Added: 0096385
2020-10-29 17:30 kgv Status new => resolved
2020-10-29 17:30 kgv Status resolved => reviewed
2020-10-31 12:48 bugmaster Note Added: 0096425
2020-10-31 12:48 bugmaster Status reviewed => tested
2020-10-31 12:52 bugmaster Test case number => Not required
2020-10-31 12:54 bugmaster Changeset attached => occt master a8b9d7eb
2020-10-31 12:54 bugmaster Status tested => verified
2020-10-31 12:54 bugmaster Resolution open => fixed
2020-11-05 15:59 git Note Added: 0096564
2020-12-02 16:22 emo Fixed in Version => 7.5.0
2020-12-02 17:13 emo Status verified => closed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker