View Issue Details

IDProjectCategoryView StatusLast Update
0031865Open CASCADEOCCT:Meshpublic2022-12-05 00:25
Reporterkgv Assigned Tooan  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version7.4.0 
Target Version7.8.0 
Summary0031865: Mesh - triangulation fails with large deflection values due to unhandled Standard_OutOfRange, BRepMesh_PairOfIndex::Append()
DescriptionAttached face cannot be triangulated due to unhandled Standard_OutOfRange, BRepMesh_PairOfIndex::Append() exception.

The issue is reproducible since OCCT 7.4.0 (earlier versions produced 49 or 51 triangles, which is probably exhaustive but not empty)
Steps To Reproduce
pload MODELING VISUALIZATION
restore bug31865.brep b
tclean b
tclean b; incmesh b 0.2 -algo watson; trinfo b
#tclean b; incmesh b 0.2; trinfo b
# KO - 0 triangles without any error
tclean b; incmesh b 0.2 -algo delabella; trinfo b
checktrinfo b -tri 1
# OK - 1 triangle
vinit View1
vdefaults -autoTriang 0
vdisplay -dispMode 1 b
vfit
TagsNo tags attached.
Test case number

Attached Files

  • bug31865.brep (8,522 bytes)

Activities

kgv

2020-10-20 15:40

developer  

bug31865.brep (8,522 bytes)

git

2022-11-21 20:04

administrator   ~0112269

Branch CR31865 has been created by oan.

SHA-1: 828fe75902311a697247f9bf2098d4b670141056


Detailed log of new commits:

Author: oan
Date: Mon Nov 21 20:04:09 2022 +0300

    0031865: Mesh - triangulation fails with large deflection values due to unhandled Standard_OutOfRange, BRepMesh_PairOfIndex::Append()
    
    Define minimum number of points for specific types of curves like it was done for circular edges.

git

2022-11-23 19:37

administrator   ~0112286

Branch CR31865 has been updated forcibly by oan.

SHA-1: 6e02cd392f2e740b6dbec7a6531b7ad85b5703c2

git

2022-11-28 14:56

administrator   ~0112356

Branch CR31865 has been updated forcibly by oan.

SHA-1: ee38a60aacf6f1d958885fbddb16116652ca148b

git

2022-11-28 20:56

administrator   ~0112371

Branch CR31865 has been updated forcibly by oan.

SHA-1: 867736c3c503ef440c9c574217c19e689308f065

oan

2022-11-30 14:53

developer   ~0112425

Test reports:
http://jenkins-test-10.nnov.opencascade.com/view/master-CR31865-OAN/view/COMPARE/

To integration:
OCCT: CR31865
PRODUCTS: None

Related Changesets

occt: master 9b7f1aea

2022-11-21 20:04:09

oan


Committer: smoskvin Details Diff
0031865: Mesh - triangulation fails with large deflection values due to unhandled Standard_OutOfRange, BRepMesh_PairOfIndex::Append()

Define minimum number of points for specific types of curves like it was done for circular edges.
Affected Issues
0031865
mod - src/BRepMesh/BRepMesh_CurveTessellator.cxx Diff File
mod - tests/bugs/mesh/bug27845 Diff File
mod - tests/bugs/mesh/bug31449_1 Diff File
mod - tests/bugs/mesh/bug31449_3 Diff File
add - tests/bugs/mesh/bug31865 Diff File
mod - tests/bugs/modalg_2/bug264_6 Diff File
mod - tests/bugs/modalg_2/bug264_7 Diff File
mod - tests/de_mesh/shape_write_stl/A8 Diff File
mod - tests/hlr/poly_hlr/A3 Diff File
mod - tests/hlr/poly_hlr/bug27979_2 Diff File
mod - tests/hlr/poly_hlr/C13 Diff File
mod - tests/hlr/poly_hlr/C15 Diff File
mod - tests/hlr/poly_hlr/C20 Diff File
mod - tests/hlr/poly_hlr/C23 Diff File
mod - tests/hlr/poly_hlr/C24 Diff File
mod - tests/hlr/poly_hlr/C3 Diff File
mod - tests/hlr/poly_hlr/C6 Diff File
mod - tests/hlr/poly_hlr/C8 Diff File

Issue History

Date Modified Username Field Change
2020-10-20 15:23 kgv New Issue
2020-10-20 15:23 kgv Assigned To => oan
2020-10-20 15:40 kgv Product Version 7.5.0 => 7.4.0
2020-10-20 15:40 kgv Summary Mesh - triangulation fails due to unhandled gp_VectorWithNullMagnitude => Mesh - triangulation fails with large deflection values due to unhandled gp_VectorWithNullMagnitude
2020-10-20 15:40 kgv Description Updated
2020-10-20 15:40 kgv Steps to Reproduce Updated
2020-10-20 15:40 kgv File Added: bug31865.brep
2020-10-20 15:40 kgv Steps to Reproduce Updated
2020-10-20 15:46 kgv Summary Mesh - triangulation fails with large deflection values due to unhandled gp_VectorWithNullMagnitude => Mesh - triangulation fails with large deflection values due to unhandled Standard_OutOfRange, BRepMesh_PairOfIndex::Append()
2020-10-20 15:46 kgv Description Updated
2021-10-07 12:38 szy Target Version 7.6.0 => 7.7.0
2022-10-24 10:40 szy Target Version 7.7.0 => 7.8.0
2022-11-21 20:04 git Note Added: 0112269
2022-11-23 19:37 git Note Added: 0112286
2022-11-28 14:56 git Note Added: 0112356
2022-11-28 20:56 git Note Added: 0112371
2022-11-30 14:53 oan Assigned To oan => msv
2022-11-30 14:53 oan Status new => resolved
2022-11-30 14:53 oan Note Added: 0112425
2022-11-30 15:30 msv Assigned To msv => bugmaster
2022-11-30 15:30 msv Status resolved => reviewed
2022-12-05 00:22 smoskvin Status reviewed => tested
2022-12-05 00:25 smoskvin Changeset attached => occt master 9b7f1aea
2022-12-05 00:25 oan Assigned To bugmaster => oan
2022-12-05 00:25 oan Status tested => verified
2022-12-05 00:25 oan Resolution open => fixed