MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031858Community[OCCT] OCCT:Modeling Algorithmspublic2020-10-18 18:302020-10-24 12:41
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeveritycrash 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0031858: [REGRESSION] Modeling Algorithms - Boolean operation crashes between the given Cylinder and Torus
Descriptionboolean-cylinder-torus.brep file contain a shape cylinder and a torus.
Boolean cut, common, fuse all crash in occt 7.5.0 beta.
It works well in version 7.4.0.
Steps To Reproducetestgrid bugs modalg_7 bug31858*
TagsNo tags attached.
Test case numberbugs/modalg_7/bug31858_1,bug31858_2
Attached Files? file icon boolean-cylinder-torus.brep (167,090 bytes) 2020-10-18 18:30
jpg file icon cylinder-torus.jpg (136,623 bytes) 2020-10-18 18:30

- Relationships
related to 0031836verifiedbugmaster [REGRESSION] Modeling Algorithms - Boolean cut failed between a Cone and a Torus 

-  Notes
(0096045)
msv (developer)
2020-10-18 22:45

Dear Eugeny,
It seems to be fixed by you previous patch. Could you create a new test case?
(0096137)
git (administrator)
2020-10-22 14:45

Branch CR31858 has been created by emv.

SHA-1: 54953036ef21899dcc1d84ab710765f3c86d0300


Detailed log of new commits:

Author: emv
Date: Thu Oct 22 14:47:23 2020 +0300

    0031858: Modeling Algorithms - boolean operation crash between the given cylinder and torus.
    
    Integrating test cases only, as the problem is not reproduced.
(0096159)
emv (developer)
2020-10-22 23:53

Dear Mikhail, could you please review test cases in the git branch CR31858.
Test results - http://occt-tests/CR31858-master-emv-OCCT/ [^]
(0096163)
msv (developer)
2020-10-23 11:58

For integration:
occt - CR31858
products - none
(0096199)
bugmaster (administrator)
2020-10-24 12:19

Combination -
OCCT branch : IR-2020-10-23
master SHA - 9f9490e1ae0eaf38507437019a117437c6317225
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-10-23 SHA - 4594c3ef5cc6ec5816231ba88e2a4863a25a06d2
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18000.12000000008 / 18036.38000000013 [-0.20%]
Products
Total CPU difference: 12171.670000000115 / 12174.520000000093 [-0.02%]
Windows-64-VC14:
OCCT
Total CPU difference: 19723.78125 / 19746.3125 [-0.11%]
Products
Total CPU difference: 13538.390625 / 13565.046875 [-0.20%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0096207)
git (administrator)
2020-10-24 12:41

Branch CR31858 has been deleted by inv.

SHA-1: 54953036ef21899dcc1d84ab710765f3c86d0300

- Related Changesets
occt: master 0612bb70
Timestamp: 2020-10-22 11:47:23
Author: emv
Committer: bugmaster
Details ] Diff ]
0031858: Modeling Algorithms - boolean operation crash between the given cylinder and torus.

Integrating test cases only, as the problem is not reproduced.
add - tests/bugs/modalg_7/bug31858_1 Diff ] File ]
add - tests/bugs/modalg_7/bug31858_2 Diff ] File ]

- Issue History
Date Modified Username Field Change
2020-10-18 18:30 Vico Liang New Issue
2020-10-18 18:30 Vico Liang Assigned To => msv
2020-10-18 18:30 Vico Liang File Added: boolean-cylinder-torus.brep
2020-10-18 18:30 Vico Liang File Added: cylinder-torus.jpg
2020-10-18 18:32 Vico Liang Target Version 7.6.0* => 7.5.0
2020-10-18 22:45 msv Note Added: 0096045
2020-10-18 22:45 msv Assigned To msv => emv
2020-10-18 22:45 msv Status new => assigned
2020-10-18 22:45 msv Summary [REGRESSION] - boolean operation crash between the given cylinder and torus. => [REGRESSION] Modeling Algorithms - boolean operation crash between the given cylinder and torus.
2020-10-22 14:45 git Note Added: 0096137
2020-10-22 14:47 kgv Relationship added related to 0031836
2020-10-22 14:48 kgv Summary [REGRESSION] Modeling Algorithms - boolean operation crash between the given cylinder and torus. => [REGRESSION] Modeling Algorithms - Boolean operation crashes between the given Cylinder and Torus
2020-10-22 23:53 emv Note Added: 0096159
2020-10-22 23:53 emv Assigned To emv => msv
2020-10-22 23:53 emv Status assigned => resolved
2020-10-22 23:53 emv Steps to Reproduce Updated View Revisions
2020-10-23 11:58 msv Note Added: 0096163
2020-10-23 11:58 msv Assigned To msv => bugmaster
2020-10-23 11:58 msv Status resolved => reviewed
2020-10-24 12:19 bugmaster Note Added: 0096199
2020-10-24 12:19 bugmaster Status reviewed => tested
2020-10-24 12:28 bugmaster Test case number => bugs/modalg_7/bug31858_1,bug31858_2
2020-10-24 12:30 bugmaster Changeset attached => occt master 0612bb70
2020-10-24 12:30 bugmaster Status tested => verified
2020-10-24 12:30 bugmaster Resolution open => fixed
2020-10-24 12:41 git Note Added: 0096207


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker