View Issue Details

IDProjectCategoryView StatusLast Update
0031845CommunityOCCT:Modeling Algorithmspublic2021-04-16 14:42
Reportergalbramc Assigned Tobugmaster  
PrioritynormalSeveritymajor 
Status closedResolutionfixed 
PlatformMacOSOS 
Product Version7.5.0 
Target Version7.5.1Fixed in Version7.6.0 
Summary0031845: [REGRESSION] Modeling Algorithms - BRepOffsetAPI_MakeThickSolid fails in OCCT 7.5.0 BETA
DescriptionThe attached case works with OCCT 7.3 and 7.4, but fails with 7.5 beta.

Changing the #if 0 to #if 1 causes the case to fail with all versions.
Steps To ReproduceCompile and execute the attached code.
TagsNo tags attached.
Test case numberbugs/modalg_7/bug31735_3,bug31845_1,bug31845_2,bug31845_3,bug31845_4,bug31845_f,bug31845_h,bug31845_i

Attached Files

  • hollow_wingFuseBEM1.tgz (4,329 bytes)
  • hollow_hollow9b.tgz (3,099 bytes)
  • hollow_hollow9c.tgz (3,177 bytes)
  • hollow_hollow9f.tgz (15,554 bytes)
  • hollow_hollow9h.tgz (4,348 bytes)
  • hollow_hollow9i.tgz (4,345 bytes)
  • hollow_design6.tgz (6,066 bytes)
  • hollow_glass.tgz (2,440 bytes)
  • BRepOffsetAPI_MakeThickSolid.patch (62,727 bytes)

Relationships

parent of 0032151 feedbackbugmaster Community [REGRESSION] Modeling Algorithms - BRepOffsetAPI_MakeThickSolid Generated fails in OCCT 7.5.1 
Not all the children of this issue are yet resolved or closed.

Activities

galbramc

2020-10-13 06:16

reporter  

hollow_wingFuseBEM1.tgz (4,329 bytes)

galbramc

2020-10-15 20:07

reporter   ~0096000

I have another 5 cases or so with a similar failure. Would you like me to provide them as well? It's possible all are failing for the same reason.

jgv

2020-10-16 14:17

developer   ~0096007

Yes, please add your cases, they will be useful.

galbramc

2020-10-16 15:57

reporter   ~0096009

Would you like me to submit them all to this bug report or create a report for each of them individually?

jgv

2020-10-16 16:24

developer   ~0096011

Please, submit them all with the corresponding offset value for each case

galbramc

2020-10-16 16:44

reporter   ~0096012

Yes I will do that. So should I create a new bug report for each case? I could add them all here with appropriate offsets.

jgv

2020-10-16 17:03

developer   ~0096013

Please, do not create separate bug for each case but add them all here with appropriate offsets.

galbramc

2020-10-16 20:35

reporter  

hollow_hollow9b.tgz (3,099 bytes)

galbramc

2020-10-16 20:36

reporter  

hollow_hollow9c.tgz (3,177 bytes)

galbramc

2020-10-16 20:37

reporter   ~0096016

Last edited: 2020-10-16 20:38

I looked closer at our cases and it was just two cases that were actually failing. The error is related to tracking history in regards to Generated and Modified faces. In OCC 7.4 all faces are properly tracked, but in OCC 7.5 some faces end up missing.

I added the two cases: hollow_hollow9b and hollow_hollow9c.

Please let me know if you have any questions about them.

galbramc

2020-10-16 21:46

reporter  

hollow_hollow9f.tgz (15,554 bytes)

galbramc

2020-10-16 21:46

reporter  

hollow_hollow9h.tgz (4,348 bytes)

galbramc

2020-10-16 21:46

reporter  

hollow_hollow9i.tgz (4,345 bytes)

galbramc

2020-10-16 21:48

reporter   ~0096017

I added three more cases which have not worked for any version of OCC.

hollow_hollow9f
hollow_hollow9h
hollow_hollow9i

git

2020-10-23 13:25

administrator   ~0096169

Branch CR31845 has been created by jgv.

SHA-1: 13328e3b34a02a9df28c613a2d3d13cc32621ac2


Detailed log of new commits:

Author: jgv
Date: Fri Oct 23 13:28:40 2020 +0300

    Intermediate version

Author: jgv
Date: Mon Oct 19 05:05:00 2020 +0300

    0031845: Modeling Algorithms - BRepOffsetAPI_MakeThickSolid fails in OCCT 7.5.0 BETA
    
    implementation of Draw command for BRepOffsetAPI_MakeThickSolid

git

2020-10-25 20:11

administrator   ~0096258

Branch CR31845 has been updated forcibly by jgv.

SHA-1: 83b82793ae0367f66774c4eac68bffb8c473707d

galbramc

2020-10-30 19:57

reporter   ~0096414

When might OCC 7.5.1 be released? I guess we will have to wait to upgrade OCC until that version is released...

abv

2020-10-31 11:04

manager   ~0096419

The regression is caused by improved treatment of nearly-tangent faces in offset algorithm, which fixed a range of customer issues, that is why we prefer to keep it even knowing about this regression. The release 7.5.1 is expected to be done in December (or perhaps January 2021 -- taken that actual schedule is usually behind the intended planning).

git

2020-11-03 13:28

administrator   ~0096490

Branch CR31845 has been updated forcibly by jgv.

SHA-1: 90acc2fcdb1981011a4f79c806acbadec2f00466

galbramc

2020-11-12 07:01

reporter  

hollow_design6.tgz (6,066 bytes)

galbramc

2020-11-12 07:01

reporter  

hollow_glass.tgz (2,440 bytes)

galbramc

2020-11-12 07:04

reporter   ~0096676

I added hollow_design6 and hollow_glass as two more test cases for you. Both work with OCC 7.4 but fail with "BRep_API: command not done" with 7.5 after applying the patch you are working on.

I have 88 test case in total that use BRepOffsetAPI, but I don't know how many of them are equivalent...

git

2020-11-20 07:10

administrator   ~0096907

Branch CR31845_1 has been created by jgv.

SHA-1: 58410758621a1ee66d48ee9b16ca4ffa6de9332c


Detailed log of new commits:

Author: jgv
Date: Fri Nov 20 07:10:19 2020 +0300

    0031845: Modeling Algorithms - BRepOffsetAPI_MakeThickSolid fails
    
    Some changes in BRepOffset_MakeOffset

git

2020-11-25 07:36

administrator   ~0097048

Branch CR31845_1 has been updated forcibly by jgv.

SHA-1: 806743b7c10ae38d574f63b857ba49bd37f48065

git

2020-12-02 22:24

administrator   ~0097254

Branch CR31845_1 has been updated forcibly by jgv.

SHA-1: 6bffe20702125adccf0afd551ca461fb301f5f05

git

2020-12-11 13:53

administrator   ~0097485

Branch CR31845_1 has been updated forcibly by jgv.

SHA-1: ac0e4511d08bf5d34e4500bfe58aa2953302ceb0

jgv

2021-01-20 17:43

developer   ~0098257

Please review the branch CR31845_2.

Test results are in http://vm-jenkins-test-12.nnov.opencascade.com:8080//view/CR31845-master-JGV/view/COMPARE/job/CR31845-master-JGV-OCCT-Debian80-64-opt-test-compare/

Concerning cases "bugs modalg_2 bug5805_18, 41, 42" - they were BAD (yellow) and they must remain BAD, but I don't know how to suppress the error message "FAILED (no final message is found)". Could you help me?

galbramc

2021-01-20 18:44

reporter   ~0098262

Is there any way I could get a patch for branch CR31845_2 so I can run the changes trough our test suite? I was able to grab a patch from CR31845_1 based on the commitdiff, but I'm not sure where branch CR31845_2 is.

msv

2021-01-20 20:54

developer   ~0098266

There was a technical problem with updates of bugtracker, so you cannot see the link to the patch just here. However, you can easily get it from the repository. Go to http://dev.opencascade.org/, there you can find a way to get access to the repository.

ifv

2021-01-21 13:28

developer   ~0098298

Code modification seems to be OK.

Problem of tests bus/modalg_2/bug5805_18, _41, _42 is caused by using checkshape command for not topological shape. It is possible to check result shape (by isdraw or dtype) and do not use checkshape if shape is not topologycal. Checkshape is called inside test script, not in script "end"

jgv

2021-01-21 14:08

developer   ~0098299

Please review CR31845_2 again.

Thanks for a good advice. I've modified these 3 cases like the similar case bug5805_17 (with null result).

Branches for integration:
OCCT – CR31845_2
Products – NOT

ifv

2021-01-21 14:17

developer   ~0098300

Branch seems to be valid for integration

galbramc

2021-01-21 15:42

reporter   ~0098305

It's going to take some time for me to sort out if I can sign the CLA to get access to the repository. Is there any other way I could get access to these modifications? A beta tar file maybe? I would like to provide feedback in case some of our 88 tests are still failing before 7.5.1 gets released.

msv

2021-01-21 15:47

developer   ~0098307

There is web access to the repository https://git.dev.opencascade.org/gitweb/?p=occt.git

kgv

2021-01-21 15:58

developer   ~0098313

galbramc wrote:
> It's going to take some time for me to sort out if I can sign the CLA
> to get access to the repository.
You don't have to sign Contribution License Agreement if you don't plan contributing a code.
Check the list of resources on development portal which includes also anonymous read-only access to git repository:
https://dev.opencascade.org/index.php?q=home/resources

galbramc

2021-01-21 16:08

reporter   ~0098314

Thanks, I didn't find that link on the developer site. I just to confirm I grabbed the correct patch: https://git.dev.opencascade.org/gitweb/?p=occt.git;a=commitdiff;h=f174bf336f7dd95711ded5ce0313656ce1afff5f

I'll run though our tests and get back to you later today.

msv

2021-01-21 17:21

developer   ~0098315

It is the correct patch.

galbramc

2021-01-21 19:01

reporter   ~0098319

Most of the cases have been fixed. However, the Modified and/or Generated functions are still not working properly with:

hollow_hollow9b.tgz
hollow_hollow9c.tgz

These work with OCC 7.4. The Modified/Generated functions are a key component that we rely heavily on.

The cases:

hollow_hollow9f.tgz
hollow_hollow9h.tgz
hollow_hollow9i.tgz

have never worked and still do not work. I don't now if fixing these is beyond the scope of this bug fix though.

msv

2021-01-21 19:49

developer   ~0098320

Modified/Generated is definitely out of scope of this bug. Please, create a separate issue for each individual problem.

msv

2021-01-21 19:55

developer   ~0098321

Sorry, may be I am wrong. In that case it is needed to create test cases for our test system that run fail.

galbramc

2021-01-21 20:22

reporter   ~0098322

I have uploaded the C++ examples in hollow_hollow9b.tgz and hollow_hollow9c.tgz which demonstrate the Modified/Generated failures. Unfortunately I am not familiar enough with your testing system to convert them for you... I am willing the help in any way I can.

msv

2021-01-21 21:55

developer   ~0098323

Julia, could you create test cases according to mentioned C++ codes? And then finish the patch to make them working.

jgv

2021-01-21 21:57

developer   ~0098324

The case hollow_hollow9b is OK. Please try in Draw the following script:

restore hollow_hollow9b.brep a
explode a f

offsetparameter 1.e-7 p i
offsetload a -0.01
offsetperform r
savehistory hh
generated gf1 hh a_1
#face gf1 corresponds to initial face a_1

The case hollow_hollow9c is OK except disappeared faces a_5 and a_6:

restore hollow_hollow9c.brep a
explode a f

offsetparameter 1.e-7 p i
offsetload a 0.001 a_5 a_6
offsetperform r

savehistory hh
generated gf5 hh a_5
#No shapes were generated from the shape.

But the same was in the version 7.4

galbramc

2021-01-21 23:00

reporter   ~0098325

The geometry is fine, it's Generated/Modified functions that tie the output geometry back to the input geometry that are not working. If you look closely at the C++ code and run it with OCC 7.5 you should get output:

14:58 $ ./hollow_hollow9b
Could not map face 1
Could not map face 2
Could not map face 3
Could not map face 4

If I run with OCC 7.4 all faces are properly mapped and there is no output from the example.

jgv

2021-01-22 16:53

developer   ~0098338

Please review again the branch CR31845_2.

Branches for integration:
OCCT – CR31845_2
Products – NOT

ifv

2021-01-22 17:05

developer   ~0098339

Branch seems to be valid

galbramc

2021-01-22 17:30

reporter   ~0098341

Maybe I didn't get all the OCC 7.5 changes when I grabbed the patch. jgv, could you confirm if you run the C++ code in hollow_hollow9b.tgz and in hollow_hollow9c.tgz you do not get any output in the terminal? If so, then the Generated/Modified functions are fine and I missed something with the patch.

jgv

2021-01-22 17:57

developer   ~0098346

Your code is too complicated. Please try the following (for hollow_hollow9c):

  TopoDS_Shape aShape = ...
  
  Standard_Real offset = 0.001; // = -0.001;
  Standard_Real tol = Precision::Confusion();

  TopTools_IndexedMapOfShape aMap;

  TopExp::MapShapes(aShape, TopAbs_FACE, aMap);

  TopTools_ListOfShape aList;
  aList.Append(aMap(5));
  aList.Append(aMap(6));

  GeomAbs_JoinType join = GeomAbs_Intersection;

  BRepOffsetAPI_MakeThickSolid hollow1;
  hollow1.MakeThickSolidByJoin(aShape, aList, offset, tol,
                               BRepOffset_Skin, Standard_False,
                               Standard_False, join);
  
  TopoDS_Shape newShape = hollow1.Shape();

  for (Standard_Integer i = 1; i <= 4; i++)
  {
    const TopoDS_Shape& aSubshape = aMap(i);
    const TopTools_ListOfShape& listImages = hollow1.Generated(aSubshape);
    TopTools_ListIteratorOfListOfShape it(listImages);
    for (; it.More(); it.Next())
    {
      TopoDS_Shape anImage = it.Value();
      TopExp_Explorer anExplo (newShape, TopAbs_FACE);
      for (; anExplo.More(); anExplo.Next())
      {
        const TopoDS_Face& aResFace = TopoDS::Face(anExplo.Current());
        if (aResFace == anImage)
          std::cout << "Image of face " << i << " is found in the result" << std::endl;
      }
    }
  }
  for (Standard_Integer i = 5; i <= 6; i++)
  {
    const TopoDS_Shape& aSubshape = aMap(i);
    const TopTools_ListOfShape& listImages = hollow1.Modified(aSubshape);
    TopTools_ListIteratorOfListOfShape it(listImages);
    for (; it.More(); it.Next())
    {
      TopoDS_Shape anImage = it.Value();
      TopExp_Explorer anExplo (newShape, TopAbs_FACE);
      for (; anExplo.More(); anExplo.Next())
      {
        const TopoDS_Face& aResFace = TopoDS::Face(anExplo.Current());
        if (aResFace == anImage)
          std::cout << "Modified face " << i << " is found in the result" << std::endl;
      }
    }
  }

galbramc

2021-01-22 18:23

reporter   ~0098352

Give me a moment to test this out with OCC 7.4 and 7.5.

galbramc

2021-01-22 18:51

reporter   ~0098353

OCC 7.4:
$ ./hollow_hollow9c
Image of face 1 is found in the result
Image of face 2 is found in the result
Image of face 3 is found in the result
Image of face 4 is found in the result
Modified face 5 is found in the result
Modified face 6 is found in the result

OCC 7.5:
./hollow_hollow9c
Modified face 5 is found in the result
Modified face 6 is found in the result

Assuming you get the same results with both OCC 7.4 and 7.5 I must be missing something in the patch I grabbed?

bugmaster

2021-01-23 12:51

administrator   ~0098378

Combination -
OCCT branch : IR-2021-01-22
master SHA - 8948e18df815e356c59a750bd2711cb4a7914cec
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2021-01-22 SHA - 7cb485e51cb439852e1e1e0726af89f51d6d6db0
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17720.020000000055 / 17721.200000000135 [-0.01%]
Products
Total CPU difference: 12428.380000000123 / 12412.630000000105 [+0.13%]
Windows-64-VC14:
OCCT
Total CPU difference: 19367.234375 / 19300.265625 [+0.35%]
Products
Total CPU difference: 13821.875 / 13740.03125 [+0.60%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

galbramc

2021-01-26 00:43

reporter   ~0098411

I grabbed the patch blow again, and the Generated function still is not working properly for me. jgv, does the hollow_hollow9c case you posted give consistent results between 7.4 and 7.5 with this patch?

jgv

2021-01-26 11:48

developer   ~0098415

Dear galbramc,

Launching the "hollow_hollow9c sample" on the last patch to 7.5, there are all 6 expected output lines: 4 for "generated" subshapes and 2 for "modified" subshapes:

Image of face 1 is found in the result
Image of face 2 is found in the result
Image of face 3 is found in the result
Image of face 4 is found in the result
Modified face 5 is found in the result
Modified face 6 is found in the result

So, I don't know why you have such strange result. Please check possible differences in your merged sources.

galbramc

2021-01-26 18:12

reporter  

BRepOffsetAPI_MakeThickSolid.patch (62,727 bytes)

galbramc

2021-01-26 18:12

reporter   ~0098424

jgv, thank you so much for your patience with me. I'm applying the patch to the OCC 7.5 released source; is it possible there are fixes by others in a master branch that you are using that I am missing? I've uploaded BRepOffsetAPI_MakeThickSolid.patch which shows the changes I've applied. It looks consistent with the patch for this branch as best as I can tell.

Also, do these cases work for you:

hollow_hollow9f.tgz
hollow_hollow9h.tgz
hollow_hollow9i.tgz

If not, should I open another bug report for them?

szy

2021-01-27 14:59

manager   ~0098438

Dear galbramc,
Sorry, but jgv is busy now with urgent tasks and can't continue communication with you.
You may address your questions to OCCT Forum (https://old.opencascade.com/forums) or consider buying our technical support (https://old.opencascade.com/content/technology-support).

galbramc

2021-01-27 22:28

reporter   ~0098451

Thank you for all the help and your patience with me.

git

2021-01-29 13:40

administrator   ~0098512

Branch CR31845_jgv has been created by jgv.

SHA-1: 96e2e7bdf450fc3e429a5a47eec6d3b5baf47425


Detailed log of new commits:

Author: jgv
Date: Fri Jan 29 13:37:15 2021 +0300

    Correction of merge

Author: jgv
Date: Tue Jan 12 03:45:17 2021 +0300

    0031845: Modeling Algorithms - BRepOffsetAPI_MakeThickSolid fails
    
    Multiple changes in BRepOffset_MakeOffset algorithm:
    - correct fusing vertices;
    - correct building intersection edges;
    - correct intersecting new edges in 2D;
    - correct building wire on a new face;
    - correct building history.
    
    # Conflicts:
    # src/BRepOffset/BRepOffset_Inter2d.hxx

git

2021-02-06 14:29

administrator   ~0098738

Branch CR31845_jgv has been deleted by inv.

SHA-1: 96e2e7bdf450fc3e429a5a47eec6d3b5baf47425

Related Changesets

occt: master 8948e18d

2021-01-12 00:45:17

jgv


Committer: bugmaster Details Diff
0031845: Modeling Algorithms - BRepOffsetAPI_MakeThickSolid fails

Multiple changes in BRepOffset_MakeOffset algorithm:
- correct fusing vertices;
- correct building intersection edges;
- correct intersecting new edges in 2D;
- correct building wire on a new face;
- correct building history.
Affected Issues
0031845
mod - src/BiTgte/BiTgte_Blend.cxx Diff File
mod - src/BRepAlgo/BRepAlgo_Loop.cxx Diff File
mod - src/BRepAlgo/BRepAlgo_Loop.hxx Diff File
mod - src/BRepOffset/BRepOffset_Inter2d.cxx Diff File
mod - src/BRepOffset/BRepOffset_Inter2d.hxx Diff File
mod - src/BRepOffset/BRepOffset_Inter3d.cxx Diff File
mod - src/BRepOffset/BRepOffset_MakeLoops.cxx Diff File
mod - src/BRepOffset/BRepOffset_MakeLoops.hxx Diff File
mod - src/BRepOffset/BRepOffset_MakeOffset.cxx Diff File
mod - src/BRepOffset/BRepOffset_MakeOffset.hxx Diff File
mod - src/BRepOffset/BRepOffset_MakeOffset_1.cxx Diff File
mod - src/BRepOffset/BRepOffset_Tool.cxx Diff File
mod - src/BRepOffset/BRepOffset_Tool.hxx Diff File
mod - tests/bugs/modalg_2/bug5805_18 Diff File
mod - tests/bugs/modalg_2/bug5805_41 Diff File
mod - tests/bugs/modalg_2/bug5805_42 Diff File
add - tests/bugs/modalg_7/bug31735_3 Diff File
add - tests/bugs/modalg_7/bug31735_4 Diff File
add - tests/bugs/modalg_7/bug31845_1 Diff File
add - tests/bugs/modalg_7/bug31845_2 Diff File
add - tests/bugs/modalg_7/bug31845_3 Diff File
add - tests/bugs/modalg_7/bug31845_4 Diff File
add - tests/bugs/modalg_7/bug31845_f Diff File
add - tests/bugs/modalg_7/bug31845_h Diff File
add - tests/bugs/modalg_7/bug31845_i Diff File
mod - tests/offset/shape_type_i/C5 Diff File
mod - tests/offset/shape_type_i_c/XI4 Diff File
mod - tests/offset/shape_type_i_c/XI6 Diff File
mod - tests/offset/shape_type_i_c/XI8 Diff File

Issue History

Date Modified Username Field Change
2020-10-13 06:16 galbramc New Issue
2020-10-13 06:16 galbramc Assigned To => abv
2020-10-13 06:16 galbramc File Added: hollow_wingFuseBEM1.tgz
2020-10-13 07:50 kgv Product Version => 7.5.0
2020-10-13 07:50 kgv Target Version => 7.5.0
2020-10-13 07:50 kgv Summary [OCCT] 7.5.0 Beta [REGRESSION] BRepOffsetAPI_MakeThickSolid => [REGRESSION] Modeling Algorithms - BRepOffsetAPI_MakeThickSolid fails in OCCT 7.5.0 BETA
2020-10-13 07:51 kgv Assigned To abv => msv
2020-10-13 09:42 msv Assigned To msv => jgv
2020-10-13 09:42 msv Status new => assigned
2020-10-15 20:07 galbramc Note Added: 0096000
2020-10-16 14:17 jgv Note Added: 0096007
2020-10-16 15:57 galbramc Note Added: 0096009
2020-10-16 16:24 jgv Note Added: 0096011
2020-10-16 16:44 galbramc Note Added: 0096012
2020-10-16 17:03 jgv Note Added: 0096013
2020-10-16 20:35 galbramc File Added: hollow_hollow9b.tgz
2020-10-16 20:36 galbramc File Added: hollow_hollow9c.tgz
2020-10-16 20:37 galbramc Note Added: 0096016
2020-10-16 20:38 galbramc Note Edited: 0096016
2020-10-16 21:46 galbramc File Added: hollow_hollow9f.tgz
2020-10-16 21:46 galbramc File Added: hollow_hollow9h.tgz
2020-10-16 21:46 galbramc File Added: hollow_hollow9i.tgz
2020-10-16 21:48 galbramc Note Added: 0096017
2020-10-23 13:25 git Note Added: 0096169
2020-10-25 20:11 git Note Added: 0096258
2020-10-30 19:41 bugmaster Target Version 7.5.0 => 7.5.1
2020-10-30 19:57 galbramc Note Added: 0096414
2020-10-31 11:04 abv Note Added: 0096419
2020-11-03 13:28 git Note Added: 0096490
2020-11-12 07:01 galbramc File Added: hollow_design6.tgz
2020-11-12 07:01 galbramc File Added: hollow_glass.tgz
2020-11-12 07:04 galbramc Note Added: 0096676
2020-11-20 07:10 git Note Added: 0096907
2020-11-25 07:36 git Note Added: 0097048
2020-12-02 22:24 git Note Added: 0097254
2020-12-11 13:53 git Note Added: 0097485
2021-01-20 17:43 jgv Note Added: 0098257
2021-01-20 17:43 jgv Assigned To jgv => emv
2021-01-20 17:43 jgv Status assigned => resolved
2021-01-20 18:44 galbramc Note Added: 0098262
2021-01-20 20:54 msv Note Added: 0098266
2021-01-21 10:49 szy Assigned To emv => ifv
2021-01-21 13:28 ifv Note Added: 0098298
2021-01-21 13:28 ifv Assigned To ifv => jgv
2021-01-21 13:28 ifv Status resolved => assigned
2021-01-21 14:08 jgv Note Added: 0098299
2021-01-21 14:08 jgv Assigned To jgv => ifv
2021-01-21 14:08 jgv Status assigned => resolved
2021-01-21 14:17 ifv Note Added: 0098300
2021-01-21 14:17 ifv Assigned To ifv => bugmaster
2021-01-21 14:17 ifv Status resolved => reviewed
2021-01-21 15:42 galbramc Note Added: 0098305
2021-01-21 15:47 msv Note Added: 0098307
2021-01-21 15:58 kgv Note Added: 0098313
2021-01-21 16:08 galbramc Note Added: 0098314
2021-01-21 17:21 msv Note Added: 0098315
2021-01-21 19:01 galbramc Note Added: 0098319
2021-01-21 19:49 msv Note Added: 0098320
2021-01-21 19:55 msv Note Added: 0098321
2021-01-21 20:22 galbramc Note Added: 0098322
2021-01-21 21:55 msv Note Added: 0098323
2021-01-21 21:55 msv Assigned To bugmaster => jgv
2021-01-21 21:55 msv Status reviewed => assigned
2021-01-21 21:57 jgv Note Added: 0098324
2021-01-21 23:00 galbramc Note Added: 0098325
2021-01-22 16:53 jgv Note Added: 0098338
2021-01-22 16:53 jgv Assigned To jgv => ifv
2021-01-22 16:53 jgv Status assigned => resolved
2021-01-22 17:05 ifv Note Added: 0098339
2021-01-22 17:05 ifv Assigned To ifv => bugmaster
2021-01-22 17:05 ifv Status resolved => reviewed
2021-01-22 17:30 galbramc Note Added: 0098341
2021-01-22 17:57 jgv Note Added: 0098346
2021-01-22 18:23 galbramc Note Added: 0098352
2021-01-22 18:51 galbramc Note Added: 0098353
2021-01-23 12:51 bugmaster Note Added: 0098378
2021-01-23 12:51 bugmaster Status reviewed => tested
2021-01-23 13:16 bugmaster Test case number => bugs/modalg_7/bug31735_3,bug31845_1,bug31845_2,bug31845_3,bug31845_4,bug31845_f,bug31845_h,bug31845_i
2021-01-23 14:14 bugmaster Changeset attached => occt master 8948e18d
2021-01-23 14:14 bugmaster Status tested => verified
2021-01-23 14:14 bugmaster Resolution open => fixed
2021-01-26 00:43 galbramc Note Added: 0098411
2021-01-26 11:48 jgv Note Added: 0098415
2021-01-26 18:12 galbramc File Added: BRepOffsetAPI_MakeThickSolid.patch
2021-01-26 18:12 galbramc Note Added: 0098424
2021-01-27 14:59 szy Note Added: 0098438
2021-01-27 22:28 galbramc Note Added: 0098451
2021-01-29 13:40 git Note Added: 0098512
2021-02-06 14:29 git Note Added: 0098738
2021-02-20 21:37 kgv Relationship added parent of 0032151