MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031827Open CASCADE[OCCT] OCCT:Samplespublic2020-10-06 15:502020-10-24 12:40
Reporterbugmaster 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0031827: Samples - Qt OCCT Overview sample is not compiled with VS 2010
Descriptionhttp://jenkins-test-11.nnov.opencascade.com/view/OCCT-750-BETA_OCCT-750-BETA/view/SAMPLES/job/OCCT-750-BETA_OCCT-750-BETA-OCCT-Windows-64-VC10-sample-qt/3/parsed_console/ [^]
Steps To Reproducecompile and run OCCTOverview with VS2010 / Qt 4.8.6
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
related to 0031826verifiedasuraven Samples - Qt OCCT Overview sample is not compiled with qt486 
child of 0031570verifiedbugmaster Samples - add Qt samples similar to standard MFC samples 

-  Notes
(0095993)
git (administrator)
2020-10-15 18:19

Branch CR31827 has been created by asuraven.

SHA-1: 0d749ce475aa4220d94063e5f22bfca5dae070e8


Detailed log of new commits:

Author: asuraven
Date: Thu Oct 15 18:23:10 2020 +0300

    # json -> XML menu change
(0095994)
git (administrator)
2020-10-15 18:21

Branch CR31827 has been deleted by asuraven.

SHA-1: 0d749ce475aa4220d94063e5f22bfca5dae070e8
(0095995)
git (administrator)
2020-10-15 18:21

Branch CR31827 has been created by asuraven.

SHA-1: b0ea1b578f7603e02342d3dd5d193ae48886378f


Detailed log of new commits:

Author: asuraven
Date: Thu Oct 15 18:23:10 2020 +0300

    # json -> XML menu change
(0096002)
kgv (developer)
2020-10-15 20:31

-  for (Handle(AIS_InteractiveObject) anAisObject : anAisObjectsList)
+  AIS_ListOfInteractive::Iterator anIter (anAisObjectsList);
+  for (; anIter.More(); anIter.Next())
...
-  for (const Handle(AIS_InteractiveObject) anObject : theObjects)
+
+  NCollection_Vector<Handle(AIS_InteractiveObject)>::Iterator anIter (theObjects);
+  for (; anIter.More(); anIter.Next())

Here an in other places - please put iterator variable into for(;;) header.

-    case CurrentAction3d::DynamicPanning:
+    case DynamicPanning:
...
-      if (sentBy == myViewActions.value(ViewAction::FitArea))
+      if (sentBy == myViewActions.value(FitArea))

Please rename enumeration values to include it's name (e.g. CurrentAction3d_DynamicPanning, ViewAction_FitArea and similar).
(0096060)
git (administrator)
2020-10-19 16:17

Branch CR31827 has been updated by asuraven.

SHA-1: 35d3821581a150a69f51ef5520e10faabcd5c71a


Detailed log of new commits:

Author: asuraven
Date: Mon Oct 19 16:20:59 2020 +0300

    Visualization fixed

(0096063)
git (administrator)
2020-10-19 18:55

Branch CR31827 has been updated by asuraven.

SHA-1: 46dee651fce45555a18002dde3ad8525cef19824


Detailed log of new commits:

Author: asuraven
Date: Mon Oct 19 18:59:14 2020 +0300

    VS2010 warnings excluded

(0096102)
git (administrator)
2020-10-21 13:34

Branch CR31827 has been updated by asuraven.

SHA-1: a5c1708b9b05d4d8ccaaba0a8825aca00cf16872


Detailed log of new commits:

Author: asuraven
Date: Wed Oct 21 13:38:12 2020 +0300

    fix menu texts

(0096105)
git (administrator)
2020-10-21 14:20

Branch CR31827 has been deleted by asuraven.

SHA-1: a5c1708b9b05d4d8ccaaba0a8825aca00cf16872
(0096106)
git (administrator)
2020-10-21 14:20

Branch CR31827 has been created by asuraven.

SHA-1: 3a9a3787fd7162b4c1c5cbfa47288035afa2ed14


Detailed log of new commits:

Author: asuraven
Date: Thu Oct 15 18:23:10 2020 +0300

    0031827: Samples - Qt OCCT Overview sample is not compiled with VS 2010
(0096107)
asuraven (developer)
2020-10-21 14:52

- Issue 31826 (Qt 4.8.6 compatibility) also fixed in this issue.
- Major changes:
  + Menu storage changed from json to XML (because Qt 4 does not support json)
  + C++11 for(object : container) construction changed to OCCT iterators / Qt foreach
  + enum type::name changed to type_name
  + non used class members removed
  + Qt connect functions changed to macros version
  + warning 4127 disabled for Q_INIT_RESOURCE in VS2010 / Qt 4 case
  + widgets parent problem on Qt 4 fixed
  + QRegularExpression changed to QRegExp
- INV confirms that the product compiles without warnings on all platforms
(0096108)
kgv (developer)
2020-10-21 14:57

> - Major changes:
The changes are expected to be put into git commit description.
(0096112)
kgv (developer)
2020-10-21 16:05

Please note that QRegExp (Qt4+) introduced by the patch as alternative to QRegularExpression (Qt5+) for compatibility reasons might be deprecated in Qt6 (but it seems not deprecated yet):
> https://bugreports.qt.io/browse/QTBUG-72974 [^]

+    Handle(AIS_InteractiveObject) anObject = anIter.Value();
...
+    Handle(AIS_InteractiveObject) anAisObject = anIter.Value();

const Handle(AIS_InteractiveObject)&

+  bool namespaceProcessing(false);
+  QString errorMsg; 
+  int errorLine(0);
+  int errorColumn(0);

anErrorMsg, anErrorLine, anErrorColumn, isNamespaceProcessing.
Please also remove redundant trailing spaces.

+#if defined(_MSC_VER) && QT_VERSION < QT_VERSION_CHECK(5, 0, 0)
+__pragma(warning(push))
+__pragma(warning(disable:4127))
+#endif
+  Q_INIT_RESOURCE(OCCTOverview);

Consider replacing with #include <Standard_WarningsDisable.hxx>/#include <Standard_WarningsRestore.hxx> without Qt version check.

-  for (const HighlightingRule& rule : qAsConst(myHighlightingRules))
+  //for
...
-  while (startIndex >= 0)
+  //while (startIndex >= 0)
+  //{

Please remove dead code.
(0096114)
git (administrator)
2020-10-21 16:56

Branch CR31827 has been deleted by asuraven.

SHA-1: 3a9a3787fd7162b4c1c5cbfa47288035afa2ed14
(0096115)
git (administrator)
2020-10-21 16:56

Branch CR31827 has been created by asuraven.

SHA-1: 74b34208cf7fa1f011176331b45f1595070286f2


Detailed log of new commits:

Author: asuraven
Date: Thu Oct 15 18:23:10 2020 +0300

    0031827: Samples - Qt OCCT Overview sample is not compiled with VS 2010
     * Menu storage changed from json to XML (because Qt 4 does not support json)
     * C++11 for(object : container) construction changed to OCCT iterators / Qt foreach
     * enum type::name changed to type_name
     * non used class members removed
     * Qt connect functions changed to macros version
     * warning 4127 disabled for Q_INIT_RESOURCE in VS2010 / Qt 4 case
     * widgets parent problem on Qt 4 fixed
     * QRegularExpression changed to QRegExp
(0096116)
git (administrator)
2020-10-21 18:25

Branch CR31827 has been updated by asuraven.

SHA-1: c0a65162ab11ffe5e714a2cff63f1539cf577441


Detailed log of new commits:

Author: asuraven
Date: Wed Oct 21 18:28:31 2020 +0300

    review fixes

(0096117)
asuraven (developer)
2020-10-21 18:27

All reviewers remarks fixed
(0096120)
kgv (developer)
2020-10-21 19:28

Please manually test updated sample before integration.
(0096138)
git (administrator)
2020-10-22 14:56

Branch CR31827 has been updated by asuraven.

SHA-1: a6295b1740718ad3e6fb2374ee2afd1d1f4e1b05


Detailed log of new commits:

Author: asuraven
Date: Thu Oct 22 15:00:11 2020 +0300

    2d view mouse work fix

(0096141)
kgv (developer)
2020-10-22 15:31

   Qt::MouseButtons aMouseButtons = theEvent->buttons();
   if (!myIs3dView)
   {
-    aMouseButtons |= Qt::LeftButton;
+    aMouseButtons = static_cast<Qt::MouseButtons>(aMouseButtons & (~Qt::LeftButton));
   }

If this code is to prevent 3D Viewer rotation by mouse, then it could be disabled via AIS_ViewController::SetAllowRotation(false) for 2D view.
(0096144)
git (administrator)
2020-10-22 16:12

Branch CR31827 has been updated by asuraven.

SHA-1: f9771aa4c91c518fbbc4b458efc626aea58e7373


Detailed log of new commits:

Author: asuraven
Date: Thu Oct 22 16:15:39 2020 +0300

    Use AIS_ViewController::SetAllowRotation()

(0096195)
bugmaster (administrator)
2020-10-24 12:19

Combination -
OCCT branch : IR-2020-10-23
master SHA - 9f9490e1ae0eaf38507437019a117437c6317225
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-10-23 SHA - 4594c3ef5cc6ec5816231ba88e2a4863a25a06d2
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18000.12000000008 / 18036.38000000013 [-0.20%]
Products
Total CPU difference: 12171.670000000115 / 12174.520000000093 [-0.02%]
Windows-64-VC14:
OCCT
Total CPU difference: 19723.78125 / 19746.3125 [-0.11%]
Products
Total CPU difference: 13538.390625 / 13565.046875 [-0.20%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0096204)
git (administrator)
2020-10-24 12:40

Branch CR31827 has been deleted by inv.

SHA-1: f9771aa4c91c518fbbc4b458efc626aea58e7373

- Related Changesets
occt: master 8833fd4d
Timestamp: 2020-10-15 15:23:10
Author: asuraven
Committer: bugmaster
Details ] Diff ]
0031827: Samples - Qt OCCT Overview sample is not compiled with VS 2010

 * Menu storage changed from json to XML (because Qt 4 does not support json)
 * C++11 for(object : container) construction changed to OCCT iterators / Qt foreach
 * enum type::name changed to type_name
 * non used class members removed
 * Qt connect functions changed to macros version
 * warning 4127 disabled for Q_INIT_RESOURCE in VS2010 / Qt 4 case
 * widgets parent problem on Qt 4 fixed
 * QRegularExpression changed to QRegExp
rm - samples/OCCTOverview/code/DataExchange.json Diff ] File ]
add - samples/OCCTOverview/code/DataExchange.xml Diff ] File ]
mod - samples/OCCTOverview/code/DataExchangeSamples.cxx Diff ] File ]
mod - samples/OCCTOverview/code/DataExchangeSamples.h Diff ] File ]
mod - samples/OCCTOverview/code/FILES Diff ] File ]
rm - samples/OCCTOverview/code/Geometry.json Diff ] File ]
add - samples/OCCTOverview/code/Geometry.xml Diff ] File ]
rm - samples/OCCTOverview/code/Ocaf.json Diff ] File ]
add - samples/OCCTOverview/code/Ocaf.xml Diff ] File ]
mod - samples/OCCTOverview/code/OcafSamples.cxx Diff ] File ]
mod - samples/OCCTOverview/code/OcafSamples.h Diff ] File ]
mod - samples/OCCTOverview/code/Samples.qrc Diff ] File ]
rm - samples/OCCTOverview/code/Topology.json Diff ] File ]
add - samples/OCCTOverview/code/Topology.xml Diff ] File ]
rm - samples/OCCTOverview/code/Triangulation.json Diff ] File ]
add - samples/OCCTOverview/code/Triangulation.xml Diff ] File ]
rm - samples/OCCTOverview/code/Viewer2d.json Diff ] File ]
add - samples/OCCTOverview/code/Viewer2d.xml Diff ] File ]
mod - samples/OCCTOverview/code/Viewer2dSamples.cxx Diff ] File ]
rm - samples/OCCTOverview/code/Viewer3d.json Diff ] File ]
add - samples/OCCTOverview/code/Viewer3d.xml Diff ] File ]
mod - samples/OCCTOverview/code/Viewer3dSamples.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/env.bat Diff ] File ]
mod - samples/qt/OCCTOverview/OCCTOverview.pro Diff ] File ]
mod - samples/qt/OCCTOverview/src/ApplicationCommon.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/ApplicationCommon.h Diff ] File ]
mod - samples/qt/OCCTOverview/src/DocumentCommon.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/GeomWidget.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/Main.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/OcctHighlighter.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/OcctHighlighter.h Diff ] File ]
mod - samples/qt/OCCTOverview/src/OcctWindow.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/View.cxx Diff ] File ]
mod - samples/qt/OCCTOverview/src/View.h Diff ] File ]

- Issue History
Date Modified Username Field Change
2020-10-06 15:50 bugmaster New Issue
2020-10-06 15:50 bugmaster Assigned To => asuraven
2020-10-06 15:50 bugmaster Status new => assigned
2020-10-06 15:53 bugmaster Relationship added related to 0031570
2020-10-06 15:56 kgv Product Version 7.4.0 => 7.5.0
2020-10-06 15:56 kgv Summary Sample: QT Overview sample is not compiled with VS 2010 => Sample - Qt OCCT Overview sample is not compiled with VS 2010
2020-10-07 16:27 kgv Summary Sample - Qt OCCT Overview sample is not compiled with VS 2010 => Samples - Qt OCCT Overview sample is not compiled with VS 2010
2020-10-07 16:27 kgv Relationship replaced child of 0031570
2020-10-15 18:19 git Note Added: 0095993
2020-10-15 18:21 git Note Added: 0095994
2020-10-15 18:21 git Note Added: 0095995
2020-10-15 20:31 kgv Note Added: 0096002
2020-10-19 16:17 git Note Added: 0096060
2020-10-19 18:55 git Note Added: 0096063
2020-10-21 13:34 git Note Added: 0096102
2020-10-21 14:14 asuraven Relationship added related to 0031826
2020-10-21 14:20 git Note Added: 0096105
2020-10-21 14:20 git Note Added: 0096106
2020-10-21 14:52 asuraven Note Added: 0096107
2020-10-21 14:54 asuraven Assigned To asuraven => kgv
2020-10-21 14:54 asuraven Status assigned => resolved
2020-10-21 14:54 asuraven Steps to Reproduce Updated View Revisions
2020-10-21 14:57 kgv Note Added: 0096108
2020-10-21 16:05 kgv Note Added: 0096112
2020-10-21 16:07 kgv Assigned To kgv => asuraven
2020-10-21 16:07 kgv Status resolved => assigned
2020-10-21 16:56 git Note Added: 0096114
2020-10-21 16:56 git Note Added: 0096115
2020-10-21 18:25 git Note Added: 0096116
2020-10-21 18:27 asuraven Note Added: 0096117
2020-10-21 18:27 asuraven Assigned To asuraven => kgv
2020-10-21 18:27 asuraven Status assigned => resolved
2020-10-21 19:28 kgv Note Added: 0096120
2020-10-21 19:28 kgv Assigned To kgv => bugmaster
2020-10-21 19:28 kgv Status resolved => reviewed
2020-10-22 14:56 git Note Added: 0096138
2020-10-22 15:31 kgv Note Added: 0096141
2020-10-22 16:12 git Note Added: 0096144
2020-10-24 12:19 bugmaster Note Added: 0096195
2020-10-24 12:19 bugmaster Status reviewed => tested
2020-10-24 12:26 bugmaster Test case number => Not required
2020-10-24 12:30 bugmaster Changeset attached => occt master 8833fd4d
2020-10-24 12:30 bugmaster Status tested => verified
2020-10-24 12:30 bugmaster Resolution open => fixed
2020-10-24 12:40 git Note Added: 0096204


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker