MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031820Open CASCADE[OCCT] OCCT:Testspublic2020-10-03 12:432020-10-08 11:01
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0031820: Tests - "dlog get" skips last exception when calling 'test" with echo OFF
DescriptionCalling test command with echo parameter OFF leads to no last exception in [dlog get] output and incorrect test result interpretation (e.g. SKIPPED does not work).
Steps To ReproduceModify test or environment to make data file "DejaVuSansMono.ttf" unavailable.
- testgrid 3rdparty fonts A2
  OK, works as expected - Tcl exception in HTML log and SKIPPED status.
- test 3rdparty fonts A2 1
  OK, works as expected - Tcl exception appears in RED color in a terminal.
- test 3rdparty fonts A2
  KO, test reports FAILED state and [dlog get] shows no Tcl exception in log.
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
child of 0031731verifiedkgv Draw Harness - colorize errors and exception messages 

-  Notes
(0095619)
git (administrator)
2020-10-03 12:45

Branch CR31820 has been created by kgv.

SHA-1: 4aa5d0371da7d3b240b83640b5b1c692e09541a8


Detailed log of new commits:

Author: kgv
Date: Sat Oct 3 12:48:19 2020 +0300

    0031820: Tests - "dlog get" skips last exception when calling 'test" with echo OFF
    
    Added missing puts to "test" command.
(0095620)
kgv (developer)
2020-10-03 12:45

Patch has been pushed to OCCT branch CR31820 - checked locally (Jenkins test have not been started yet).
(0095705)
git (administrator)
2020-10-04 21:50

Branch CR31820 has been updated by abv.

SHA-1: 7b31face513a455c72cdf3df87b0167dcd602beb


Detailed log of new commits:

Author: abv
Date: Sun Oct 4 21:54:03 2020 +0300

    # revise code to localize processing of exception

(0095706)
git (administrator)
2020-10-04 21:53

Branch CR31820 has been updated forcibly by abv.

SHA-1: 6ec37832b77f21dc0022a6e9175d27b8f3cce655
(0095707)
abv (manager)
2020-10-04 22:47

Reviewed with minor correction, please integrate. Jenkins testing is not needed because the patch is related to situation when some data files are missing.
(0095780)
bugmaster (administrator)
2020-10-07 15:58

Combination -
OCCT branch : OCCT-750-BETA
master SHA - 278da162dc52c26c8cfe9d002a6f07db12405194
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : OCCT-750-BETA SHA - d9c364e1137eed3249e5a05befa860c708f243c0
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18038.89000000012 / 18085.73000000008 [-0.26%]
Products
Total CPU difference: 12182.170000000115 / 12217.490000000116 [-0.29%]
Windows-64-VC14:
OCCT
Total CPU difference: 19726.21875 / 19713.9375 [+0.06%]
Products
Total CPU difference: 13586.625 / 13579.390625 [+0.05%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0095799)
git (administrator)
2020-10-08 11:01

Branch CR31820 has been deleted by inv.

SHA-1: 6ec37832b77f21dc0022a6e9175d27b8f3cce655

- Related Changesets
occt: master afe3ff9a
Timestamp: 2020-10-03 09:48:19
Author: kgv
Committer: bugmaster
Details ] Diff ]
0031820: Tests - "dlog get" skips last exception when calling 'test" with echo OFF

Added missing puts to "test" command.
mod - src/DrawResources/TestCommands.tcl Diff ] File ]

- Issue History
Date Modified Username Field Change
2020-10-03 12:43 kgv New Issue
2020-10-03 12:43 kgv Assigned To => kgv
2020-10-03 12:45 git Note Added: 0095619
2020-10-03 12:45 kgv Note Added: 0095620
2020-10-03 12:45 kgv Assigned To kgv => abv
2020-10-03 12:45 kgv Status new => resolved
2020-10-03 12:47 kgv Relationship added child of 0031731
2020-10-04 21:50 git Note Added: 0095705
2020-10-04 21:53 git Note Added: 0095706
2020-10-04 22:47 abv Note Added: 0095707
2020-10-04 22:47 abv Assigned To abv => bugmaster
2020-10-04 22:47 abv Status resolved => reviewed
2020-10-05 13:15 bugmaster Test case number => Not required
2020-10-07 15:58 bugmaster Note Added: 0095780
2020-10-07 15:58 bugmaster Status reviewed => tested
2020-10-07 16:17 bugmaster Changeset attached => occt master afe3ff9a
2020-10-07 16:17 bugmaster Status tested => verified
2020-10-07 16:17 bugmaster Resolution open => fixed
2020-10-08 11:01 git Note Added: 0095799


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker