MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031807Community[OCCT] OCCT:Application Frameworkpublic2020-09-30 11:582020-09-30 18:52
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0031807: TDocStd_Application::Open (const TCollection_ExtendedString&,...) crash in non-main thread
DescriptionPCDM_ReaderStatus TDocStd_Application::Open (const TCollection_ExtendedString& path,
                                          Handle(TDocStd_Document)& aDoc,
                                          const Message_ProgressRange& theRange = Message_ProgressRange());

Open function with file path crashes in non-main thread different from TDocStd_Application. It works in main thread.

The stream interface works well even in non-main thread.

Tested in OCCT 7.5 dev main source.
Steps To ReproduceSame as in 31785
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0031785verifiedbugmaster Open CASCADE [REGRESSION] Application Framework - application crashes on reading XBF document in background thread 

-  Notes
(0095489)
kgv (developer)
2020-09-30 12:49
edited on: 2020-09-30 12:50

Vico,

could you please confirm that you have the problem on actual master (IR-2020-09-25, see 0031785) and not on the previous two weeks master?

(0095497)
Vico Liang (developer)
2020-09-30 15:47

Dear KGV,

I just updated to the latest master, it works. Thanks for your reply on this. It is a duplication of 0031785. It's fixed. Please close this.
(0095499)
mpv (developer)
2020-09-30 15:51

  Dear bugmaster,
Please, close this issue.

- Issue History
Date Modified Username Field Change
2020-09-30 11:58 Vico Liang New Issue
2020-09-30 11:58 Vico Liang Assigned To => mpv
2020-09-30 12:36 mpv Relationship added duplicate of 0031785
2020-09-30 12:49 kgv Note Added: 0095489
2020-09-30 12:50 kgv Note Edited: 0095489 View Revisions
2020-09-30 15:47 Vico Liang Note Added: 0095497
2020-09-30 15:51 mpv Note Added: 0095499
2020-09-30 15:51 mpv Assigned To mpv => bugmaster
2020-09-30 15:51 mpv Status new => resolved
2020-09-30 15:51 mpv Steps to Reproduce Updated View Revisions
2020-09-30 15:51 mpv Status resolved => reviewed
2020-09-30 18:52 bugmaster Status reviewed => closed
2020-09-30 18:52 bugmaster Resolution open => fixed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker