View Issue Details

IDProjectCategoryView StatusLast Update
0031781Open CASCADEOCCT:Modeling Algorithmspublic2020-12-02 17:13
Reporterbugmaster Assigned Toifv  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
PlatformVS 2019 
Product Version7.4.0 
Target Version7.5.0Fixed in Version7.5.0 
Summary0031781: Modeling Algorithms - ChFi3d_Builder throws an exception when built with Visual Studio 2019
DescriptionTutorial Qt crashes on try to execute MakeBottle operation.
Problem is reproduces on VS 2019 only
TagsNo tags attached.
Test case number

Relationships

related to 0031782 closedbugmaster Modeling Algorithms - Regressions on VS 2019 (vc142) on fillet tests 
related to 0031821 closedbugmaster Coding - Uninitialized variables in TKFillet project 
child of 0031806 newbugmaster Configuration - Visual Studio 2019 bugs 

Activities

kgv

2020-09-24 20:16

developer   ~0095291

Ilya, could you please reproduce scenario and localize the problem?

kgv

2020-09-30 10:12

developer   ~0095479

Last edited: 2020-09-30 10:20

Based on the current analysis, ChFi3d_Builder::Compute() throws an exception while calling PerformFilletOnVertex(),
which is catched and leads to `done` flag being set to FALSE: method ProjLib_CompProjectedCurve::D0(), line:
 if (!found) throw Standard_DomainError("ProjLib_CompProjectedCurve::D0");

As a consequence, calling method `BRepBuilderAPI_MakeShape::Shape()` raises another exception that shape is not done.

The issue doesn't happen in Debug build and with optimization level set to 0 (Ob0).
Based on the current analysis, the issue might be caused by a bug in Visual Studio 2019 optimizer.

kgv

2020-09-30 10:17

developer   ~0095480

Might be duplicate or similar to 0031782.

Issue History

Date Modified Username Field Change
2020-09-19 14:56 bugmaster New Issue
2020-09-19 14:56 bugmaster Assigned To => kgv
2020-09-19 14:58 bugmaster Summary Samples: Tutorial QT crashed on try to execute MakeBottle operation => Samples: Tutorial QT is crashed on try to execute MakeBottle operation
2020-09-19 14:58 bugmaster Status new => assigned
2020-09-19 15:32 kgv Relationship added related to 0031628
2020-09-19 15:32 kgv Summary Samples: Tutorial QT is crashed on try to execute MakeBottle operation => Samples - Tutorial Qt crashes on try to execute MakeBottle operation
2020-09-21 17:23 kgv Relationship added related to 0031782
2020-09-24 20:16 kgv Assigned To kgv => iko
2020-09-24 20:16 kgv Note Added: 0095291
2020-09-30 10:06 kgv Relationship added child of 0031806
2020-09-30 10:06 kgv Assigned To iko => tizmaylo
2020-09-30 10:06 kgv Assigned To tizmaylo => kgv
2020-09-30 10:12 kgv Note Added: 0095479
2020-09-30 10:12 kgv Note Edited: 0095479
2020-09-30 10:13 kgv Note Edited: 0095479
2020-09-30 10:15 kgv Summary Samples - Tutorial Qt crashes on try to execute MakeBottle operation => Modeling Algorithms - ChFi3d_Builder throws an exception when build with Visual Studio 2019
2020-09-30 10:15 kgv Assigned To kgv => msv
2020-09-30 10:15 kgv Category OCCT:Samples => OCCT:Modeling Algorithms
2020-09-30 10:15 kgv Target Version 7.5.0 => 7.6.0
2020-09-30 10:16 kgv Summary Modeling Algorithms - ChFi3d_Builder throws an exception when build with Visual Studio 2019 => Modeling Algorithms - ChFi3d_Builder throws an exception when built with Visual Studio 2019
2020-09-30 10:17 kgv Description Updated
2020-09-30 10:17 kgv Note Added: 0095480
2020-09-30 10:18 kgv Relationship deleted related to 0031628
2020-09-30 10:20 kgv Note Edited: 0095479
2020-10-02 19:41 abv Target Version 7.6.0 => 7.5.0
2020-10-05 09:40 tizmaylo Relationship added related to 0031821
2020-10-13 09:56 msv Assigned To msv => jgv
2020-10-16 16:57 utverdov Assigned To jgv => ifv
2020-10-26 18:02 bugmaster Status assigned => verified
2020-10-26 18:02 bugmaster Resolution open => fixed
2020-12-02 16:22 emo Fixed in Version => 7.5.0
2020-12-02 17:13 emo Status verified => closed