MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031635Open CASCADE[OCCT] OCCT:Documentationpublic2020-06-28 13:272020-07-04 12:52
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityintegration request 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0031635: Documentation - minor clean-up of User Guide for Foundation Classes module
DescriptionIt is desired to clean up User Guides text from minor mistakes / misprints / old or non-existing OCCT classes.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot required
Attached Filesdocx file icon 31635_remarks.docx (262,802 bytes) 2020-07-01 18:52

- Relationships
child of 0031634newkgv Documentation - minor clean-up of User Guides from misprints and old classes 

-  Notes
(0092819)
git (administrator)
2020-06-28 18:10

Branch CR31635 has been created by kgv.

SHA-1: ed000b9efea9e210ca0a4db1d4dbd163f2c97004


Detailed log of new commits:

Author: kgv
Date: Fri Jun 26 23:49:48 2020 +0300

    0031635: Documentation - minor clean-up of User Guide for Foundation Classes module
    
    Changes in Technical Overview.
    Corrected reference of "Mesh" as dedicated module, which is actually a Toolkit within "Modeling Algorithms" module.
    Reduced references to "Configurable optimized memory manager",
    which has not been updated for a long time and no more encouraged to be used as replacement of standard memory allocator of C library.
    VRML/STL converters have been moved from section Mesh to Data Exchange.
    Visualization chapter has been slightly reworded and reordered;
    added references to PBR metallic-roughness material model.
    Data Exchange chapter - reworded sentence "The exchanges run smoothly regardless of the quality of external data..."
    to "This module handles various problems of interoperability between CAD systems...";
    added AP242 to the list of STEP capabilities.
    
    Removed references to "physical quantities" in package Quanity, deprecated since 0028799 and not actually used anywhere.
    Adjusted description of string classes to avoid duplicated statements.
    Collections section has been refactored to replace obsolete TCollection references by NCollection.
    Remove obsolete statement "furthermore *catch()* statement does not allow passing exception object as argument".
    
    Fixed broken nested enumeration in a couple of places.
    Fixed usage of inappropriate quote symbols in code snippets.
    Fixed references to non-existing classes like ZeroDivide instead of Standard_DivideByZero.
    Removed suggested usage of Standard_Failure::Raise() instead of "throw Standard_Failure()" following 0026937.
    Code snippets now suggest "catch(const Standard_Failure& )" instead of "catch(Standard_Failure )" (0026937).
    Fixed broken code snippets with lost symbols like <<.
    
    Cosmetics: removed numerous trailing spaces, double spaces.
    Added missing {.cpp} language qualifier to code quotations.
    Sentences within paragraphs have been split into multiple lines in source file.
(0092820)
kgv (developer)
2020-06-28 18:12

Patch is ready for review in OCCT branch CR31635.
(0092821)
git (administrator)
2020-06-28 18:13

Branch CR31635 has been updated forcibly by kgv.

SHA-1: 625ae3f6a62db6c0031b949d5f8791737876335d
(0092867)
nds (developer)
2020-07-01 18:54

Dear Kirill,

please, have a look at attached document. May be there's something to change inside this issue or skip/postpone.

Best regards, Natalia
(0092868)
git (administrator)
2020-07-01 21:11

Branch CR31635 has been updated by kgv.

SHA-1: b8ce7711e2c5726ff2fe34e54468292b477072f1


Detailed log of new commits:

Author: kgv
Date: Wed Jul 1 21:12:51 2020 +0300

    # applying remarks

(0092869)
kgv (developer)
2020-07-01 21:11
edited on: 2020-07-01 21:11

> 1. having toolkit and module on the same level in the list;
Moved to another level.

> 1. on the image toolkit has the same color/style/size as parent module.
Blue color on the image indicates "Open" component in legenda.
I think that reworking this image is subject for another bug.

> 2. It’s not clear what is the grammar base of the sentence (never find the verb)
The section has been reworked.

> 3. The presentations can be customized to take
Removed

> 4. AP242 - not whole functionality is supported, isn’t it?
This list describes the key objective of specific AP version, not the part implemented by OCCT.
In some contexts AP242 is desribed as "Managed Model Based 3D Engineering" - dunno if this description should be added.

> 5. Now, we have no CDL or WOK. Why the user need to read/think about them here?
Reworded to remove mentioning of CDL/WOK.

> 6. The caption tells which container is described.
Remove a couple of occurences.

> 7. may be let’s say: ”OCCT provides …”
Applied

> 8. Maps serve to describe a combination key to value,
Reworded.

> 9. Caption “Collection of maps” inside the “Maps” is not clear.
Redundant chapters have been merged and filtered.

> 10. Init, More, Next, Value are not very accented/visible/pointed here
Replaced by table.

> 11. Some packages might define a dedicated Iterator classes like
This code is still used in OCCT API and not replaced by ::Iterator analogs.
So that it might be helpful to user to know the difference.
Notice has been removed, as proposed.

> 12. BVH_Tree description is absent (link to outside description is also absent)
Shared documentation has been built without C++ classes references - so that in real documentation it will have an URL to class.
BVH_Tree requires a more comprehensive description, similar to UBTree, which is a good subject of another issue.
In this modification, I have tried to structure collections into distinguishable groups,
and it is difficult to omit BVH_Tree from the list of acceleration structures, even if it does not have yet a good description.

> 13. What containers are mentioned below?
Section has been truncated.

(0092885)
git (administrator)
2020-07-02 10:42

Branch CR31635 has been updated forcibly by kgv.

SHA-1: 1b4c3d777a1a1007b25343c81923a418e6226ea8
(0092887)
git (administrator)
2020-07-02 11:25

Branch CR31635 has been updated forcibly by kgv.

SHA-1: b01c77e0fdbbc157df44c22204a80da7238571db
(0092888)
git (administrator)
2020-07-02 11:51

Branch CR31635_1 has been created by kgv.

SHA-1: badaa87ae2e0063973e29827bac6b99530f8d823


Detailed log of new commits:

Author: kgv
Date: Fri Jun 26 23:49:48 2020 +0300

    0031635: Documentation - minor clean-up of User Guide for Foundation Classes module
    
    Changes in Technical Overview:
    Corrected reference of "Mesh" as dedicated module, which is actually a Toolkit within "Modeling Algorithms" module.
    Reduced references to "Configurable optimized memory manager",
    which has not been updated for a long time and no more encouraged to be used as replacement of standard memory allocator of C library.
    VRML/STL converters have been moved from section Mesh to Data Exchange.
    Visualization chapter has been slightly reworded and reordered;
    added references to PBR metallic-roughness material model.
    Data Exchange chapter - reworded sentence "The exchanges run smoothly regardless of the quality of external data..."
    to "This module handles various problems of interoperability between CAD systems...";
    added AP242 to the list of STEP capabilities.
    
    Changes in User Guide for Foundation Classes:
    Removed references to "physical quantities" in package Quanity, deprecated since 0028799 and not actually used anywhere.
    Adjusted description of string classes to avoid duplicated statements.
    Collections section has been refactored to replace obsolete TCollection references by NCollection.
    Remove obsolete statement "furthermore *catch()* statement does not allow passing exception object as argument".
    
    Fixed broken nested enumeration in a couple of places.
    Fixed usage of inappropriate quote symbols in code snippets.
    Fixed references to non-existing classes like ZeroDivide instead of Standard_DivideByZero.
    Removed suggested usage of Standard_Failure::Raise() instead of "throw Standard_Failure()" following 0026937.
    Code snippets now suggest "catch(const Standard_Failure& )" instead of "catch(Standard_Failure )" (0026937).
    Fixed broken code snippets with lost symbols like <<.
    
    Cosmetics: removed numerous trailing spaces, double spaces.
    Added missing {.cpp} language qualifier to code quotations.
    Sentences within paragraphs have been split into multiple lines in source file.
(0092889)
nds (developer)
2020-07-02 12:10

Branches for integration:

OCCT – CR31635_1
Products – NOT
(0092947)
bugmaster (administrator)
2020-07-04 12:13

Combination -
OCCT branch : IR-2020-07-03
master SHA - 8f5760bc1679b45691fe8ac5fff1a4e978524009
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-07-03 SHA - 715997b86e7db13b7a7ddd1f26bab717621d84ec
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17174.900000000107 / 17168.64000000016 [+0.04%]
Products
Total CPU difference: 11226.760000000077 / 11202.250000000082 [+0.22%]
Windows-64-VC14:
OCCT
Total CPU difference: 18704.34375 / 18712.96875 [-0.05%]
Products
Total CPU difference: 13043.15625 / 13084.109375 [-0.31%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0092962)
git (administrator)
2020-07-04 12:52

Branch CR31635_1 has been deleted by inv.

SHA-1: badaa87ae2e0063973e29827bac6b99530f8d823
(0092963)
git (administrator)
2020-07-04 12:52

Branch CR31635 has been deleted by inv.

SHA-1: b01c77e0fdbbc157df44c22204a80da7238571db

- Related Changesets
occt: master 8b742dc1
Timestamp: 2020-06-26 20:49:48
Author: kgv
Committer: bugmaster
Details ] Diff ]
0031635: Documentation - minor clean-up of User Guide for Foundation Classes module

Changes in Technical Overview:
Corrected reference of "Mesh" as dedicated module, which is actually a Toolkit within "Modeling Algorithms" module.
Reduced references to "Configurable optimized memory manager",
which has not been updated for a long time and no more encouraged to be used as replacement of standard memory allocator of C library.
VRML/STL converters have been moved from section Mesh to Data Exchange.
Visualization chapter has been slightly reworded and reordered;
added references to PBR metallic-roughness material model.
Data Exchange chapter - reworded sentence "The exchanges run smoothly regardless of the quality of external data..."
to "This module handles various problems of interoperability between CAD systems...";
added AP242 to the list of STEP capabilities.

Changes in User Guide for Foundation Classes:
Removed references to "physical quantities" in package Quanity, deprecated since 0028799 and not actually used anywhere.
Adjusted description of string classes to avoid duplicated statements.
Collections section has been refactored to replace obsolete TCollection references by NCollection.
Remove obsolete statement "furthermore *catch()* statement does not allow passing exception object as argument".

Fixed broken nested enumeration in a couple of places.
Fixed usage of inappropriate quote symbols in code snippets.
Fixed references to non-existing classes like ZeroDivide instead of Standard_DivideByZero.
Removed suggested usage of Standard_Failure::Raise() instead of "throw Standard_Failure()" following 0026937.
Code snippets now suggest "catch(const Standard_Failure& )" instead of "catch(Standard_Failure )" (0026937).
Fixed broken code snippets with lost symbols like <<.

Cosmetics: removed numerous trailing spaces, double spaces.
Added missing {.cpp} language qualifier to code quotations.
Sentences within paragraphs have been split into multiple lines in source file.
mod - dox/technical_overview/technical_overview.md Diff ] File ]
mod - dox/user_guides/foundation_classes/foundation_classes.md Diff ] File ]

- Issue History
Date Modified Username Field Change
2020-06-28 13:27 kgv New Issue
2020-06-28 13:27 kgv Assigned To => kgv
2020-06-28 13:28 kgv Relationship added child of 0031634
2020-06-28 18:10 git Note Added: 0092819
2020-06-28 18:12 kgv Note Added: 0092820
2020-06-28 18:12 kgv Assigned To kgv => nds
2020-06-28 18:12 kgv Status new => resolved
2020-06-28 18:13 git Note Added: 0092821
2020-07-01 18:52 nds File Added: 31635_remarks.docx
2020-07-01 18:54 nds Note Added: 0092867
2020-07-01 18:54 nds Assigned To nds => kgv
2020-07-01 18:54 nds Status resolved => assigned
2020-07-01 21:11 git Note Added: 0092868
2020-07-01 21:11 kgv Note Added: 0092869
2020-07-01 21:11 kgv Note Edited: 0092869 View Revisions
2020-07-01 21:11 kgv Assigned To kgv => nds
2020-07-01 21:11 kgv Status assigned => resolved
2020-07-02 10:42 git Note Added: 0092885
2020-07-02 11:25 git Note Added: 0092887
2020-07-02 11:51 git Note Added: 0092888
2020-07-02 12:10 nds Note Added: 0092889
2020-07-02 12:10 nds Assigned To nds => bugmaster
2020-07-02 12:10 nds Status resolved => reviewed
2020-07-04 12:13 bugmaster Note Added: 0092947
2020-07-04 12:13 bugmaster Status reviewed => tested
2020-07-04 12:16 bugmaster Test case number => Not required
2020-07-04 12:23 bugmaster Changeset attached => occt master 8b742dc1
2020-07-04 12:23 bugmaster Status tested => verified
2020-07-04 12:23 bugmaster Resolution open => fixed
2020-07-04 12:52 git Note Added: 0092962
2020-07-04 12:52 git Note Added: 0092963


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker