MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031623Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2020-06-22 09:412021-04-13 15:04
Reportersnn 
Assigned Tosnn 
PrioritynormalSeverityminor 
StatusfeedbackResolutionunable to reproduce 
PlatformOSOS Version
Product Version[OCCT] 7.4.0 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0031623: Modeling Algorithms - BRepExtrema_DistShapeShape crashes at distance computing
DescriptionThe crash takes place in Extrema_ExtCC::PrepareResults.
In the code below is expected that ExtPCir has at least one extrema, but it is really 0.
        Extrema_ExtPElC ExtPCir(aPCirc2,
                                Extrema_CurveTool::Circle(((Adaptor3d_Curve) myC[0])),
                                Precision::Confusion(), theUt11, theUt12);
        Standard_Real aMinSqD = ExtPCir.SquareDistance(1);

I failed to reproduce the issue on a smaller model with extracted parts of interest only.
Steps To Reproduce1. Open model \\master\projects\DMU_Reviewer\test_files\Engine V Twin Revision 02.xbf
2. Select parts as it is shown in the attached picture
3. Call BRepExtrema_DistShapeShape for the selected shapes
TagsNo tags attached.
Test case number
Attached Filespng file icon Parts_to_select_1.PNG (322,280 bytes) 2020-09-15 12:21
? file icon Engine V Twin Revision 02 - 2tubes.STEP (46,086 bytes) 2021-03-16 12:40

- Relationships

-  Notes
(0099583)
ifv (developer)
2021-03-18 16:23

Analysis
(0099653)
ifv (developer)
2021-03-22 17:14

Debugging
(0099739)
ifv (developer)
2021-03-25 16:25

Debugging
(0099740)
ifv (developer)
2021-03-25 16:32

Bug is not reproducible on OCCT 7.4.0 and current master.
Analysis is done with help of Draw commands:
XOpen - for reading *.xbf file
XGetOneShape and XGetFreeShapes - to get shapes from document
distmini - to call BRepExtrema_DistShapeShape
(0099741)
kgv (developer)
2021-03-25 17:00
edited on: 2021-03-25 17:00

> Bug is not reproducible on OCCT 7.4.0
It doesn't look like the bug being reported for some older OCCT version.

Dear Sergey, please specify OCCT version with the bug ("Product Version") / provide more details for reproducing.

(0100281)
snn (developer)
2021-04-13 15:04

This bug is not reproduced in the target application (DMU Reviewer) after moving to OCCT 7.5.1.

- Issue History
Date Modified Username Field Change
2020-06-22 09:41 snn New Issue
2020-06-22 09:41 snn Assigned To => msv
2020-06-22 09:41 snn File Added: Parts_to_select.PNG
2020-09-15 11:54 msv Assigned To msv => szy
2020-09-15 11:54 msv Target Version 7.5.0 => 7.6.0*
2020-09-15 11:58 msv Summary BRepExtrema_DistShapeShape crashes at distance computing => Modeling Algorithms - BRepExtrema_DistShapeShape crashes at distance computing
2020-09-15 12:21 snn File Added: Parts_to_select_1.PNG
2020-09-15 12:23 msv File Deleted: Parts_to_select.PNG
2020-12-28 14:40 szy Assigned To szy => aavtamon
2021-03-16 12:40 snn File Added: Engine V Twin Revision 02 - 2tubes.STEP
2021-03-18 16:23 ifv Note Added: 0099583
2021-03-22 17:14 ifv Note Added: 0099653
2021-03-25 16:25 ifv Note Added: 0099739
2021-03-25 16:32 ifv Note Added: 0099740
2021-03-25 16:32 ifv Assigned To aavtamon => szy
2021-03-25 16:32 ifv Status new => resolved
2021-03-25 17:00 kgv Note Added: 0099741
2021-03-25 17:00 kgv Assigned To szy => snn
2021-03-25 17:00 kgv Status resolved => feedback
2021-03-25 17:00 kgv Note Edited: 0099741 View Revisions
2021-03-25 17:01 kgv Resolution open => unable to reproduce
2021-03-25 17:01 kgv Product Version => 7.4.0
2021-04-13 15:04 snn Note Added: 0100281


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker