MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031562Community[OCCT] OCCT:Meshpublic2020-05-14 05:122020-10-08 11:02
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0031562: Mesh - A surface mesh failure
DescriptionThe uploaded file surface-mesh-issue.brep can't be visualized correctly.It seems a meshing issue.
Steps To Reproduce
restore surface-mesh-issue.brep a
checkshape a
fixshape a a
checkshape a
vinit
vsetdispmode 1
vdisplay a
TagsNo tags attached.
Test case numberbugs modalg_7 bug31652
Attached Files? file icon surface-mesh-issue.brep (6,484 bytes) 2020-05-14 05:12
png file icon surface-mesh-issue.png (10,805 bytes) 2020-05-14 05:12
png file icon fixed_mesh_issue.png (26,994 bytes) 2020-05-14 12:14

- Relationships

-  Notes
(0092108)
oan (developer)
2020-05-14 12:13

Hello Vico,

aforementioned shape contains numerous faulties according to checkshape:

On Shape faulty_1 :
BRepCheck_UnorientableShape
Shape faulty_2 on shape faulty_1 :
BRepCheck_NoCurveOnSurface
Shape faulty_3 on shape faulty_1 :
BRepCheck_NoCurveOnSurface
On Shape faulty_4 :
BRepCheck_UnorientableShape
Shape faulty_5 on shape faulty_4 :
BRepCheck_NoCurveOnSurface
Shape faulty_6 on shape faulty_4 :
BRepCheck_NoCurveOnSurface

Faulty shapes in variables faulty_1 to faulty_6

As far as BRepMesh relies on valid input, this is actually the cause of the described issue.

It could easily be fixed by calling fixshape functionality, e.g.:
restore surface-mesh-issue.brep a
checkshape a
fixshape a a
checkshape a
vinit
vsetdispmode 1
vdisplay a

Best regards,
Oleg.
(0092162)
Vico Liang (developer)
2020-05-15 19:48

Hello Oleg,

I see that it might be a bug of the modeling algorithm which produce this invalid shape.Thanks for checking this.Please close this issue.

Best regards.
(0092225)
oan (developer)
2020-05-18 12:14

Dear Bugmaster,

Please add test case and close the issue.
(0094969)
bugmaster (administrator)
2020-09-17 17:11

Please review
(0094970)
git (administrator)
2020-09-17 17:12
edited on: 2020-09-17 17:13

Branch CR31562 has been created by inv.

SHA-1: 7ad6c7ed257a99528636079226d0617b0e1e5a0f

(0094976)
msv (developer)
2020-09-17 19:54

This test case is not interesting to be placed in the base.
(0095813)
git (administrator)
2020-10-08 11:02

Branch CR31562 has been deleted by inv.

SHA-1: 7ad6c7ed257a99528636079226d0617b0e1e5a0f

- Issue History
Date Modified Username Field Change
2020-05-14 05:12 Vico Liang New Issue
2020-05-14 05:12 Vico Liang Assigned To => oan
2020-05-14 05:12 Vico Liang File Added: surface-mesh-issue.brep
2020-05-14 05:12 Vico Liang File Added: surface-mesh-issue.png
2020-05-14 12:13 oan Note Added: 0092108
2020-05-14 12:13 oan Assigned To oan => Vico Liang
2020-05-14 12:13 oan Status new => feedback
2020-05-14 12:14 oan File Added: fixed_mesh_issue.png
2020-05-14 12:14 oan File Deleted: fixed_mesh_issue.png
2020-05-14 12:14 oan File Added: fixed_mesh_issue.png
2020-05-15 19:48 Vico Liang Note Added: 0092162
2020-05-16 16:24 Vico Liang Assigned To Vico Liang => oan
2020-05-18 12:13 oan Steps to Reproduce Updated View Revisions
2020-05-18 12:14 oan Note Added: 0092225
2020-05-18 12:14 oan Assigned To oan => bugmaster
2020-05-18 12:14 oan Status feedback => assigned
2020-06-04 15:11 kgv Summary A surface mesh failure => Mesh - A surface mesh failure
2020-06-04 15:11 kgv Steps to Reproduce Updated View Revisions
2020-09-17 17:10 bugmaster Test case number => bugs modalg_7 bug31652
2020-09-17 17:11 bugmaster Note Added: 0094969
2020-09-17 17:11 bugmaster Assigned To bugmaster => msv
2020-09-17 17:11 bugmaster Status assigned => resolved
2020-09-17 17:12 git Note Added: 0094970
2020-09-17 17:13 bugmaster Note Edited: 0094970 View Revisions
2020-09-17 17:13 bugmaster Note Edited: 0094970 View Revisions
2020-09-17 19:54 msv Note Added: 0094976
2020-09-17 19:54 msv Assigned To msv => bugmaster
2020-09-17 19:54 msv Status resolved => feedback
2020-09-18 10:42 bugmaster Status feedback => closed
2020-09-18 10:42 bugmaster Resolution open => no change required
2020-10-08 11:02 git Note Added: 0095813


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker