MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031550Community[OCCT] OCCT:Data Exchangepublic2020-05-06 15:192020-09-10 15:12
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.4.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0031550: Data Exchange, STEP Import - surface transparency is ignored (SURFACE_STYLE_TRANSPARENT)
DescriptionSURFACE_STYLE_TRANSPARENT entity is ignored by STEP reader leading to translucent entities like building windows being displayed as opaque.

The entity might look like this:
#7612=PRESENTATION_LAYER_ASSIGNMENT('61','Layer 61',(#7611));
#7613=COLOUR_RGB('',0.6,0.4,0.4);
#7614=FILL_AREA_STYLE_COLOUR('',#7613);
#7615=FILL_AREA_STYLE('',(#7614));
#7616=SURFACE_STYLE_FILL_AREA(#7615);
#7617=SURFACE_STYLE_TRANSPARENT(0.7);
#7618=SURFACE_STYLE_RENDERING_WITH_PROPERTIES(.NORMAL_SHADING.,#7613,(#7617));
#7619=SURFACE_SIDE_STYLE('',(#7616,#7618));
#7620=SURFACE_STYLE_USAGE(.BOTH.,#7619);
#7621=PRESENTATION_STYLE_ASSIGNMENT((#7620));
#7622=STYLED_ITEM('',(#7621),#7611)
Steps To ReproduceExisting test case using within non-zero SURFACE_STYLE_TRANSPARENT (screenshot is not created by test).
test bugs xde bug29525 1
vinit View1
XDisplay -dispMode 1 D
vfit
TagsNo tags attached.
Test case numberbugs/step/bug31550
Attached Filespng file icon stp_transp_nist_KO.png (112,403 bytes) 2020-05-06 15:19
7z file icon nist_ftc_08_asme1_ap242-1.7z (154,519 bytes) 2020-05-06 15:20

- Relationships
related to 0023037assignedgka Data Exchange - support different materials and transparency in XDE 

-  Notes
(0092215)
git (administrator)
2020-05-17 17:32

Branch CR31550 has been created by Igor.

SHA-1: 36b94cb5e428b79f6261024d0680e5525b3bada2


Detailed log of new commits:

Author: Igor Khozhanov
Date: Sun May 17 17:32:19 2020 +0300

    Implemented reading and writing of the surface transparency to/from step files
(0092228)
git (administrator)
2020-05-18 13:13

Branch CR31550 has been updated forcibly by Igor.

SHA-1: 1c135cb56402944f282b2222a7a330120aedbd51
(0092229)
Igor (developer)
2020-05-18 13:21

test bugs step bug31550
(0092230)
Igor (developer)
2020-05-18 13:29
edited on: 2020-05-18 14:34

Dear Galina, please review branch CR31550

(0092233)
gka (developer)
2020-05-18 14:32

Branch CR31550 was reviewed
(0092234)
ika (developer)
2020-05-18 15:04
edited on: 2020-05-18 15:06

Dear Igor,

// Created by: igor
I think such autogenerated line in stamps of new files doesn't look good. Could you please replace it with Name SURNAME?
After these changes please assign the issue to me, I will start auto testing.

(0092235)
git (administrator)
2020-05-18 15:35

Branch CR31550 has been updated forcibly by Igor.

SHA-1: 6b3998d783b0b735520a0a556ccfc63a4329e4b9
(0092236)
kgv (developer)
2020-05-18 15:53
edited on: 2020-05-18 15:53

--- /dev/null
+++ b/src/RWStepVisual/RWStepVisual_RWSurfaceStyleReflectanceAmbient.cxx
@@ -0,0 +1,78 @@
+// Created on : Thu May 14 15:13:19 2020 
+// Created by: Igor KHOZHANOV
+// Generator:  Express (EXPRESS -> CASCADE/XSTEP Translator) V2.0
...
+#include <Interface_EntityIterator.hxx>

Was this file generated or manually edited?
In the latter case, please make sure that class header (RWStepVisual_RWSurfaceStyleReflectanceAmbient.hxx in this case) is included first in new .cxx files. It is also desired removing trailing spaces in new files.

(0092237)
git (administrator)
2020-05-18 15:59

Branch CR31550 has been updated forcibly by Igor.

SHA-1: 1ce19adb7008f3b88196e14827914a81b7fc52ce
(0092239)
Igor (developer)
2020-05-18 16:35

kgv, the files are generated. I didn't change the order of includes manually. Ok, I will do it. Could you please explain why the class header should be first?
(0092240)
kgv (developer)
2020-05-18 16:42

> Could you please explain why the class header should be first?
I hope that you have started development from reading OCCT Coding Rules:
https://dev.opencascade.org/doc/overview/html/occt_dev_guides__coding_rules.html#occt_coding_rules_3 [^]

> Headers order
> ...
> Inclusion of class header on top verifies consistency of the header (e.g. that header file does not use any undefined declarations due to missing includes of dependencies).
(0092241)
git (administrator)
2020-05-18 22:17

Branch CR31550 has been updated forcibly by Igor.

SHA-1: f8ff6876b00438668625c904358aec584af15de1
(0092242)
Igor (developer)
2020-05-18 22:19

All notes are implemented
(0092252)
git (administrator)
2020-05-19 14:43

Branch CR31550 has been updated forcibly by Igor.

SHA-1: 0865ea60cbcbe6d1c4a806074fa7ef679deb56dc
(0092289)
ika (developer)
2020-05-21 12:17

Dear bugmaster,

the issue was tested:
http://occt-tests/CR31550-master-Igor-OCCT/Windows-64-VC14/diff_summary.html [^]
Failed cases are not affected by the changes and are not regressions of this issue
http://occt-tests/CR31550-master-Igor-OCCT/Debian80-64/diff_summary.html [^]
OK
http://occt-tests/CR31550-master-Igor-Products/Windows-64-VC14/diff_summary.html [^]
these ifc cases fail on several branches, not affected by the current changes and not regressions
http://occt-tests/CR31550-master-Igor-Products/Debian80-64/diff_summary.html [^]
OK

branch is ready to be integrated
OCCT - CR31550
Products - NOT
(0092310)
bugmaster (administrator)
2020-05-23 12:45

OCCT branch : IR-2020-05-22
master SHA - ae58f70718a089f84178d45a1bf9bee586d52d80
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-05-22 SHA - 454ac05077d8a84cd61adbfc32a89c7a61a67e10
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17169.13000000018 / 17197.13000000017 [-0.16%]
Products
Total CPU difference: 11217.810000000067 / 11198.660000000078 [+0.17%]
Windows-64-VC14:
OCCT
Total CPU difference: 18640.75 / 18655.984375 [-0.08%]
Products
Total CPU difference: 13006.1875 / 13006.671875 [-0.00%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0092415)
git (administrator)
2020-05-30 12:26

Branch CR31550 has been deleted by inv.

SHA-1: 0865ea60cbcbe6d1c4a806074fa7ef679deb56dc

- Related Changesets
occt: master 691711cd
Timestamp: 2020-05-18 10:04:19
Author: Igor
Committer: bugmaster
Details ] Diff ]
0031550: Data Exchange, STEP Import - surface transparency is ignored (SURFACE_STYLE_TRANSPARENT)

Implemented reading and writing transparency to/from step files
mod - src/RWStepAP214/RWStepAP214_GeneralModule.cxx Diff ] File ]
mod - src/RWStepAP214/RWStepAP214_ReadWriteModule.cxx Diff ] File ]
mod - src/RWStepVisual/FILES Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleReflectanceAmbient.cxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleReflectanceAmbient.hxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleRendering.cxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleRendering.hxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleRenderingWithProperties.cxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleRenderingWithProperties.hxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleTransparent.cxx Diff ] File ]
add - src/RWStepVisual/RWStepVisual_RWSurfaceStyleTransparent.hxx Diff ] File ]
mod - src/StepAP214/StepAP214_Protocol.cxx Diff ] File ]
mod - src/STEPCAFControl/STEPCAFControl_Reader.cxx Diff ] File ]
mod - src/STEPCAFControl/STEPCAFControl_Writer.cxx Diff ] File ]
mod - src/STEPConstruct/STEPConstruct_Styles.cxx Diff ] File ]
mod - src/STEPConstruct/STEPConstruct_Styles.hxx Diff ] File ]
mod - src/StepVisual/FILES Diff ] File ]
add - src/StepVisual/StepVisual_Array1OfRenderingPropertiesSelect.hxx Diff ] File ]
add - src/StepVisual/StepVisual_HArray1OfRenderingPropertiesSelect.hxx Diff ] File ]
add - src/StepVisual/StepVisual_RenderingPropertiesSelect.cxx Diff ] File ]
add - src/StepVisual/StepVisual_RenderingPropertiesSelect.hxx Diff ] File ]
add - src/StepVisual/StepVisual_ShadingSurfaceMethod.hxx Diff ] File ]
mod - src/StepVisual/StepVisual_SurfaceStyleElementSelect.cxx Diff ] File ]
mod - src/StepVisual/StepVisual_SurfaceStyleElementSelect.hxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleReflectanceAmbient.cxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleReflectanceAmbient.hxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleRendering.cxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleRendering.hxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleRenderingWithProperties.cxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleRenderingWithProperties.hxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleTransparent.cxx Diff ] File ]
add - src/StepVisual/StepVisual_SurfaceStyleTransparent.hxx Diff ] File ]
add - tests/bugs/step/bug31550 Diff ] File ]

- Issue History
Date Modified Username Field Change
2020-05-06 15:19 kgv New Issue
2020-05-06 15:19 kgv Assigned To => gka
2020-05-06 15:19 kgv File Added: stp_transp_nist_KO.png
2020-05-06 15:20 kgv File Added: nist_ftc_08_asme1_ap242-1.7z
2020-05-06 15:22 kgv Description Updated View Revisions
2020-05-06 15:23 kgv Steps to Reproduce Updated View Revisions
2020-05-06 15:24 kgv Steps to Reproduce Updated View Revisions
2020-05-06 15:45 bugmaster Project Open CASCADE => Community
2020-05-06 15:49 utverdov Assigned To gka => Igor
2020-05-17 17:32 git Note Added: 0092215
2020-05-18 13:13 git Note Added: 0092228
2020-05-18 13:21 Igor Note Added: 0092229
2020-05-18 13:21 Igor Assigned To Igor => gka
2020-05-18 13:21 Igor Status new => resolved
2020-05-18 13:29 Igor Note Added: 0092230
2020-05-18 14:32 gka Note Added: 0092233
2020-05-18 14:32 gka Assigned To gka => bugmaster
2020-05-18 14:32 gka Status resolved => reviewed
2020-05-18 14:34 Igor Note Edited: 0092230 View Revisions
2020-05-18 15:04 ika Note Added: 0092234
2020-05-18 15:04 ika Assigned To bugmaster => Igor
2020-05-18 15:04 ika Status reviewed => assigned
2020-05-18 15:06 ika Note Edited: 0092234 View Revisions
2020-05-18 15:06 ika Note Edited: 0092234 View Revisions
2020-05-18 15:35 git Note Added: 0092235
2020-05-18 15:41 Igor Assigned To Igor => ika
2020-05-18 15:41 Igor Status assigned => resolved
2020-05-18 15:53 kgv Note Added: 0092236
2020-05-18 15:53 kgv Note Edited: 0092236 View Revisions
2020-05-18 15:53 kgv Note Edited: 0092236 View Revisions
2020-05-18 15:59 git Note Added: 0092237
2020-05-18 16:35 Igor Note Added: 0092239
2020-05-18 16:42 kgv Note Added: 0092240
2020-05-18 22:17 git Note Added: 0092241
2020-05-18 22:19 Igor Note Added: 0092242
2020-05-19 14:43 git Note Added: 0092252
2020-05-21 12:17 ika Note Added: 0092289
2020-05-21 12:17 ika Assigned To ika => bugmaster
2020-05-21 12:17 ika Status resolved => reviewed
2020-05-23 12:45 bugmaster Note Added: 0092310
2020-05-23 12:45 bugmaster Status reviewed => tested
2020-05-23 12:48 bugmaster Test case number => bugs/step/bug31550
2020-05-23 12:52 bugmaster Changeset attached => occt master 691711cd
2020-05-23 12:52 bugmaster Status tested => verified
2020-05-23 12:52 bugmaster Resolution open => fixed
2020-05-30 12:26 git Note Added: 0092415
2020-09-10 15:12 kgv Relationship added related to 0023037


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker