View Issue Details

IDProjectCategoryView StatusLast Update
0031449Open CASCADEOCCT:Meshpublic2022-09-17 19:38
Reporterabv Assigned Tooan  
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Target Version7.7.0 
Summary0031449: Mesh - BRepMesh works too long and produces many free nodes on a valid face
DescriptionThe shape analyzed in context of #31301 exhibits problems in meshing occuring after export of the original shape (initially imported from STEP) to STEP and importing back, in a case when parameter xstep.cascade.unit is set to meters during last import. The meshing takes enormous time (effectively hangs) and (when suceeds) produces a lot of free nodes.

Originally detected in CAD Assistant which just hangs and eats all available memory when reading the exported STEP file if unit settings are "M".
Steps To Reproduce1. Full variant of original sequence in DRAW (hang or too long to wait for):

pload XDE AISV
ReadStep D [locate_data_file bug31301.stp]
WriteStep D bug31301_exported.stp
param xstep.cascade.unit M
ReadStep Q bug31301_exported.stp
XShow Q
----> WAIT (forever?)!

2. Simplified variant (prototype of test case) using single face (one that caused problems in #31301) already passed through all import - export steps:

pload MODELING MESH
restore [locate_data_file bug31301_face_loopback_M.brep] a
checkshape a
tolerance a

dchrono s restart
incmesh a 0.0001
dchrono s stop show
# meshing must be fraction of second, takes ~ 30 sec

tricheck a
# 6.000+ free nodes

3. Reproduction of the situation of CAD Assistant that eats ~ 30 GB of memory in ~ 3 min (on 6-core CPU):

pload MODELING
restore [locate_data_file bug31301_2_exported.brep] a
incmesh a 0.00039624 -a 20 -min 0.0001 -parallel

(the file is attached to #31301)
TagsNo tags attached.
Test case numberbugs/mesh/bug31449_1, bug31449_2, bug31449_3

Attached Files

  • bug31301_face_loopback_M.brep (24,500 bytes)
  • free_nodes_axo.png (4,333 bytes)
  • free_nodes_UV.png (2,096 bytes)

Relationships

related to 0025287 closedbugmaster Community BRepMesh_IncrementalMesh produces (way) out of tolerance mesh 

Activities

abv

2020-03-20 09:16

manager  

bug31301_face_loopback_M.brep (24,500 bytes)

oan

2020-03-20 10:54

developer   ~0091075

Last edited: 2020-03-20 11:00

It is strange, but reported free nodes are all visually located out of face boundary (see attached screenshots). To be analysed.

oan

2020-03-20 10:55

developer  

free_nodes_axo.png (4,333 bytes)

oan

2020-03-20 10:56

developer  

free_nodes_UV.png (2,096 bytes)

git

2022-09-01 13:49

administrator   ~0110532

Branch CR31449 has been created by oan.

SHA-1: 0b693379af696834c90d1e68daa847ba239197f1


Detailed log of new commits:

Author: oan
Date: Thu Sep 1 13:49:19 2022 +0300

    0031449: Mesh - BRepMesh works too long and produces many free nodes on a valid face
    
    Added test cases

git

2022-09-01 16:11

administrator   ~0110540

Branch CR31449 has been updated forcibly by oan.

SHA-1: db741596bc79ab5b0f33818350a55f13003d929d

git

2022-09-01 17:07

administrator   ~0110543

Branch CR31449 has been updated forcibly by oan.

SHA-1: 82d9237a509591d0f2ee99c31a475588e750d2ff

oan

2022-09-01 18:15

developer   ~0110546

The issue is not reproducible anymore on current master.

Branch CR31449 contains test cases only, see the report:
http://jenkins-test-occt/view/master-CR31449-OAN/view/COMPARE/

To integrate:
OCCT: CR31449
PRODUCTS: None

msv

2022-09-06 21:38

developer   ~0110775

Please do not make test failed due to exceeding execution time. Instead use cpulimit with some large enough threshold to pass the test on a low end PC or in debug mode.

git

2022-09-07 17:29

administrator   ~0110825

Branch CR31449 has been updated forcibly by oan.

SHA-1: 0763fd334fb7daab568a963787609200d34543ec

oan

2022-09-07 21:36

developer   ~0110836

See updated test cases.

Branch CR31449 contains test cases only, see the report:
http://jenkins-test-occt/view/master-CR31449-OAN/view/COMPARE/

To integrate:
OCCT: CR31449
PRODUCTS: None

smoskvin

2022-09-10 17:12

administrator   ~0110912

Unstable tests bug31449_1 bug31449_3

bug31449_1:
Error: Number of triangles = 9025 is not equal to expected 9177
Error: Number of nodes = 6562 is not equal to expected 6642
bug31449_3:
Error: Number of triangles = 7661 is not equal to expected 7813
Error: Number of nodes = 5810 is not equal to expected 5890

git

2022-09-12 17:18

administrator   ~0110987

Branch CR31449 has been updated forcibly by oan.

SHA-1: 094243fe3604f567791bdd869776a1545fb0ba86

git

2022-09-12 17:23

administrator   ~0110988

Branch CR31449 has been updated forcibly by oan.

SHA-1: cc9452598ae5aa41dc610c947ed25a472f7b3bfa

oan

2022-09-13 14:12

developer   ~0111012

Branch has been rebased to current master:

http://jenkins-test-occt/view/master-CR31449-OAN/view/COMPARE/

smoskvin

2022-09-17 19:31

administrator   ~0111117

Combination -
OCCT branch : IR-2022-09-16
master SHA - changes and them, and you can discard any commits you make in this
a939fd40eb473e79134ba740ed8e3f8aa4df37a7
changes and them, and you can discard any commits you make in this
e0ceb716c70188b98130b1550914140d0502a6f9
Products branch : IR-2022-09-16 SHA - 63dd76a64eb2213a575fdcfd88c28e77af367df1
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18769.440000000584 / 18960.430000000466 [-1.01%]
Products
Total CPU difference: 11959.870000000119 / 12078.45000000014 [-0.98%]
Windows-64-VC14:
OCCT
Total CPU difference: 20851.0625 / 20895.5625 [-0.21%]
Products
Total CPU difference: 14084.640625 / 13533.359375 [+4.07%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-09-17 19:38

administrator   ~0111120

Branch CR31449 has been deleted by mnt.

SHA-1: cc9452598ae5aa41dc610c947ed25a472f7b3bfa

Related Changesets

occt: master f3573fb5

2022-09-01 13:49:19

oan


Committer: smoskvin Details Diff
0031449: Mesh - BRepMesh works too long and produces many free nodes on a valid face

Added test cases
Affected Issues
0031449
add - tests/bugs/mesh/bug31449_1 Diff File
add - tests/bugs/mesh/bug31449_2 Diff File
add - tests/bugs/mesh/bug31449_3 Diff File

Issue History

Date Modified Username Field Change
2020-03-20 09:16 abv New Issue
2020-03-20 09:16 abv Assigned To => oan
2020-03-20 09:16 abv File Added: bug31301_face_loopback_M.brep
2020-03-20 09:16 abv Steps to Reproduce Updated
2020-03-20 10:12 oan Relationship added related to 0025287
2020-03-20 10:44 abv Steps to Reproduce Updated
2020-03-20 10:44 abv File Added: bug31301_2_exported.brep
2020-03-20 10:47 abv File Deleted: bug31301_2_exported.brep
2020-03-20 10:47 abv Steps to Reproduce Updated
2020-03-20 10:54 oan Note Added: 0091075
2020-03-20 10:55 oan File Added: free_nodes_axo.png
2020-03-20 10:56 oan File Added: free_nodes_UV.png
2020-03-20 11:00 oan Note Edited: 0091075
2020-08-28 15:43 oan Target Version 7.5.0 => 7.6.0
2021-10-06 16:57 szy Target Version 7.6.0 => 7.7.0
2022-09-01 13:49 git Note Added: 0110532
2022-09-01 16:11 git Note Added: 0110540
2022-09-01 17:07 git Note Added: 0110543
2022-09-01 18:15 oan Assigned To oan => msv
2022-09-01 18:15 oan Status new => resolved
2022-09-01 18:15 oan Note Added: 0110546
2022-09-06 21:38 msv Note Added: 0110775
2022-09-06 21:39 msv Assigned To msv => oan
2022-09-06 21:39 msv Status resolved => assigned
2022-09-07 17:29 git Note Added: 0110825
2022-09-07 21:36 oan Assigned To oan => msv
2022-09-07 21:36 oan Status assigned => resolved
2022-09-07 21:36 oan Note Added: 0110836
2022-09-08 11:00 msv Assigned To msv => bugmaster
2022-09-08 11:00 msv Status resolved => reviewed
2022-09-10 17:12 smoskvin Assigned To bugmaster => oan
2022-09-10 17:12 smoskvin Status reviewed => assigned
2022-09-10 17:12 smoskvin Note Added: 0110912
2022-09-12 17:18 git Note Added: 0110987
2022-09-12 17:23 git Note Added: 0110988
2022-09-13 14:12 oan Assigned To oan => smoskvin
2022-09-13 14:12 oan Note Added: 0111012
2022-09-13 14:13 oan Assigned To smoskvin => oan
2022-09-13 14:13 oan Status assigned => resolved
2022-09-13 14:13 oan Assigned To oan => smoskvin
2022-09-13 19:43 msv Assigned To smoskvin => bugmaster
2022-09-13 19:43 msv Status resolved => reviewed
2022-09-17 19:31 smoskvin Status reviewed => tested
2022-09-17 19:31 smoskvin Note Added: 0111117
2022-09-17 19:33 smoskvin Test case number => bugs/mesh/bug31449_1, bug31449_2, bug31449_3
2022-09-17 19:36 smoskvin Changeset attached => occt master f3573fb5
2022-09-17 19:36 oan Assigned To bugmaster => oan
2022-09-17 19:36 oan Status tested => verified
2022-09-17 19:36 oan Resolution open => fixed
2022-09-17 19:38 git Note Added: 0111120