View Issue Details

IDProjectCategoryView StatusLast Update
0031437CommunityOCCT:Modeling Datapublic2022-04-23 18:51
ReporterRoman Lygin Assigned Toazv 
PrioritynormalSeveritycrash 
Status verifiedResolutionfixed 
Product Version7.1.0 
Target Version7.7.0 
Summary0031437: Modeling Data - Offset surface throws exception when trying to evaluate at singularity point
DescriptionThe offset surface comes from Parasolid. The underlying surface is a B-Spline (apparently from surface of revolution) and has a singularity.
Geom_OffsetSurface cannot be evaluated at the singularity point as the normal to the base surface cannot be evaluated. In fact, the normal can be evaluated - just need a more adapted algorithm to compute at singularity.
Steps To ReproduceIn DRAW:
restore bs
offset os bs -2.5

or
restore os

An exception was caught 0000000003C12620 : Geom_UndefinedValue: GeomEvaluator_OffsetSurface::CalculateD0(): Unable to calculate normal
** Exception ** 0000000003C12620 : Geom_UndefinedValue: GeomEvaluator_OffsetSurface::CalculateD0(): Unable to calculate normal
TagsNo tags attached.
Test case numberbugs/moddata_3/bug31437

Attached Files

  • surface.zip (1,048 bytes)
  • screenshot.png (22,763 bytes)

Activities

Roman Lygin

2020-03-18 11:24

developer  

surface.zip (1,048 bytes)

Roman Lygin

2020-03-18 11:25

developer  

screenshot.png (22,763 bytes)

git

2022-04-16 22:30

administrator   ~0108008

Branch CR31437 has been created by azv.

SHA-1: d8bfee7b03e3f6c9f8f2799c3a782e28d393c83b


Detailed log of new commits:

Author: azv
Date: Sat Apr 16 22:29:47 2022 +0300

    0031437: Modeling Data - Offset surface throws exception when trying to evaluate at singularity point
    
    Add test case to prove the exception is avoided.

azv

2022-04-18 08:32

administrator   ~0108014

Dear Mikhail,

The problem is not reproducible since OCCT 7.5.0. Please, review the test case.

OCCT: CR31437
Products: NOT
Test results: http://jenkins-test-occt/view/CR31437-master-AZV/view/COMPARE/

msv

2022-04-18 18:06

developer   ~0108019

Actually the last version in which this test fails is 7.1.0.

smoskvin

2022-04-23 13:59

administrator   ~0108118

Combination -
OCCT branch : IR-2022-04-22
master SHA - a0b4fff17a6ad88f569052733d24723dd53e0919
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2022-04-22 SHA - 75f214de3df3529ee06eee62bf6c9b71e35e8c8b
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18635.800000000607 / 18527.100000000686 [+0.59%]
Products
Total CPU difference: 11716.970000000136 / 11769.420000000111 [-0.45%]
Windows-64-VC14:
OCCT
Total CPU difference: 20692.578125 / 20548.828125 [+0.70%]
Products
Total CPU difference: 13247.5625 / 13272.65625 [-0.19%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-04-23 18:51

administrator   ~0108125

Branch CR31437 has been deleted by mnt.

SHA-1: d8bfee7b03e3f6c9f8f2799c3a782e28d393c83b

Related Changesets

occt: master d8bfee7b

2022-04-16 22:29:47

azv

Details Diff
0031437: Modeling Data - Offset surface throws exception when trying to evaluate at singularity point

Add test case to prove the exception is avoided.
Affected Issues
0031437
add - tests/bugs/moddata_3/bug31437 Diff File

Issue History

Date Modified Username Field Change
2020-03-18 11:24 Roman Lygin New Issue
2020-03-18 11:24 Roman Lygin Assigned To => msv
2020-03-18 11:24 Roman Lygin File Added: surface.zip
2020-03-18 11:25 Roman Lygin File Added: screenshot.png
2020-09-15 12:08 msv Target Version 7.5.0 => 7.6.0
2020-09-15 12:09 msv Summary Offset surface throws exception when trying to evaluate at singularity point => Modeling Data - Offset surface throws exception when trying to evaluate at singularity point
2021-08-29 18:53 msv Target Version 7.6.0 => 7.7.0
2022-04-16 22:30 git Note Added: 0108008
2022-04-18 08:32 azv Status new => resolved
2022-04-18 08:32 azv Note Added: 0108014
2022-04-18 18:06 msv Note Added: 0108019
2022-04-18 18:06 msv Assigned To msv => bugmaster
2022-04-18 18:06 msv Status resolved => reviewed
2022-04-23 13:59 smoskvin Status reviewed => tested
2022-04-23 13:59 smoskvin Note Added: 0108118
2022-04-23 14:01 smoskvin Test case number => bugs/moddata_3/bug31437
2022-04-23 18:43 azv Changeset attached => occt master d8bfee7b
2022-04-23 18:43 azv Assigned To bugmaster => azv
2022-04-23 18:43 azv Status tested => verified
2022-04-23 18:43 azv Resolution open => fixed
2022-04-23 18:51 git Note Added: 0108125