View Issue Details

IDProjectCategoryView StatusLast Update
0031383CommunityOCCT:Data Exchangepublic2021-05-14 09:53
Reporterthomhong Assigned Tobugmaster  
PrioritynormalSeveritymajor 
Status closedResolutionunable to reproduce 
PlatformVisual Studio 2019OSWindows 10 
Product Version7.3.0 
Target Version7.6.0 
Summary0031383: Data Exchange - STEPCAFControl_Writer generates invalid curve in STEP file
DescriptionOCCT 7.4.0's STEPCAFControl_Writer is generating a STEP file that is unable to be opened by consumers, including OCC's STEP reader (appears to be due to a tiny curve with parametric step size < double precision). This is easily reproducible using the OCC CadAssistant application.
Steps To Reproduce1. Open HSK63AER40120M.STP in CadAssistant
2. Save as STEP model using default settings (HSK63AER40120M-output.step)
3. Close CadAssistant
4. Attempt to open HSK63AER40120M-output.step in CadAssistant

CadAssistant will hang indefinitely.
TagsNo tags attached.
Test case number

Attached Files

  • HSK63AER40120M.STP (496,736 bytes)

Activities

thomhong

2020-02-18 20:26

reporter  

HSK63AER40120M.STP (496,736 bytes)

dpasukhi

2021-04-28 14:24

developer   ~0100638

Dear bugmaster,
please Close the issue.

Not reproduce. An incorrect tolerance has caused it to hang indefinitely. It was fixed together with tolerance issues.

Issue History

Date Modified Username Field Change
2020-02-18 20:26 thomhong New Issue
2020-02-18 20:26 thomhong Assigned To => gka
2020-02-18 20:26 thomhong File Added: HSK63AER40120M.STP
2020-03-04 11:59 kgv Summary STEPCAFControl_Writer generates invalid curve in STEP file => Data Exchange - STEPCAFControl_Writer generates invalid curve in STEP file
2020-11-23 21:18 gka Assigned To gka => dpasukhi
2021-04-28 14:24 dpasukhi Note Added: 0100638
2021-04-28 14:24 dpasukhi Assigned To dpasukhi => bugmaster
2021-04-28 14:24 dpasukhi Status new => feedback
2021-04-28 14:45 kgv Resolution open => unable to reproduce
2021-04-28 14:45 kgv Target Version => 7.6.0
2021-05-14 09:53 bugmaster Status feedback => closed