View Issue Details

IDProjectCategoryView StatusLast Update
0031382Open CASCADEOCCT:Data Exchangepublic2022-04-29 16:48
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityfeature 
Status closedResolutionfixed 
Target Version7.6.0Fixed in Version7.6.0 
Summary0031382: Data Exchange - BinXCAF should preserve length unit information
DescriptionCurrently, XCAF document (XBF) is loaded / written without length unit conversions, so that document implicitly preserves system units.
As different OCCT-based applications may choose different system units, opening the documents across such applications becomes problematic as there are no related information preserved in the file no standard tools for units conversion of XCAF document content.

As minimal requirement, it is necessary preserving length unit information within XBF/Xml file, which should be set and processed by unit-aware applications (by default, it might be reasonable keeping length unit UNDEFINED).
Steps To Reproducebug31382
TagsNo tags attached.
Test case numberbugs/xde/bug31382

Relationships

related to 0031136 closedbugmaster Open CASCADE Modeling Data - BinXCAF persistence loses normals from triangulation-only Faces 
parent of 0032748 verifiedsmoskvin Community Data Exchange, Step Import - xstep.cascade.unit doesn't work [regression since OCCT 7.6.0] 
related to 0032452 verifiedsmoskvin Community Data Exchange - IGES reader returns invalid shapes if xstep.cascade.unit property is changed from default 
related to 0032512 newgka Community DXF Import - OCC is not reading $INSUNITS variable from DXF file 
related to 0032514 newgka Community DXF Export - OCC export DXF file without $INSUNITS variable 
related to 0026733 newgka Community Data Exchange - "nm" length unit is not supported to import and export 
related to 0032954 verifiedsnn Open CASCADE Data Exchange - Tool for applying transformation to XCAF document 

Activities

git

2020-11-10 07:53

administrator   ~0096632

Branch CR31382 has been created by skl.

SHA-1: 8638eb6923dd4c515bd8d899cf3c8f233b1734e7


Detailed log of new commits:

Author: skl
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Add LengthUnit info to XCAF document.

git

2020-11-10 07:55

administrator   ~0096633

Branch CR31382 has been updated forcibly by skl.

SHA-1: 70bc6ab2cf4ecc77b2856b82f4324978a498398f

git

2020-11-10 08:41

administrator   ~0096634

Branch CR31382 has been updated forcibly by skl.

SHA-1: d3ebb3870574430d07f8657fc4f45114ca82f8d0

git

2020-11-10 14:36

administrator   ~0096638

Branch CR31382 has been updated forcibly by skl.

SHA-1: 3a4f47ea05b5faf8469cc349fc7d4fd8854effd8

git

2020-11-11 10:19

administrator   ~0096652

Branch CR31382 has been updated forcibly by skl.

SHA-1: 4bdf1ebadccec4c4696508d5b294fbbf7ae561ab

skl

2020-11-11 15:54

developer   ~0096659

Result of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-master/view/COMPARE/

msv

2020-11-11 17:01

developer   ~0096662

It would be helpful to add to the LengthUnitTool a method that returned scale ratio between two units.
Use case:
  XCAFDoc_LengthUnitTool::UnitValue aUnit = aLUTool->GetLengthUnit();
  double aScale = XCAFDoc_LengthUnitTool::GetScale (XCAFDoc_LengthUnitTool::UV_METER, aUnit);

GetScale (XCAFDoc_LengthUnitTool::UV_METER, XCAFDoc_LengthUnitTool::UV_MILLIMETER) is expected to return 1000.

msv

2020-11-11 17:05

developer   ~0096664

Sergey, you can make the code compact (and less error prone) by separating the code that converts a string to the unit enum into a dedicated function in XDEDRAW.cxx.

kgv

2020-11-11 17:11

developer   ~0096666

Last edited: 2020-11-11 17:13

To make patch actually useful, it is desired to:
1. Update existing XCAF document (e.g. STEP, IGES, glTF, JT) filling/creation tools to set up units information, when it is known.
2. Analyze how to convert XCAF document from one unit to another (while reading or by other means). This might be really complicated considering reading of TopoDS_Shape / PMI information / etc., but feasible.

This is not necessary to be put into this patch, but before processing with integration of this step we should analyze how to go further (and potentially alter this patch to suite better further needs).

msv

2020-11-11 17:26

developer   ~0096668

What is missing in this fix is storing units in standard saving procedure. Can we use the current value of the parameter xstep.cascade.unit to store the unit in the saved file? If some unit-aware application does not use this parameter it will set the units in the document explicitly, and in this case the standard procedure must not override the value of unit set in the document.

mpv

2020-11-11 17:28

developer   ~0096669

To get conversion from one unit to other you may use method UnitsMethods::GetLengthFactorValue

I don't know, may be it is worth synchronize somehow enumeration with integer values used in this method. May be we could use the same enum in both UnitsMethods and XCAFDoc_lengthUnitTool?

Also in XCAFDoc_LengthUnitTool::SetLengthUnit you may remove everything except the last line, because TDataStd_Integer::Set checks the attribute already exists and changes the value. You don't need to forget the attribute just to change it.

git

2020-11-12 11:13

administrator   ~0096690

Branch CR31382 has been updated forcibly by skl.

SHA-1: e068e892f3134df99842e18d7881e87e2d22984a

skl

2020-11-12 18:10

developer   ~0096726

Result of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-master/view/COMPARE/

kgv

2020-11-12 19:16

developer   ~0096730

+  enum LengthUnit {

This should be moved to dedicated enum header following recommendations in OCCT Coding Rules.

+UnitsMethods::LengthUnit lengthUnitByStr(TCollection_AsciiString theStr)

static
const TCollection_AsciiString&

+  if (theStr.IsEqual("MM"))

It is preferred making comparison case-insensitive.

+  di.Add("XCheckLengthUnit",

This command makes no sense for general usage - it could be replaced by Tcl comparison check using XGetLengthUnit command.

+  di.Add("XDumpLengthUnit",

XDump* prefix is unusual for getters in Draw Harness plugins - other getters have XGet* prefix.

git

2020-11-15 07:18

administrator   ~0096778

Branch CR31382 has been updated forcibly by skl.

SHA-1: ab1c68a13e150ae3ec6b1ba806d092de4001f640

git

2020-11-16 12:08

administrator   ~0096788

Branch CR31382 has been updated forcibly by skl.

SHA-1: 763bab75800c94d58dae4db90953d1e9c98c6a5d

git

2020-11-17 10:42

administrator   ~0096818

Branch CR31382 has been updated forcibly by skl.

SHA-1: cfd5bf689758ece85287db5ba9c9357138906e70

skl

2020-11-17 15:04

developer   ~0096828

In order to avoid situation with undefined length unit in the document special protection in the XCAFDoc_ShapeTool is added: before adding of first TopoDS_Shape to document value of length unit is checked and if it is undefined, a value from session (param xstep.cascade.unit) sets into document as length unit.

Results of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-master/view/COMPARE/

kgv

2020-11-17 15:10

developer   ~0096829

Last edited: 2020-11-17 15:10

+  case UnitsMethods_LengthUnit::LU_MILLIMETER: return "MILLIMETER";

This enumeration value syntax will raise old compiler warning on weekly Jenkins, please drop it.

Please also rename enumeration values to include full enumeration name, e.g.:
- UnitsMethods_LengthUnit::LU_MILLIMETER -> UnitsMethods_LengthUnit_Millimeter

msv

2020-11-17 15:55

developer   ~0096831

+XSetLengthUnit D IncH
Why last letter is capital? It causes reader to find a hidden sense of it. Please use the simple word instead.

+ Handle(XCAFDoc_LengthUnitTool) aLUTool = XCAFDoc_LengthUnitTool::Set(Label().Father().FindChild(11, Standard_True));
Use LengthUnitLabel from document tool to access to the label of units.

git

2020-11-17 16:07

administrator   ~0096833

Branch CR31382 has been updated forcibly by skl.

SHA-1: 05da37a7aac569198019f4b4cf1a0508d426f8c1

git

2020-11-18 07:02

administrator   ~0096858

Branch CR31382 has been updated forcibly by skl.

SHA-1: 7de4b54ab5b9f28877857fdde5f276e9e7845bc4

skl

2020-11-18 11:34

developer   ~0096873

Result of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-master/view/COMPARE/

msv

2020-11-18 12:17

developer   ~0096878

Please rebase on the latest master.

git

2020-11-18 12:28

administrator   ~0096880

Branch CR31382 has been updated forcibly by skl.

SHA-1: cdaf43ee09e80fbc6d368d0c94b7fafb488142b5

msv

2020-11-18 12:32

developer   ~0096881

For integration:
occt - CR31382
products - none

kgv

2020-11-19 10:56

developer   ~0096891

Last edited: 2020-11-19 11:02

--- a/src/TKXCAF/EXTERNLIB
+++ b/src/TKXCAF/EXTERNLIB
@@ -10,3 +10,5 @@ TKLCAF
 TKG3d
 TKCAF
 TKVCAF
+TKXSBase

Putting STEP reader/writer as dependency for XCAF document library doesn't look like an acceptable change.

+UnitsMethods_LengthUnitEnum.hxx

File name should be "UnitsMethods_LengthUnit.hxx" according to OCCT coding rules, not "UnitsMethods_LengthUnitEnum.hxx".

+UnitsMethods_LengthUnit lengthUnitByStr(TCollection_AsciiString theStr)

static

+UnitsMethods_LengthUnit lengthUnitByStr(TCollection_AsciiString theStr)
+{
...
+  else
+    return UnitsMethods_LengthUnit_Undefined;
...

+  TCollection_AsciiString aUnit(argv[2]);
+  aLUTool->SetLengthUnit(lengthUnitByStr(argv[2]));

Command is expected to print user an error in case of wrong input, not silently commit UNDEFINED unit.

+  if (argc < 3) {

Unknown arguments (>3) should be reported as a syntax error as well.

+  if (argc < 3) {
...
+enum UnitsMethods_LengthUnit {

Please follow OCCT coding rules in new code - put { on the next line.

@@ -548,6 +551,17 @@ TDF_Label XCAFDoc_ShapeTool::AddShape (const TopoDS_Shape& theShape,
...
+      aLU = (UnitsMethods_LengthUnit)Interface_Static::IVal("xstep.cascade.unit");

Reading STEP-specific parameter within the base tool is illogical.
In contrary, it is a STEP translator filling in XCAF document should put length unit information (and print a warning if document has already specified non-matching length unit).

+UnitsMethods_LengthUnit XCAFDoc_LengthUnitTool::GetLengthUnit() const
...
+    aVal = (UnitsMethods_LengthUnit)anAttribute->Get();

As there is no dedicated driver, no versioning and no guarantee that UnitsMethods_LengthUnit will not be extended in future, it would be helpful verifying the enumeration range before cast.
By the way, I think it might be more useful storing length unit as a string rather than enum in XCAF document.

+  static Standard_GUID LengthUnitID("4eba571f-de90-4840-8639-eab9b72360e0");

static const

+//! The Enumeration describes possible values for length units
+
+enum UnitsMethods_LengthUnit {

Unexpected empty line between documentation and enum.

+};
+#endif // _XCAFDoc_LengthUnitTool_HeaderFile

Please put an empty line after };

skl

2020-11-19 15:11

developer   ~0096900

Package UnitsMethods is in toolkit TKXSBase.
Is it reasonable to move this package to another toolkit (for example to TKernel) in order to avoid dependency between TKXCAF and TKXSBase?

git

2020-11-24 15:27

administrator   ~0097032

Branch CR31382 has been updated forcibly by skl.

SHA-1: a1e2fe4eb0f4d439b71ea756b41793d9aeb1ca73

kgv

2020-12-10 10:33

developer   ~0097453

> Is it reasonable to move this package to another toolkit
> (for example to TKernel) in order to avoid
> dependency between TKXCAF and TKXSBase?
UnitsMethods currently defines not only global "cascade units" property (GetCasCadeLengthUnit()), but also auxiliary geometry conversion methods.
So that while technically it looks reasonable moving GetCasCadeLengthUnit() outside, this cannot be done for the whole UnitsMethods package as it has to be split into parts.

git

2020-12-24 16:30

administrator   ~0097891

Branch CR31382 has been updated forcibly by skl.

SHA-1: 0425c2c264d1563a48e08a386a50d9d9b6032f39

git

2020-12-25 16:47

administrator   ~0097906

Branch CR31382 has been updated by skl.

SHA-1: 22a2d00cc3be85718bad5173f31d327326bb84bb


Detailed log of new commits:

Author: skl
Date: Fri Dec 25 16:47:44 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Split package UnitsMethods.

git

2020-12-25 17:26

administrator   ~0097907

Branch CR31382 has been updated forcibly by skl.

SHA-1: 3c5c03080bf878bed9c24bc86f6d6fbc00f254be

git

2020-12-28 13:03

administrator   ~0097958

Branch CR31382 has been updated by skl.

SHA-1: e250344fe147c0b792f013f4231824e145d9c35a


Detailed log of new commits:

Author: skl
Date: Mon Dec 28 13:03:29 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Try to avoid using "xstep.cascade.unit".

git

2020-12-28 16:52

administrator   ~0097962

Branch CR31382 has been updated forcibly by skl.

SHA-1: dd51932a9680eb7c6f2ab685ffb639758f3966db

git

2020-12-28 18:59

administrator   ~0097964

Branch CR31382 has been updated forcibly by skl.

SHA-1: 3e974687d560c8e8afe519b32f2de4b361ae7fbf

git

2020-12-29 09:25

administrator   ~0097969

Branch CR31382 has been updated forcibly by skl.

SHA-1: 3c086c829ba4912cd6616d5beb31b6e695342469

git

2020-12-30 11:00

administrator   ~0097985

Branch CR31382 has been updated forcibly by skl.

SHA-1: cccbf41f43b51078d31fb8c68cf8054468d312f5

skl

2020-12-31 10:18

developer   ~0097995

Package UnitsMethods is splitted: geom methods was placed to new package UnitsGeomMethods which is in the toolkit TKXSBase. Package UnitsMethods is placed to toolkit TKernel.
Since for all supported formats value CasCadeLengthUnit is used for set unit of length it is reasonable to avoid using of parameter "xstep.cascade.unit".
New Draw command "setlengthunit" for set length unit is added. This command have to be used istead of command "param xstep.cascade.unit".
All using "xstep.cascade.unit" in the read/write classes is removed.
But for supporting of existed Draw tests and other using in "old" code setting for "xstep.cascade.unit" in class XSAlgo.cxx is kept.

Result of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-CR31382-skl/view/COMPARE/


msv

2020-12-31 11:49

developer   ~0097997

The description of the method UnitsMethods::GetLengthUnitByFactorValue is not valid. Please correct it.

The new methods FactRD and FactDR in UnitsMethods have unclear names and no description. Please rename them like FactorRadianDegree and add description.

Why did you remove the virtual method XSAlgo_AlgoContainer::PrepareForTransfer? It can be redefined in some other code.

I propose to replace in the tests usage of "param xstep.cascade.unit" with "setlengthunit". It is in order to remove the usage of obsolete mechanism from OCCT.

git

2020-12-31 16:15

administrator   ~0098000

Branch CR31382 has been updated forcibly by skl.

SHA-1: f96ad714e2d84bf57b637cf82c60c9b2ccd992b3

skl

2021-01-11 12:05

developer   ~0098050

Needed changes is done.
Result of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-CR31382-skl/view/COMPARE/

msv

2021-01-11 14:11

developer   ~0098061

Again, the description of the method UnitsMethods::GetLengthUnitByFactorValue is not valid. Please correct it.

msv

2021-01-11 14:26

developer   ~0098066

In XtControl_ActorRead::Transfer(), why did you commented out the following line? I think we should leave the call of this virtual method.
  //XSAlgo::AlgoContainer()->PrepareForTransfer();

msv

2021-01-11 14:28

developer   ~0098067

Prepare new ready for integration branches with one commit in both occt and products.

git

2021-01-11 15:19

administrator   ~0098072

Branch CR31382 has been updated forcibly by skl.

SHA-1: cd6512ffde9a700723eafee98341526242620a48

git

2021-01-11 15:22

administrator   ~0098073

Branch CR31382 has been updated forcibly by skl.

SHA-1: d4fd7db52d1ec856ceda766cd822c1e102f0ef53

skl

2021-01-12 10:04

developer   ~0098083

Needed changes is done.
Result of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-CR31382-skl/view/COMPARE/

kgv

2021-01-12 11:16

developer   ~0098085

> Add LengthUnit info to XCAF document.
> Split package UnitsMethods.
> Try to avoid using "xstep.cascade.unit".

This comment description is too basic - it is expected to see details on modifications (how UnitsMethods package has been split? which interface is introduced in XCAF for LengthUnit info? what does it mean "try to avoid using xstep.cascade.unit"?).

+  di << "current value of length unit is " << UnitsMethods::DumpLengthUnit(aLU);

This is an overloaded output for the command intended to return variable value - please consider removing redundant text and keep only output of value itself.
So that Tcl script could be able to use "set aUnit [lengthunit]" without necessity to parse text.

--- a/src/TKernel/PACKAGES
+++ b/src/TKernel/PACKAGES
@@ -14,3 +14,4 @@ Units
 UnitsAPI
 NCollection
 Message
+UnitsMethods

Please apply alphabetical order for new entities.

+
+class UnitsGeomMethods 

Please provide description for new class and it's methods.

+  
+protected:
+
+private:
+
+};

No need in copying empty sections.

+  if (fabs(1. - theFactorValue) < aPreci)

fabs() -> Abs()

+enum UnitsMethods_LengthUnit {

Please follow OCCT Coding Style (newline before opening bracket).

msv

2021-01-12 11:24

developer   ~0098086

src/UnitsMethods/UnitsMethods.hxx
  //! Returns the enumeration corresnoding to the given scale factor
Misprint "corresnoding"

skl

2021-01-13 12:37

developer   ~0098098

Results of tests:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR31382-CR31382-skl/view/COMPARE/

msv

2021-01-13 14:47

developer   ~0098103

I have corrected the spelling of commit message in CR31382_1.

msv

2021-01-13 14:52

developer   ~0098104

For integration:
occt - CR31382_1
products - CR31382

kgv

2021-01-13 16:24

developer   ~0098106

Last edited: 2021-01-13 16:25

+static Standard_Integer setLengthUnit(Draw_Interpretor& di, Standard_Integer argc, const char** argv)
+{
+  if (argc < 2)
...
+static Standard_Integer lengthUnit(Draw_Interpretor& di, Standard_Integer 
+{
+  UnitsMethods_LengthUnit aLU = UnitsMethods::GetLengthUnitByFactorValue(UnitsMethods::GetCasCadeLengthUnit());
+  di << UnitsMethods::DumpLengthUnit(aLU);
+  return 0;

This is a weak check - it allows passing extra arguments to commands without user noticing they will be ignored. Please check for equality instead.

+  theCommands.Add("lengthunit", "return value of length unit"
+  theCommands.Add("setlengthunit", "set value of length unit"

Defining two commands for the same thing looks redundant - it will be simpler having a single command "lengthunit" doing both tasks depending on a number of arguments, as many other Draw Harness commands.

--- a/src/Interface/Interface_Static.cxx
+++ b/src/Interface/Interface_Static.cxx
+    if (strcmp(name, "xstep.cascade.unit") == 0)
+    {
+      Standard_Integer aUnit = item->IntegerValue();
+      UnitsMethods::SetCasCadeLengthUnit(aUnit);
+    }

Keeping this hack indefinitely within the basic interface for arbitrary parameters doesn't look like a good idea.
I propose generating a runtime warning (Message::SendWarning()) about deprecation of "xstep.cascade.unit" parameter, so that we will remove this code after a couple of OCCT releases.

+//! Class contains conversion methods for 2d geom objects
+class UnitsGeomMethods
+{

I don't know if these methods have been supposed to be public / have any use for external applications, but if yes - this API change should be mentioned in Upgrade Guide, as user will be unable to figure out where the methods have gone.

dpasukhi

2021-02-09 23:26

developer   ~0098803

Solution elaboration
Elaboration storing of new XCAF attribute ( Units )

dpasukhi

2021-02-10 23:58

developer   ~0098822

Solution elaboration

dpasukhi

2021-02-11 23:47

developer   ~0098834

Solution elaboration & testing

Implementation of a new attribute for storing units

dpasukhi

2021-02-12 23:56

developer   ~0098854

Solution elaboration & testing

dpasukhi

2021-03-27 01:58

developer   ~0099775

Solution elaboration

dpasukhi

2021-03-30 23:14

developer   ~0099897

Solution elaboration

dpasukhi

2021-04-16 19:58

developer   ~0100355

Solution elaboration

dpasukhi

2021-05-02 23:38

developer   ~0100750

Solution elaboration

dpasukhi

2021-05-09 21:50

developer   ~0100835

dpasukhi

2021-05-16 23:13

developer   ~0101078

Last edited: 2021-05-17 12:04

Solution implementation

git

2021-05-20 03:23

administrator   ~0101193

Branch CR31382_2 has been created by dpasukhi.

SHA-1: 9e94dab88a63b3abb68f26ec0abd7e8ec6ff87a7


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Possibility for adding LengthUnit info to XCAF document using special class TDataStd_LenghtUnit is implemented
    Package UnitsMethods is splited: geom methods was placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData
    All global units was replace by UnitsAPI
    Since for all supported formats value CasCadeLengthUnit is used for set unit of length using of parameter "xstep.cascade.unit" for set length unit is not needed.
    New Draw command "setlengthunit" for set value of length unit is added. This command have to be used istead of command "param xstep.cascade.unit".
    All using "xstep.cascade.unit" in the read/write classes is removed.
    Initialization of "xstep.cascade.unit" is kept in the method XSAlgo::Init() in order to support old versions.

dpasukhi

2021-05-23 23:16

developer   ~0101293

Solution implementation & testing

git

2021-05-24 02:28

administrator   ~0101295

Branch CR31382_2 has been updated forcibly by dpasukhi.

SHA-1: 42ddefea9995a4500b5876c59397c197649e0c28

abv

2021-05-24 16:02

manager   ~0101330

A remark following our discussion: we do not seem to have a strong need of global parameter defining units of OCCT apart of DE components (which use xstep.cascade,units). These units are defined by the application and can be managed in application-specific way (usially this is not customizable).

At the same time, there is apparently a need to have possibility to convert XCAF document defined in one units, to some other units. This operation shall be performed after loading XCAF document if it was written in units different from those used by the application.

git

2021-05-25 13:45

administrator   ~0101356

Branch CR31382_2 has been updated by dpasukhi.

SHA-1: 89fcc93f371d6319627c8b0486885d0ccfab683b


Detailed log of new commits:

Author: dpasukhi
Date: Tue May 25 13:45:45 2021 +0300

    // fix unit initialization ( test version )

git

2021-05-26 13:25

administrator   ~0101388

Branch CR31382_2 has been updated forcibly by dpasukhi.

SHA-1: 58595f39c67bb437624bc500e138673b9db31db8

git

2021-05-26 14:44

administrator   ~0101394

Branch CR31382_2 has been updated forcibly by dpasukhi.

SHA-1: 5a42d15f8e88affe6b1716123a8e567b7fe7bddc

dpasukhi

2021-05-30 23:32

developer   ~0101514

Solution elaboration

Revert old realization. Development according to the splitting of the task

git

2021-06-03 04:19

administrator   ~0101565

Branch CR31382_3 has been created by dpasukhi.

SHA-1: 73bf8b601034a798dd65840b67bff8d94bdfa280


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Possibility for adding LengthUnit info to XCAF document using special class TDataStd_LenghtUnit is implemented
    Package UnitsMethods is splited: geom methods was placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData
    Since for all supported formats value CasCadeLengthUnit is used for set unit of length using of parameter "xstep.cascade.unit" for set length unit is not needed.
    New Draw command "XSetlengthunit" for set XDE attribute for in the doc.

git

2021-06-03 12:28

administrator   ~0101573

Branch CR31382_3 has been updated forcibly by dpasukhi.

SHA-1: 5683e2df45c38fae113f16769e8c6763acc74585

dpasukhi

2021-06-06 23:45

developer   ~0101648

Last edited: 2021-06-06 23:51

Solution implementation

git

2021-06-23 12:21

administrator   ~0102006

Branch CR31382_4 has been created by dpasukhi.

SHA-1: 7c6a6aa14c8b4abc316cdc09a162b800ff09798a


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Possibility for adding LengthUnit info to XCAF document using special class TDataStd_LenghtUnit is implemented
    Package UnitsMethods is splited: geom methods was placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData
    Since for all supported formats value CasCadeLengthUnit is used for set unit of length using of parameter "xstep.cascade.unit" for set length unit is not needed.
    New Draw command "XSetlengthunit" for set XDE attribute for in the doc.
    Upgraded tests\de to check "loop back" algorithms with any unit

git

2021-06-24 15:31

administrator   ~0102030

Branch CR31382_4 has been updated forcibly by dpasukhi.

SHA-1: 5d30d207c7121ee0abca1d9c729125543280bb13

git

2021-06-24 15:35

administrator   ~0102031

Branch CR31382_4 has been updated forcibly by dpasukhi.

SHA-1: ea11886458d8e952efc82c295731913f822658cd

dpasukhi

2021-06-27 22:59

developer   ~0102108

git

2021-08-02 02:59

administrator   ~0102917

Branch CR31382_5 has been created by dpasukhi.

SHA-1: 0c735100b2ce35614453c58f5d388f4be168e263


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Possibility for adding LengthUnit info to XCAF document using special class TDataStd_LenghtUnit is implemented
    Package UnitsMethods is splited: geom methods was placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData
    Since for all supported formats value CasCadeLengthUnit is used for set unit of length using of parameter "xstep.cascade.unit" for set length unit is not needed.
    New Draw command "XSetlengthunit" for set XDE attribute for in the doc.
    Upgraded tests\de to check "loop back" algorithms with any unit

git

2021-08-12 02:57

administrator   ~0103144

Branch CR31382_5 has been updated forcibly by dpasukhi.

SHA-1: 0e0fecee8da5a25eff16a1a082b7841b3ec2ce40

git

2021-08-13 19:06

administrator   ~0103191

Branch CR31382_5 has been updated by dpasukhi.

SHA-1: c8002f3986bf65d4c0572be4c074de8d5fa737f0


Detailed log of new commits:

Author: dpasukhi
Date: Fri Aug 13 19:05:11 2021 +0300

    // Added Length unit attribute to Doc as new type of an attribute

git

2021-08-13 19:14

administrator   ~0103192

Branch CR31382_5 has been updated forcibly by dpasukhi.

SHA-1: 0bf1a152f08be0a3d8a4f0f88282f56598594a1c

dpasukhi

2021-08-15 23:50

developer   ~0103225

git

2021-08-18 15:08

administrator   ~0103274

Branch CR31382_6 has been created by dpasukhi.

SHA-1: c346bcbc181da9d3cbd88490085aff73f1b61dc6


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Possibility for adding LengthUnit info to XCAF document using special class XCAFDoc_LenghtUnit and XCAFDoc_LenghtUnitTool is implemented
    Package UnitsMethods is splited: geom methods was placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData
    Updated UnitMethods to convert scale factor to different unit types.
    Now, XSAlgo::XSAlgo_AlgoContainer used for update unit info from static interface values.
    New Draw command "XSetlengthunit" and "XGetLengthUnit" for set or get XDE attribute
    Upgraded tests for step, iges, obj, gltf, vrlm formats to check area regressing with used unit
    Upgraded tests\de test cases to use any units in the "loop back" algorithms

git

2021-08-18 21:13

administrator   ~0103292

Branch CR31382_6 has been updated by dpasukhi.

SHA-1: 1dd95deadc82abb91b90af69b1b661621d815641


Detailed log of new commits:

Author: dpasukhi
Date: Wed Aug 18 21:09:42 2021 +0300

    // remarks have been fixed

git

2021-08-18 22:45

administrator   ~0103295

Branch CR31382_6 has been updated by dpasukhi.

SHA-1: 8403a799b6c4383570f960fb71a37ef60fb9c8b4


Detailed log of new commits:

Author: dpasukhi
Date: Wed Aug 18 22:45:10 2021 +0300

    // fixed problem with StepCafControl_Writer and IGESCAFControl_Writer transferring

git

2021-08-18 23:21

administrator   ~0103296

Branch CR31382_6 has been updated forcibly by dpasukhi.

SHA-1: ad0cc3c986b72d249fe80d7a3cf29e115d78ab9e

git

2021-08-19 12:34

administrator   ~0103301

Branch CR31382_7 has been created by dpasukhi.

SHA-1: 7263ddef83eb434547862d305fa115ea2af94650


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 10 07:52:30 2020 +0300

    0031382: Data Exchange - BinXCAF should preserve length unit information
    
    Possibility for adding LengthUnit info to XCAF document using special class XCAFDoc_LenghtUnit and XCAFDoc_LenghtUnitTool is implemented
    Package UnitsMethods is splited: geom methods was placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData
    Updated UnitMethods to convert scale factor to different unit types.
    Now, XSAlgo::XSAlgo_AlgoContainer used for update unit info from static interface values.
    New Draw command "XSetLengthUnit" and "XGetLengthUnit" for set or get XDE attribute
    Upgraded tests for step, iges, obj, gltf, vrlm formats to check area regressing with used unit
    Upgraded tests\de test cases to use any units in the "loop back" algorithms

git

2021-08-19 14:50

administrator   ~0103306

Branch CR31382_7 has been updated forcibly by dpasukhi.

SHA-1: d8e12e9581b74dd0891791ad8c7d25f1629f9ed1

git

2021-08-19 16:20

administrator   ~0103311

Branch CR31382_7 has been updated forcibly by dpasukhi.

SHA-1: 4db9971672adfb59601da91281314860198940c8

dpasukhi

2021-08-19 17:41

developer   ~0103312

Last edited: 2021-08-20 10:06

Dear KGV,
please review the CR31382_7

OCCT: CR31382_7
PRODUCTS: NO

All tests are OK, see:
http://jenkins-test-08.nnov.opencascade.com/view/CR31382-master-dpasukhi/view/COMPARE/

git

2021-08-19 22:28

administrator   ~0103314

Branch CR31382_7 has been updated forcibly by dpasukhi.

SHA-1: 19807e831e719b183eb58fef7fafc4726307f907

kgv

2021-08-20 15:47

developer   ~0103319

bugmaster

2021-08-21 14:19

administrator   ~0103326

Combination -
OCCT branch : IR-2021-08-20
master SHA - da80ff68f1e9853c1015a5dbb6199541e92789ce
a87b7ddc8cb44606b91e3f37113847c3f5f50fdc
Products branch : IR-2021-08-20 SHA - dd282797d1b40a373376bcd4a820edeb3d4d52f6
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17364.550000000334 / 17371.860000000408 [-0.04%]
Products
Total CPU difference: 11522.500000000102 / 11493.740000000085 [+0.25%]
Windows-64-VC14:
OCCT
Total CPU difference: 19242.96875 / 19148.140625 [+0.50%]
Products
Total CPU difference: 12876.5625 / 12805.328125 [+0.56%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2021-08-21 14:31

administrator   ~0103329

Branch CR31382 has been deleted by mnt.

SHA-1: 8c60f25ff0d623a713738776f3f6b846908a3f29

git

2021-08-21 14:31

administrator   ~0103330

Branch CR31382_1 has been deleted by mnt.

SHA-1: 1f4050bc7036002ba99a5cdff459f9f648711759

git

2021-08-21 14:31

administrator   ~0103331

Branch CR31382_2 has been deleted by mnt.

SHA-1: 5a42d15f8e88affe6b1716123a8e567b7fe7bddc

git

2021-08-21 14:31

administrator   ~0103332

Branch CR31382_3 has been deleted by mnt.

SHA-1: 5683e2df45c38fae113f16769e8c6763acc74585

git

2021-08-21 14:31

administrator   ~0103333

Branch CR31382_4 has been deleted by mnt.

SHA-1: ea11886458d8e952efc82c295731913f822658cd

git

2021-08-21 14:31

administrator   ~0103334

Branch CR31382_5 has been deleted by mnt.

SHA-1: 0bf1a152f08be0a3d8a4f0f88282f56598594a1c

git

2021-08-21 14:32

administrator   ~0103335

Branch CR31382_6 has been deleted by mnt.

SHA-1: ad0cc3c986b72d249fe80d7a3cf29e115d78ab9e

git

2021-08-21 14:32

administrator   ~0103336

Branch CR31382_7 has been deleted by mnt.

SHA-1: 19807e831e719b183eb58fef7fafc4726307f907

Related Changesets

occt: master da80ff68

2020-11-10 04:52:30

dpasukhi


Committer: bugmaster Details Diff
0031382: Data Exchange - BinXCAF should preserve length unit information

Possibility for adding LengthUnit info to XCAF document using special class XCAFDoc_LenghtUnit and XCAFDoc_LenghtUnitTool is implemented.
Package UnitsMethods is split: geom methods were placed to new file GeomConvert_Units which is in the toolkit TKXSBase, internal step scale factors was placed to StepData.
Updated UnitMethods to convert scale factor to different unit types.
Now, XSAlgo::XSAlgo_AlgoContainer is used to update unit info from static interface values.
New Draw command "XSetLengthUnit" and "XGetLengthUnit" for set or get XDE attribute.
Upgraded tests for STEP, IGES, OBJ, glTF, VRML formats to check area regressing with used unit.
Upgraded tests\de test cases to use any units in the "loop back" algorithms.
Affected Issues
0031382
mod - src/AIS/AIS_Plane.cxx Diff File
mod - src/BinMXCAFDoc/BinMXCAFDoc.cxx Diff File
mod - src/BinMXCAFDoc/BinMXCAFDoc.hxx Diff File
add - src/BinMXCAFDoc/BinMXCAFDoc_LengthUnitDriver.cxx Diff File
add - src/BinMXCAFDoc/BinMXCAFDoc_LengthUnitDriver.hxx Diff File
mod - src/BinMXCAFDoc/FILES Diff File
mod - src/GeomConvert/FILES Diff File
add - src/GeomConvert/GeomConvert_Units.cxx Diff File
add - src/GeomConvert/GeomConvert_Units.hxx Diff File
mod - src/GeomToStep/GeomToStep_MakeCartesianPoint.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeCircle.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeCircle_gen.pxx Diff File
mod - src/GeomToStep/GeomToStep_MakeConicalSurface.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeCylindricalSurface.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeEllipse.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeEllipse_gen.pxx Diff File
mod - src/GeomToStep/GeomToStep_MakeHyperbola.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeParabola.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeRectangularTrimmedSurface.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeSphericalSurface.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeSurface.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeToroidalSurface.cxx Diff File
mod - src/GeomToStep/GeomToStep_MakeVector.cxx Diff File
mod - src/IGESCAFControl/IGESCAFControl_Reader.cxx Diff File
mod - src/IGESCAFControl/IGESCAFControl_Writer.cxx Diff File
mod - src/IGESCAFControl/IGESCAFControl_Writer.hxx Diff File
mod - src/IGESData/IGESData_BasicEditor.cxx Diff File
mod - src/IGESData/IGESData_GlobalSection.cxx Diff File
mod - src/IGESData/IGESData_GlobalSection.hxx Diff File
mod - src/IGESData/IGESData_IGESModel.cxx Diff File
mod - src/IGESData/IGESData_IGESModel.hxx Diff File
mod - src/PrsDim/PrsDim_AngleDimension.cxx Diff File
mod - src/PrsDim/PrsDim_Dimension.cxx Diff File
mod - src/RWGltf/RWGltf_CafWriter.cxx Diff File
mod - src/RWMesh/RWMesh_CafReader.cxx Diff File
mod - src/RWMesh/RWMesh_CafReader.hxx Diff File
mod - src/RWObj/RWObj_CafWriter.cxx Diff File
mod - src/ShapeAnalysis/ShapeAnalysis_Edge.cxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Reader.cxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Reader.hxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Writer.cxx Diff File
mod - src/STEPCAFControl/STEPCAFControl_Writer.hxx Diff File
mod - src/STEPConstruct/STEPConstruct_UnitContext.cxx Diff File
mod - src/STEPControl/STEPControl_ActorRead.cxx Diff File
mod - src/STEPControl/STEPControl_ActorWrite.cxx Diff File
mod - src/STEPControl/STEPControl_Reader.cxx Diff File
mod - src/STEPControl/STEPControl_Reader.hxx Diff File
mod - src/STEPControl/STEPControl_Writer.cxx Diff File
mod - src/StepData/FILES Diff File
add - src/StepData/StepData_GlobalFactors.cxx Diff File
add - src/StepData/StepData_GlobalFactors.hxx Diff File
mod - src/StepData/StepData_StepModel.cxx Diff File
mod - src/StepData/StepData_StepModel.hxx Diff File
mod - src/StepFile/StepFile_ReadData.cxx Diff File
mod - src/StepToGeom/StepToGeom.cxx Diff File
mod - src/StepToTopoDS/StepToTopoDS_TranslateEdge.cxx Diff File
mod - src/TKernel/PACKAGES Diff File
mod - src/TKXSBase/PACKAGES Diff File
mod - src/TopoDSToStep/TopoDSToStep_MakeStepFace.cxx Diff File
mod - src/UnitsMethods/FILES Diff File
mod - src/UnitsMethods/UnitsMethods.cxx Diff File
mod - src/UnitsMethods/UnitsMethods.hxx Diff File
add - src/UnitsMethods/UnitsMethods_LengthUnit.hxx Diff File
mod - src/XCAFDoc/FILES Diff File
mod - src/XCAFDoc/GUID.txt Diff File
mod - src/XCAFDoc/XCAFDoc.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_DocumentTool.cxx Diff File
mod - src/XCAFDoc/XCAFDoc_DocumentTool.hxx Diff File
add - src/XCAFDoc/XCAFDoc_LengthUnit.cxx Diff File
add - src/XCAFDoc/XCAFDoc_LengthUnit.hxx Diff File
mod - src/XDEDRAW/XDEDRAW.cxx Diff File
mod - src/XDEDRAW/XDEDRAW_Common.cxx Diff File
mod - src/XDEDRAW/XDEDRAW_Shapes.cxx Diff File
mod - src/XmlMXCAFDoc/FILES Diff File
mod - src/XmlMXCAFDoc/XmlMXCAFDoc.cxx Diff File
mod - src/XmlMXCAFDoc/XmlMXCAFDoc.hxx Diff File
add - src/XmlMXCAFDoc/XmlMXCAFDoc_LengthUnitDriver.cxx Diff File
add - src/XmlMXCAFDoc/XmlMXCAFDoc_LengthUnitDriver.hxx Diff File
mod - src/XSAlgo/XSAlgo_AlgoContainer.cxx Diff File
mod - src/XSDRAWSTEP/XSDRAWSTEP.cxx Diff File
mod - src/XSDRAWSTLVRML/XSDRAWSTLVRML.cxx Diff File
mod - tests/bugs/xde/bug22962 Diff File
add - tests/bugs/xde/bug31382 Diff File
mod - tests/de/begin Diff File
mod - tests/de/end Diff File
mod - tests/de/iges_1/A2 Diff File
mod - tests/de/iges_1/B4 Diff File
mod - tests/de/iges_1/M9 Diff File
mod - tests/de/iges_2/H1 Diff File
mod - tests/de/step_1/E4 Diff File
mod - tests/de/step_1/J5 Diff File
mod - tests/de/step_1/O7 Diff File
mod - tests/de/step_2/A3 Diff File
mod - tests/de/step_2/M3 Diff File
mod - tests/de/step_2/Q2 Diff File
mod - tests/de/step_2/X1 Diff File
mod - tests/de/step_3/A5 Diff File
mod - tests/de/step_3/F2 Diff File
mod - tests/de/step_4/A5 Diff File
mod - tests/de/step_4/C9 Diff File
mod - tests/de/step_4/E3 Diff File
mod - tests/de/step_4/G6 Diff File
mod - tests/de/step_5/B2 Diff File
mod - tests/de_mesh/gltf_write/helmet Diff File
mod - tests/de_mesh/obj_read/ship_boat Diff File
mod - tests/de_mesh/obj_write/mustang Diff File

Issue History

Date Modified Username Field Change
2020-02-18 17:30 kgv New Issue
2020-02-18 17:30 kgv Assigned To => gka
2020-02-18 17:30 kgv Relationship added related to 0031136
2020-09-11 17:35 gka Target Version 7.5.0 => 7.6.0
2020-10-01 10:32 kgv Summary 0031136: Modeling Data - BinXCAF should preserve length unit information => Modeling Data - BinXCAF should preserve length unit information
2020-10-01 11:35 kgv Summary Modeling Data - BinXCAF should preserve length unit information => Data Exchange - BinXCAF should preserve length unit information
2020-10-29 09:45 szy Assigned To gka => skl
2020-10-29 09:45 szy Status new => assigned
2020-11-10 07:53 git Note Added: 0096632
2020-11-10 07:55 git Note Added: 0096633
2020-11-10 08:41 git Note Added: 0096634
2020-11-10 14:36 git Note Added: 0096638
2020-11-11 10:19 git Note Added: 0096652
2020-11-11 15:54 skl Note Added: 0096659
2020-11-11 15:54 skl Assigned To skl => mpv
2020-11-11 15:54 skl Status assigned => resolved
2020-11-11 15:54 skl Steps to Reproduce Updated
2020-11-11 17:01 msv Note Added: 0096662
2020-11-11 17:05 msv Note Added: 0096664
2020-11-11 17:11 kgv Note Added: 0096666
2020-11-11 17:13 kgv Note Edited: 0096666
2020-11-11 17:13 kgv Note Edited: 0096666
2020-11-11 17:26 msv Note Added: 0096668
2020-11-11 17:28 mpv Note Added: 0096669
2020-11-11 17:28 mpv Assigned To mpv => skl
2020-11-11 17:28 mpv Status resolved => assigned
2020-11-12 11:13 git Note Added: 0096690
2020-11-12 18:10 skl Note Added: 0096726
2020-11-12 18:10 skl Assigned To skl => mpv
2020-11-12 18:10 skl Status assigned => resolved
2020-11-12 19:16 kgv Note Added: 0096730
2020-11-13 17:50 mpv Assigned To mpv => skl
2020-11-13 17:50 mpv Status resolved => assigned
2020-11-15 07:18 git Note Added: 0096778
2020-11-16 12:08 git Note Added: 0096788
2020-11-17 10:42 git Note Added: 0096818
2020-11-17 15:04 skl Note Added: 0096828
2020-11-17 15:04 skl Assigned To skl => msv
2020-11-17 15:04 skl Status assigned => resolved
2020-11-17 15:10 kgv Note Added: 0096829
2020-11-17 15:10 kgv Note Edited: 0096829
2020-11-17 15:55 msv Note Added: 0096831
2020-11-17 15:55 msv Assigned To msv => skl
2020-11-17 15:55 msv Status resolved => assigned
2020-11-17 16:07 git Note Added: 0096833
2020-11-18 07:02 git Note Added: 0096858
2020-11-18 11:34 skl Note Added: 0096873
2020-11-18 11:34 skl Assigned To skl => msv
2020-11-18 11:34 skl Status assigned => resolved
2020-11-18 12:17 msv Note Added: 0096878
2020-11-18 12:17 msv Assigned To msv => skl
2020-11-18 12:17 msv Status resolved => assigned
2020-11-18 12:28 git Note Added: 0096880
2020-11-18 12:29 skl Assigned To skl => msv
2020-11-18 12:29 skl Status assigned => resolved
2020-11-18 12:32 msv Note Added: 0096881
2020-11-18 12:32 msv Assigned To msv => bugmaster
2020-11-18 12:32 msv Status resolved => reviewed
2020-11-19 10:56 kgv Note Added: 0096891
2020-11-19 10:56 kgv Assigned To bugmaster => skl
2020-11-19 10:56 kgv Status reviewed => assigned
2020-11-19 10:59 kgv Note Edited: 0096891
2020-11-19 11:02 kgv Note Edited: 0096891
2020-11-19 15:11 skl Note Added: 0096900
2020-11-19 15:11 skl Assigned To skl => kgv
2020-11-19 15:11 skl Status assigned => feedback
2020-11-24 15:27 git Note Added: 0097032
2020-12-10 10:33 kgv Note Added: 0097453
2020-12-24 16:30 git Note Added: 0097891
2020-12-25 16:47 git Note Added: 0097906
2020-12-25 17:26 git Note Added: 0097907
2020-12-28 12:58 skl Assigned To kgv => skl
2020-12-28 12:58 skl Status feedback => assigned
2020-12-28 13:03 git Note Added: 0097958
2020-12-28 16:52 git Note Added: 0097962
2020-12-28 18:59 git Note Added: 0097964
2020-12-29 09:25 git Note Added: 0097969
2020-12-30 11:00 git Note Added: 0097985
2020-12-31 10:18 skl Note Added: 0097995
2020-12-31 10:18 skl Assigned To skl => msv
2020-12-31 10:18 skl Status assigned => resolved
2020-12-31 11:49 msv Note Added: 0097997
2020-12-31 11:50 msv Assigned To msv => skl
2020-12-31 11:50 msv Status resolved => assigned
2020-12-31 16:15 git Note Added: 0098000
2021-01-11 12:05 skl Note Added: 0098050
2021-01-11 12:05 skl Assigned To skl => msv
2021-01-11 12:05 skl Status assigned => resolved
2021-01-11 14:11 msv Note Added: 0098061
2021-01-11 14:12 msv Assigned To msv => skl
2021-01-11 14:12 msv Status resolved => assigned
2021-01-11 14:26 msv Note Added: 0098066
2021-01-11 14:28 msv Note Added: 0098067
2021-01-11 15:19 git Note Added: 0098072
2021-01-11 15:22 git Note Added: 0098073
2021-01-12 10:04 skl Note Added: 0098083
2021-01-12 10:04 skl Assigned To skl => msv
2021-01-12 10:04 skl Status assigned => resolved
2021-01-12 11:16 kgv Note Added: 0098085
2021-01-12 11:24 msv Note Added: 0098086
2021-01-12 11:24 msv Assigned To msv => skl
2021-01-12 11:24 msv Status resolved => assigned
2021-01-13 12:37 skl Note Added: 0098098
2021-01-13 12:37 skl Assigned To skl => msv
2021-01-13 12:37 skl Status assigned => resolved
2021-01-13 14:47 msv Note Added: 0098103
2021-01-13 14:52 msv Note Added: 0098104
2021-01-13 14:52 msv Assigned To msv => bugmaster
2021-01-13 14:52 msv Status resolved => reviewed
2021-01-13 16:24 kgv Note Added: 0098106
2021-01-13 16:24 kgv Assigned To bugmaster => skl
2021-01-13 16:24 kgv Status reviewed => assigned
2021-01-13 16:24 kgv Note Edited: 0098106
2021-01-13 16:25 kgv Note Edited: 0098106
2021-01-13 16:25 kgv Note Edited: 0098106
2021-01-13 16:25 kgv Note Edited: 0098106
2021-01-29 16:28 kgv Assigned To skl => dpasukhi
2021-02-09 23:26 dpasukhi Note Added: 0098803
2021-02-10 23:58 dpasukhi Note Added: 0098822
2021-02-11 23:47 dpasukhi Note Added: 0098834
2021-02-12 23:56 dpasukhi Note Added: 0098854
2021-03-27 01:58 dpasukhi Note Added: 0099775
2021-03-30 23:14 dpasukhi Note Added: 0099897
2021-04-16 19:58 dpasukhi Note Added: 0100355
2021-05-02 23:38 dpasukhi Note Added: 0100750
2021-05-09 21:50 dpasukhi Note Added: 0100835
2021-05-16 23:13 dpasukhi Note Added: 0101078
2021-05-17 12:04 dpasukhi Note Edited: 0101078
2021-05-20 03:23 git Note Added: 0101193
2021-05-23 23:16 dpasukhi Note Added: 0101293
2021-05-24 02:28 git Note Added: 0101295
2021-05-24 16:02 abv Note Added: 0101330
2021-05-25 13:45 git Note Added: 0101356
2021-05-26 13:25 git Note Added: 0101388
2021-05-26 14:44 git Note Added: 0101394
2021-05-30 23:32 dpasukhi Note Added: 0101514
2021-06-03 04:19 git Note Added: 0101565
2021-06-03 12:28 git Note Added: 0101573
2021-06-06 23:45 dpasukhi Note Added: 0101648
2021-06-06 23:51 dpasukhi Note Edited: 0101648
2021-06-17 17:36 kgv Relationship added related to 0032452
2021-06-23 12:21 git Note Added: 0102006
2021-06-24 15:31 git Note Added: 0102030
2021-06-24 15:35 git Note Added: 0102031
2021-06-27 22:59 dpasukhi Note Added: 0102108
2021-08-02 02:59 git Note Added: 0102917
2021-08-03 18:13 kgv Relationship added related to 0032512
2021-08-03 18:13 kgv Relationship added related to 0032514
2021-08-12 02:57 git Note Added: 0103144
2021-08-13 19:06 git Note Added: 0103191
2021-08-13 19:14 git Note Added: 0103192
2021-08-15 23:50 dpasukhi Note Added: 0103225
2021-08-18 15:08 git Note Added: 0103274
2021-08-18 21:13 git Note Added: 0103292
2021-08-18 22:45 git Note Added: 0103295
2021-08-18 23:21 git Note Added: 0103296
2021-08-19 12:34 git Note Added: 0103301
2021-08-19 14:50 git Note Added: 0103306
2021-08-19 16:20 git Note Added: 0103311
2021-08-19 17:41 dpasukhi Note Added: 0103312
2021-08-19 17:41 dpasukhi Assigned To dpasukhi => kgv
2021-08-19 17:41 dpasukhi Status assigned => resolved
2021-08-19 17:59 kgv Assigned To kgv => bugmaster
2021-08-19 17:59 kgv Status resolved => reviewed
2021-08-19 19:07 kgv Assigned To bugmaster => dpasukhi
2021-08-19 19:07 kgv Status reviewed => assigned
2021-08-19 22:28 git Note Added: 0103314
2021-08-20 10:00 kgv Assigned To dpasukhi => bugmaster
2021-08-20 10:00 kgv Status assigned => resolved
2021-08-20 10:00 kgv Status resolved => reviewed
2021-08-20 10:06 dpasukhi Note Edited: 0103312
2021-08-20 15:47 kgv Note Added: 0103319
2021-08-21 14:19 bugmaster Note Added: 0103326
2021-08-21 14:19 bugmaster Status reviewed => tested
2021-08-21 14:22 bugmaster Changeset attached => occt master da80ff68
2021-08-21 14:22 bugmaster Status tested => verified
2021-08-21 14:22 bugmaster Resolution open => fixed
2021-08-21 14:31 git Note Added: 0103329
2021-08-21 14:31 git Note Added: 0103330
2021-08-21 14:31 git Note Added: 0103331
2021-08-21 14:31 git Note Added: 0103332
2021-08-21 14:31 git Note Added: 0103333
2021-08-21 14:31 git Note Added: 0103334
2021-08-21 14:32 git Note Added: 0103335
2021-08-21 14:32 git Note Added: 0103336
2021-09-04 16:01 smoskvin Test case number => pointcloud/reader/ply_units_m,move_to_origin
2021-09-04 16:16 bugmaster Test case number pointcloud/reader/ply_units_m,move_to_origin => bugs/xde/bug31382
2021-10-18 11:43 kgv Relationship added related to 0026733
2021-12-23 13:42 kgv Relationship added parent of 0032748
2022-04-29 16:48 kgv Relationship added related to 0032954