MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031279Open CASCADE[OCCT] OCCT:Visualizationpublic2019-12-26 13:522020-01-17 20:51
Reporterkgv 
Assigned Tomzernova 
PrioritynormalSeverityminor 
StatusassignedResolutionopen 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.5.0*Fixed in Version 
Summary0031279: Visualization, TKOpenGl - environment background is misplaced within Ray-Tracing
DescriptionEnvironment texture displayed as background in Ray-Tracing is misplaced (note that it is not the same for Path-Tracing).
Steps To Reproducev3d/raytrace/bug31279
TagsNo tags attached.
Test case numberv3d/raytrace/bug31279
Attached Filespng file icon raytrace_env_KO.png (60,259 bytes) 2019-12-26 13:52

- Relationships
related to 0031225verifiedbugmaster Visualization, TKOpenGl - support cubemap for environment texture within Ray-Tracing 
child of 0024130closedbugmaster Implementing ray tracing visualization core 

-  Notes
(0089865)
git (administrator)
2020-01-13 12:01

Branch CR31279 has been created by mzernova.

SHA-1: 4896ceb96f916fcfb8ca2b2adde25716d8bdfb99


Detailed log of new commits:

Author: mzernova
Date: Mon Jan 13 10:21:10 2020 +0300

    0031279: Visualization, TKOpenGl - environment background is misplaced within Ray-Tracing
    
    Fixed problem with misplacing background texture in Ray-Tracing.
(0089866)
mzernova (developer)
2020-01-13 12:06

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR31279-master-mzernova [^]
(0089881)
git (administrator)
2020-01-14 11:11

Branch CR31279 has been updated forcibly by mzernova.

SHA-1: ea849b911aacb0dc16778413b8288c310cd91660
(0089888)
git (administrator)
2020-01-14 18:01

Branch CR31279 has been updated by mzernova.

SHA-1: f584056b2c9e547ce86927eb5923910242a1df6c


Detailed log of new commits:

Author: mzernova
Date: Tue Jan 14 17:52:49 2020 +0300

    Fixed problem with refraction.

(0089889)
git (administrator)
2020-01-14 18:01

Branch CR31279_1 has been created by mzernova.

SHA-1: dce76b7d3027628efe0f88bda6db2b0a61698c2a


Detailed log of new commits:

Author: mzernova
Date: Mon Jan 13 10:21:10 2020 +0300

    0031279: Visualization, TKOpenGl - environment background is misplaced within Ray-Tracing
    
    Fixed problem with misplacing background texture in Ray-Tracing.
(0089891)
mzernova (developer)
2020-01-14 19:14

The patch CR31279 is ready to review
(0089892)
kgv (developer)
2020-01-14 20:02

Test case should be created for testing this bug.
(0089900)
git (administrator)
2020-01-15 16:26

Branch CR31279 has been updated by mzernova.

SHA-1: 6f28d4f16566fd2bcb7e70c1083d091d480ebaac


Detailed log of new commits:

Author: mzernova
Date: Wed Jan 15 16:20:03 2020 +0300

    Add test

(0089901)
git (administrator)
2020-01-15 16:26

Branch CR31279_1 has been updated forcibly by mzernova.

SHA-1: 05ae8e9a792d502ba8a483d8c184f8ee5b9ed8d8
(0089902)
mzernova (developer)
2020-01-15 16:32

The patch CR31279 is ready to review
(0089910)
git (administrator)
2020-01-16 11:06

Branch CR31279 has been updated by mzernova.

SHA-1: e20dc9c27f42970fab9b798ec330b667c9f28e8a


Detailed log of new commits:

Author: mzernova
Date: Thu Jan 16 10:59:41 2020 +0300

    remarks from osa

(0089911)
git (administrator)
2020-01-16 11:06

Branch CR31279_1 has been updated forcibly by mzernova.

SHA-1: e4789769f9a5ab22c12ca12d239a917d6c3e42d5
(0089934)
bugmaster (administrator)
2020-01-17 20:47
edited on: 2020-01-17 20:51

I can not take this fix to IR because:

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR31279-master-mzernova/view/COMPARE/job/CR31279-master-mzernova-OCCT-Windows-64-VC14-opt-test-compare/ [^]

Problem v3d raytrace bug31279 is permanently reproduced
I restarted 5 time


- Issue History
Date Modified Username Field Change
2019-12-26 13:52 kgv New Issue
2019-12-26 13:52 kgv Assigned To => mzernova
2019-12-26 13:52 kgv File Added: raytrace_env_KO.png
2019-12-26 13:53 kgv Relationship added related to 0031225
2020-01-13 12:01 git Note Added: 0089865
2020-01-13 12:06 mzernova Note Added: 0089866
2020-01-14 11:11 git Note Added: 0089881
2020-01-14 18:01 git Note Added: 0089888
2020-01-14 18:01 git Note Added: 0089889
2020-01-14 19:14 mzernova Note Added: 0089891
2020-01-14 19:14 mzernova Assigned To mzernova => kgv
2020-01-14 19:14 mzernova Status new => resolved
2020-01-14 19:14 mzernova Steps to Reproduce Updated View Revisions
2020-01-14 20:02 kgv Note Added: 0089892
2020-01-14 20:41 kgv Assigned To kgv => mzernova
2020-01-14 20:41 kgv Status resolved => assigned
2020-01-14 20:44 kgv Steps to Reproduce Updated View Revisions
2020-01-14 20:44 kgv Product Version 7.3.0 => 7.0.0
2020-01-14 20:46 kgv Relationship added child of 0024130
2020-01-15 16:26 git Note Added: 0089900
2020-01-15 16:26 git Note Added: 0089901
2020-01-15 16:32 mzernova Note Added: 0089902
2020-01-15 16:32 mzernova Assigned To mzernova => kgv
2020-01-15 16:32 mzernova Status assigned => resolved
2020-01-15 16:32 mzernova Steps to Reproduce Updated View Revisions
2020-01-15 16:35 kgv Assigned To kgv => osa
2020-01-16 11:06 git Note Added: 0089910
2020-01-16 11:06 git Note Added: 0089911
2020-01-17 12:16 osa Assigned To osa => bugmaster
2020-01-17 12:16 osa Status resolved => reviewed
2020-01-17 16:02 bugmaster Test case number => v3d/raytrace/bug31279
2020-01-17 20:47 bugmaster Note Added: 0089934
2020-01-17 20:48 bugmaster Assigned To bugmaster => mzernova
2020-01-17 20:48 bugmaster Status reviewed => assigned
2020-01-17 20:51 bugmaster Note Edited: 0089934 View Revisions


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker