MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031258Community[OCCT] OCCT:Meshpublic2019-12-22 07:002020-01-22 09:31
Reporterhwliu11 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusreviewedResolutionopen 
PlatformIntel X86OSWindowsOS Version10.0.18362
Product Version[OCCT] 7.4.0 
Target Version[OCCT] 7.5.0*Fixed in Version 
Summary0031258: Mesh - OCCT 7.4.0 VIS get wrong render data
DescriptionMy file is a face as below,in OCCT 7.3 Draw Test Harness,it render right.But int 7.4.0,don't get right render data.
The issue information may be wrong,I cant select OCCT 7.4.0 and VS2014 64 bit
Steps To Reproducepload VIS
restore 1.brep 1
vinit
vdisplay 1
TagsNo tags attached.
Test case number
Attached Files? file icon 1.brep (2,042 bytes) 2019-12-22 07:00
png file icon 1_730_OK.png (12,325 bytes) 2019-12-31 10:58
png file icon 1_740_KO.png (4,674 bytes) 2019-12-31 10:58

- Relationships

-  Notes
(0089978)
git (administrator)
2020-01-21 13:40

Branch CR31258 has been created by oan.

SHA-1: 008cc5f6c2595352d031bbb125176dea3808f280


Detailed log of new commits:

Author: oan
Date: Tue Jan 21 13:21:38 2020 +0300

    0031258: Mesh - OCCT 7.4.0 VIS get wrong render data
    
    Check intervals for infinite value causing exception in GeomLib::NormEstim
(0089979)
oan (developer)
2020-01-21 13:45

The bug is caused by exception in GeomLib::NormEstim due to infinite value returned by CN intervals.
(0089984)
git (administrator)
2020-01-21 15:23

Branch CR31258 has been updated forcibly by oan.

SHA-1: 6ce3bc7b7204db96980297837e1e457f1b27273d
(0089985)
oan (developer)
2020-01-21 15:44

Please review:
http://jenkins-test-12.nnov.opencascade.com/view/CR31258-master-OAN/view/COMPARE/ [^]

- Issue History
Date Modified Username Field Change
2019-12-22 07:00 hwliu11 New Issue
2019-12-22 07:00 hwliu11 Assigned To => ssv
2019-12-22 07:00 hwliu11 File Added: 1.brep
2019-12-31 10:58 kgv File Added: 1_730_OK.png
2019-12-31 10:58 kgv File Added: 1_740_KO.png
2019-12-31 10:58 kgv Assigned To ssv => oan
2019-12-31 10:58 kgv Category OCCT:VIS => OCCT:Mesh
2019-12-31 10:58 kgv Summary OCCT 7.4.0 VIS get wrong render data => Mesh - OCCT 7.4.0 VIS get wrong render data
2019-12-31 10:59 kgv Product Version => 7.4.0
2019-12-31 10:59 kgv Target Version => 7.5.0*
2020-01-21 13:40 git Note Added: 0089978
2020-01-21 13:45 oan Note Added: 0089979
2020-01-21 15:23 git Note Added: 0089984
2020-01-21 15:44 oan Note Added: 0089985
2020-01-21 15:44 oan Assigned To oan => msv
2020-01-21 15:44 oan Status new => resolved
2020-01-22 09:31 msv Assigned To msv => bugmaster
2020-01-22 09:31 msv Status resolved => reviewed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker