View Issue Details

IDProjectCategoryView StatusLast Update
0031182CommunityOCCT:Data Exchangepublic2020-12-02 17:12
ReporterVico Liang Assigned Togka  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version7.4.0 
Target Version7.5.0Fixed in Version7.5.0 
Summary0031182: Data Exchange - STEP export unicode name as "???"
DescriptionTo reproduce the issue, set the object name to Unicode such as Chinese "中文名字"
You'll see from the output file step, the name become unreadable with ??
TagsNo tags attached.
Test case numberbugs xde bug31851

Attached Files

  • as1-oc-214_chinese.xbf (289,702 bytes)

Relationships

duplicate of 0031851 closedbugmaster Open CASCADE Data Exchange, STEP - enable Unicode symbols in STEP export 
child of 0022484 closedbugmaster Open CASCADE UNICODE characters support. 

Activities

kgv

2019-12-17 13:34

developer  

as1-oc-214_chinese.xbf (289,702 bytes)

abv

2020-10-25 20:45

manager   ~0096259

Fixed by patch for 0031851

Issue History

Date Modified Username Field Change
2019-11-20 19:09 Vico Liang New Issue
2019-11-20 19:09 Vico Liang Assigned To => gka
2019-12-17 13:30 kgv Summary STEP export unicode name as "???" => Data Exchange - STEP export unicode name as "???"
2019-12-17 13:34 kgv File Added: as1-oc-214_chinese.xbf
2019-12-17 13:35 kgv Relationship added child of 0022484
2020-09-11 17:36 gka Target Version 7.5.0 => 7.6.0
2020-10-25 20:41 abv Relationship added duplicate of 0031851
2020-10-25 20:45 abv Test case number => bugs xde bug31851
2020-10-25 20:45 abv Note Added: 0096259
2020-10-25 20:45 abv Status new => feedback
2020-10-25 20:45 abv Target Version 7.6.0 => 7.5.0
2020-10-25 20:45 abv Status feedback => verified
2020-12-02 16:22 emo Fixed in Version => 7.5.0
2020-12-02 17:04 emo Resolution open => fixed
2020-12-02 17:12 emo Status verified => closed