MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0031000Community[OCCT] OCCT:Data Exchangepublic2019-09-25 17:362020-12-19 15:23
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 6.3.1 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0031000: Data Exchange - STEP file cannot be opened due to lower-case special token End-ISO-10303-21
DescriptionAttached STEP file cannot be opened due to lower-case symbols in special token "End-ISO-10303-21" at the end of the file.
Steps To Reproduce
pload XDE
testreadstep __Acube111.stp s


Result:
Status from reading STEP file __Acube111.stp : error during read
TagsNo tags attached.
Test case numberbugs/step/bug31000
Attached Files? file icon __Acube111.stp (7,741 bytes) 2019-09-25 17:36

- Relationships
related to 0031970verifiedbugmaster Open CASCADE Data Exchange, STEP reader - parser syntax error messages are inaccessible 

-  Notes
(0087516)
kgv (developer)
2019-09-25 17:42

By the way, OCCT 6.3.1 is more informative on reporting parser error, although it reports a line before error:
      ...    Step File Reading : __Acube111.stp
    ****    StepFile Error : At line 232, parse error    ****
Status from reading STEP file __Acube111.stp : error during read
(0097034)
git (administrator)
2020-11-24 15:53

Branch CR31000 has been created by dpasukhi.

SHA-1: c30695ef79cf39b58c4c46229f349066089f6744


Detailed log of new commits:

Author: dpasukhi
Date: Tue Nov 24 15:52:39 2020 +0300

    0031000: Data Exchange - STEP file cannot be opened due to lower-case special token End-ISO-10303-21
    
    Update flex lexical scanner (step.lex lex.step.cxx) to parse special tokens in a case insensitive manner
(0097514)
abv (manager)
2020-12-12 07:42

Reviewed, please integrate (together with 0031756)
OCCT branch CR31756_4
(0097735)
bugmaster (administrator)
2020-12-19 14:47

Combination -
OCCT branch : IR-2020-12-18
master SHA - 04114fd201c20efe9fbe85f00bec9a99ae3747ad
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-12-18 SHA - 290e5c74e8fef71947cadf90acb8e43c81ed10a1
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17709.570000000054 / 17744.450000000124 [-0.20%]
Products
Total CPU difference: 12258.480000000121 / 12330.210000000125 [-0.58%]
Windows-64-VC14:
OCCT
Total CPU difference: 19272.796875 / 19429.1875 [-0.80%]
Products
Total CPU difference: 13712.859375 / 13755.5 [-0.31%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0097801)
git (administrator)
2020-12-19 15:23

Branch CR31000 has been deleted by inv.

SHA-1: c30695ef79cf39b58c4c46229f349066089f6744

- Related Changesets
occt: master 465ffe28
Timestamp: 2020-11-24 12:52:39
Author: dpasukhi
Committer: bugmaster
Details ] Diff ]
0031000: Data Exchange - STEP file cannot be opened due to lower-case special token End-ISO-10303-21

Update flex lexical scanner (step.lex lex.step.cxx) to parse special tokens in a case insensitive manner
mod - src/StepFile/lex.step.cxx Diff ] File ]
mod - src/StepFile/step.lex Diff ] File ]
add - tests/bugs/step/bug31000 Diff ] File ]

- Issue History
Date Modified Username Field Change
2019-09-25 17:36 kgv New Issue
2019-09-25 17:36 kgv Assigned To => gka
2019-09-25 17:36 kgv File Added: __Acube111.stp
2019-09-25 17:37 kgv Steps to Reproduce Updated View Revisions
2019-09-25 17:42 kgv Note Added: 0087516
2019-09-25 17:42 kgv Product Version 7.4.0 => 6.3.1
2020-09-11 17:51 gka Target Version 7.5.0 => 7.6.0*
2020-11-23 21:14 gka Assigned To gka => dpasukhi
2020-11-24 15:53 git Note Added: 0097034
2020-12-02 12:24 kgv Relationship added related to 0031970
2020-12-02 12:34 kgv Status new => assigned
2020-12-11 17:48 abv Assigned To dpasukhi => abv
2020-12-11 17:48 abv Status assigned => resolved
2020-12-12 07:42 abv Note Added: 0097514
2020-12-12 07:42 abv Assigned To abv => bugmaster
2020-12-12 07:42 abv Status resolved => reviewed
2020-12-19 14:47 bugmaster Note Added: 0097735
2020-12-19 14:47 bugmaster Status reviewed => tested
2020-12-19 14:51 bugmaster Test case number => bugs/step/bug31000
2020-12-19 15:06 bugmaster Changeset attached => occt master 465ffe28
2020-12-19 15:06 bugmaster Status tested => verified
2020-12-19 15:06 bugmaster Resolution open => fixed
2020-12-19 15:23 git Note Added: 0097801


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker