MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030702Community[OCCT] OCCT:Configurationpublic2019-05-08 09:572019-05-26 10:48
ReporterVico Liang 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformMacOSOSOS VersionX
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0030702: Configuration, CMake - error for iOS build due to searching macos frameworks
DescriptionCMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Appkit_LIB
    linked by target "TKService" in directory /software/OCCT/git/src/TKService
    linked by target "TKOpenGl" in directory /software/OCCT/git/src/TKOpenGl
OpenGlLibs_LIB
    linked by target "TKService" in directory /software/OCCT/git/src/TKService
    linked by target "TKV3d" in directory /software/OCCT/git/src/TKV3d
    linked by target "TKOpenGl" in directory /software/OCCT/git/src/TKOpenGl
Steps To Reproduce1. get the latest OCCT code from git
2. macos 10.14, xcode 10.1, cmake 3.14
3. build with cmake with toolchain: https://github.com/leetal/ios-cmake [^]
4. disable xdraw package build in cmake config.
5. run cmake config operation. CMake Error: Appkit_LIB and OpenGlLibs_LIB.
TagsNo tags attached.
Test case numberNot required
Attached Files? file icon occt_csf.cmake (2,773 bytes) 2019-05-09 06:00
txt file icon occ_occt_build_ios.sh.txt (4,351 bytes) 2019-05-24 13:24

- Relationships

-  Notes
(0084269)
Vico Liang (developer)
2019-05-09 06:02

The fix is uploaded occt_csf.cmake. IOS branch handled to fix the issue.
(0084593)
git (administrator)
2019-05-24 11:00

Branch CR30702 has been created by kgv.

SHA-1: 13ec02d48ca6883428be56b03f4e3ccec6af2ff6


Detailed log of new commits:

Author: kgv
Date: Fri May 24 11:00:35 2019 +0300

    0030702: Configuration, CMake - error for iOS build due to searching macos frameworks
    
    Look for UIKit+OpenGLES on iOS instead of AppKit+OpenGL.
(0084595)
git (administrator)
2019-05-24 11:20

Branch CR30702 has been updated forcibly by kgv.

SHA-1: 9a1810c6269d4378ce37938a957caeb691575029
(0084600)
kgv (developer)
2019-05-24 13:04
edited on: 2019-05-24 13:27

Please raise the patch.

http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30702-master-KGV/ [^]

Manually tested on XCode 10.2 + iOS SDK 12.2 + CMake 3.14 + leetal/ios-cmake 3.0.2.

(0084623)
git (administrator)
2019-05-26 10:48

Branch CR30702 has been deleted by inv.

SHA-1: 9a1810c6269d4378ce37938a957caeb691575029

- Related Changesets
occt: master 48ba1811
Timestamp: 2019-05-24 08:00:35
Author: kgv
Committer: bugmaster
Details ] Diff ]
0030702: Configuration, CMake - error for iOS build due to searching macos frameworks

Look for UIKit+OpenGLES on iOS instead of AppKit+OpenGL.
mod - adm/cmake/occt_csf.cmake Diff ] File ]
mod - adm/genproj.tcl Diff ] File ]
mod - adm/qmake/OccToolkit.pri Diff ] File ]

- Issue History
Date Modified Username Field Change
2019-05-08 09:57 Vico Liang New Issue
2019-05-08 09:57 Vico Liang Assigned To => bugmaster
2019-05-08 10:07 Vico Liang Steps to Reproduce Updated View Revisions
2019-05-09 06:00 Vico Liang File Added: occt_csf.cmake
2019-05-09 06:02 Vico Liang Note Added: 0084269
2019-05-24 10:28 kgv Summary cmake error for ios build => Configuration, CMake - error for iOS build
2019-05-24 10:29 kgv Summary Configuration, CMake - error for iOS build => Configuration, CMake - error for iOS build due to searching desktop frameworks
2019-05-24 10:29 kgv Summary Configuration, CMake - error for iOS build due to searching desktop frameworks => Configuration, CMake - error for iOS build due to searching macos frameworks
2019-05-24 11:00 git Note Added: 0084593
2019-05-24 11:20 git Note Added: 0084595
2019-05-24 13:04 kgv Note Added: 0084600
2019-05-24 13:04 kgv Status new => resolved
2019-05-24 13:04 kgv Product Version 7.4.0* => 7.3.0
2019-05-24 13:04 kgv Status resolved => reviewed
2019-05-24 13:23 kgv File Added: occ_occt_build_ios.sh
2019-05-24 13:24 kgv File Deleted: occ_occt_build_ios.sh
2019-05-24 13:24 kgv File Added: occ_occt_build_ios.sh.txt
2019-05-24 13:24 kgv Note Edited: 0084600 View Revisions
2019-05-24 13:26 kgv Note Edited: 0084600 View Revisions
2019-05-24 13:27 kgv Note Edited: 0084600 View Revisions
2019-05-24 16:46 bugmaster Test case number => Not required
2019-05-24 16:48 bugmaster Status reviewed => tested
2019-05-25 19:58 bugmaster Changeset attached => occt master 48ba1811
2019-05-25 19:58 bugmaster Status tested => verified
2019-05-25 19:58 bugmaster Resolution open => fixed
2019-05-26 10:48 git Note Added: 0084623


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker