View Issue Details

IDProjectCategoryView StatusLast Update
0030592Open CASCADEOCCT:DRAWpublic2019-11-05 10:49
Reporterkgv Assigned Tobugmaster  
PrioritynormalSeverityintegration request 
Status closedResolutionfixed 
Target Version7.4.0Fixed in Version7.4.0 
Summary0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg
DescriptionCurrently Draw Harness provides a set of commands configuring viewer background:
- vsetcolorbg sets background color.
- vsetgradientbg sets gradient (between 2 colors) background.
- vsetgrbgmode modifies gradient filling mode.
- vsetbg set background image.
- vsetbgmode modifies background image filling mode.
This set is too much for a functionality managing the same thing - viewer background.

It is desired to merge all possible options within single command vbackground (preserving old commands as aliases to new command), and make new command following best practices. In particular, color should be parsed via ViewerTest::ParseColor() command, and it should be possible entering filling type via name instead of integer value.

In addition, ViewerTest::ParseColor() should be extended to:
- Allow [0,255] color components definition by checking that all arguments are integers, at least one argument is >=2 and all arguments <=255.
  So that 0 0 0 and 1 0 0 will be parsed as floating [0.0,1.0] values.
- Support hex color codes like #0000FF and #0000FF00.

Existing test cases should be updated to use new vbackground command syntax with colors specified by name or float values.
Steps To ReproduceNot required
TagsNo tags attached.
Test case numberNot required

Relationships

parent of 0030623 closedbugmaster Draw Harness - support hex color codes within ViewerTest::ParseColor() 
parent of 0031129 newkgv Visualization - revise background / environment API 
Not all the children of this issue are yet resolved or closed.

Activities

git

2019-03-22 16:00

administrator   ~0083198

Branch CR30592 has been created by tizmaylo.

SHA-1: fb2e9c06569ed0016f5536495373a45c1e87d950


Detailed log of new commits:

Author: tiv
Date: Fri Mar 22 15:34:25 2019 +0300

    0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg
    
    ViewerTest::ParseColor() functionality is extended to:
      - Allow [0, 255] color components definition by checking that all arguments are integers, at least one argument is >= 2.
        So that 0 0 0 and 1 0 0 are parsed as real [0.0, 1.0] values.
      - Support hex color codes like #0000FF and #0000FFFF (including short hex variants #00F and #00FF).

git

2019-03-29 21:39

administrator   ~0083300

Branch CR30592_1 has been created by tizmaylo.

SHA-1: bece5b4107db758bca612ffd0fb7b368784c5745


Detailed log of new commits:

Author: tiv
Date: Fri Mar 29 21:32:50 2019 +0300

    0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg
    
    Command vbackground is created. Tests are not changed yet.

kgv

2019-03-30 17:39

developer   ~0083319

Please split patch in two pieces - Color parsing improvements and vbackground command introduction (register dedicated issue for this purpose), so that one patch can be based on another one (if necessary).

+} // namespace
+
+
+//=======================================================================
+// function : ColorFromName
...
+  Quantity_ColorRGBA aColor;
+
+  if (!Quantity_Color::ColorFromName (theColorNameString, aColor.ChangeRGB ()))
+  {
+    return false;
+  }
+  theColor = aColor;
+
...
+
+  ColorInteger aHexColorInteger;
+
+  if (!ConvertStringToInteger (aHexColorString, aHexColorInteger, 16u))

There are double empty lines / redundant empty lines in the patch.
Please check your formatting settings and avoid putting too many empty lines - their presence should split logical blocks in the code.

+  Quantity_NameOfColor aColorName;
+
+  if (!ColorFromName (theColorNameString, aColorName))

Please avoid uninitialized variables, even if they are supposed to be initialized by called function.

+Standard_Boolean Quantity_Color::ColorFromName (const Standard_CString theColorNameString, Quantity_Color& theColor)
+{
...
+bool Quantity_Color::ColorFromHex (const Standard_CString theHexColorString, Quantity_Color& theColor)
+{

These are probably inline functions.

+  //! Defines all possible lengthes of strings representing color in hex format
+  struct HexColorLengthStruct

lengths.

+  //! value, where color components represent digits: an alpha component is a low number and a red component is a high
+  //! number)
...
+  //! @tparam TheLessComparableType the type of the passed values (it must support the less comparability for its
+  //! values)

[here and in other places] line length limits within Coding Rules are suggestive, not imperative.
It is better splitting long text by lines basing on sentence / logical parts,
rather than aborting line in the middle.

+  //! Checks if the charater is a hexadecimal digit (0 .. 9, a .. f, A .. F)

character.
Consider installing Spell Checked extension to you IDE to avoid misprints.

+  //! @return true if parsing was successfull, or false otherwise

successful

+typedef NCollection_Vec3<Standard_ShortReal> Graphic3d_Vec3;
+
+typedef NCollection_Vec3<Standard_Real> Graphic3d_Vec3d;

These duplicating declarations make no sense - please include <Graphic3d_Vec3.hxx> instead.

-#else
-static Handle(Xw_Window)& VT_GetWindow(){
-  static Handle(Xw_Window) XWWin;
-  return XWWin;
-}
+#else
+static Handle(Xw_Window)& VT_GetWindow(){
+  static Handle(Xw_Window) XWWin;
+  return XWWin;
+}
+
+static void VProcessEvents(ClientData,int);
+#endif
+
...

Please discard unrelated changes (though I don't understand what they are doing in this diff at all).

tizmaylo

2019-04-01 17:31

developer   ~0083335

Last edited: 2019-04-02 11:11

+Standard_Boolean Quantity_Color::ColorFromName (const Standard_CString theColorNameString, Quantity_Color& 
theColor)
+{
...
+bool Quantity_Color::ColorFromHex (const Standard_CString theHexColorString, Quantity_Color& theColor)

+{


These are probably inline functions.


Only Quantity_Color::ColorFromName() can be made inline. It is impossible to make Quantity_Color::ColorFromHex() inline because an object of the Quantity_Color class is a member of the Quantity_ColorRGBA class.


+typedef NCollection_Vec3<Standard_ShortReal> Graphic3d_Vec3;
+
+typedef NCollection_Vec3<Standard_Real> Graphic3d_Vec3d;


These duplicating declarations make no sense - please include <Graphic3d_Vec3.hxx> instead.


They make sense in fact because <Graphic3d_Vec3.hxx> includes <NCollection_Vec3.hxx> that contains a template class definition. So such construction ("a forward declaration of a class template specialization alias") may reduce compile time a bit. It might make sense to consider adding of special header files for this purpose (aka <Graphic3d_Vec2fwd.hxx>, <Graphic3d_Vec3fwd.hxx>, <Graphic3d_Vec4fwd.hxx>, <Graphic3d_Mat4fwd.hxx>) that would contain only such forward declarations.


...though I don't understand what they are doing in this diff at all.

The cause of such strange behavior of the diff is a simple extra empty line # 175.

git

2019-04-02 19:05

administrator   ~0083371

Branch CR30592_2 has been created by tizmaylo.

SHA-1: c131c18c4e241abc96c207b1fe17f5a3e6c4c26e


Detailed log of new commits:

Author: tiv
Date: Tue Apr 2 18:58:08 2019 +0300

    0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg
    
    New command vbackground is created. Old background commands are made aliases for the newly created command (including vsetdefaultbg). Tests are not changed yet.
    Some reviewer's remarks are taken into account.

git

2019-04-02 20:37

administrator   ~0083374

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: 811602f8e78147f400406dc3ac166bd4111775bb

git

2019-04-04 11:38

administrator   ~0083406

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: 8fc082b4a5999461dede210273fd7925c045505c

git

2019-04-04 12:51

administrator   ~0083407

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: e130e38b2323c2b615bc1a6e0fed6bc52456c9b8


Detailed log of new commits:

Author: tiv
Date: Wed Apr 3 17:53:04 2019 +0300

    0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg
    
    Tests are changed using newly added command vbackground.

kgv

2019-04-04 12:53

developer   ~0083408

-# 
-# vsetgradientbg: vsetgradientbg R1 G1 B1 R2 G2 B2 Type
-# R1\G1\B1 - First color [0..255]
-# R2\G2\B2 - Second color [0..255]
-# Type 0 to 8
-# 0 = NONE,
-# 1 = HORIZONTAL,
-# 2 = VERTICAL,
-# 3 = DIAGONAL1,
-# 4 = DIAGONAL2,
-# 5 = CORNER1,
-# 6 = CORNER2,
-# 7 = CORNER3,
-# 8 = CORNER4
+#
+# vbackground -gradient Color1 Color2 [-gradientMode FillMethod]
+#
+#   Color:      Red Green Blue  - where Red, Green, Blue must be integers within the range [0, 255]\n"
+#                                   or reals within the range [0.0, 1.0]\n"
+#               ColorName       - one of WHITE, BLACK, RED, GREEN, BLUE, etc.\n"
+#               #HHH, [#]HHHHHH - where H is a hexadecimal digit (0 .. 9, a .. f, or A .. F)\n"
+#
+#   FillMethod: one of NONE, HOR (horizontal), VER (vertical), DIAG1 (diagonal1), DIAG2 (diagonal2),
+#                 CORNER1, CORNER2, CORNER3, CORNER4

These obsolete comments in test script should be removed - command help should be enough.

kgv

2019-04-04 12:56

developer   ~0083409

 set R2 0
 set G2 0
 set B2 255
-set Type 5
+set Type CORNER1

The temporary variables can be skipped now (passed to command directly as values), when command syntax has been improved (these dummy variables have been intended to understand what is actually passed to command, when it tool hundred of numbers as argument list).

Colors to be replaced by 0..1 or with names.

git

2019-04-05 17:31

administrator   ~0083442

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: ddce0a912d45cd4621dae339d910c84951741dcf

git

2019-04-08 12:19

administrator   ~0083510

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: ea7f573434f0a256f4de47967a7c8bc57a0b6dc4

git

2019-04-08 15:55

administrator   ~0083524

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: 356b0fd0a124893ff65cc73e519c4be6ff22254b

git

2019-04-09 19:18

administrator   ~0083588

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: afb6b9c6390752ba73a912ab91e853ae81fc7327

git

2019-04-09 19:18

administrator   ~0083589

Branch CR30592_3 has been created by tizmaylo.

SHA-1: 4e7e93a9aa6509f785168f252055e575772588e6


Detailed log of new commits:

Author: tiv
Date: Tue Apr 9 19:10:29 2019 +0300

    0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg
    
    A new command vbackground is created. Old background commands are made aliases for the newly created command (including vsetdefaultbg).
    Tests are modified using newly added command vbackground.

tizmaylo

2019-04-10 10:34

developer   ~0083593

Patch is ready for review: http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/ALL/

Main OCCT branch: CR30592_2

OCCT branch with squashed commits: CR30592_3

Branch in products: CR30592

kgv

2019-04-10 10:46

developer   ~0083595

Last edited: 2019-04-10 10:47

+template <typename Element_t>
+class NCollection_Vec3;
+
+typedef NCollection_Vec3<Standard_ShortReal> Graphic3d_Vec3;
+
+typedef NCollection_Vec3<Standard_Real> Graphic3d_Vec3d;

Please never use template forward declaration without a very good rationale.
Hypothetical compilation time improvement is no excuse for these error-prone constructions.

OCCT Coding Rules document currently lacks information about forward declarations:
https://dev.opencascade.org/doc/overview/html/occt_dev_guides__coding_rules.html

Practically, OCCT code tends to mixture reasonable amount (but NOT everything) of forward declarations for Handle-types and gp primitives,
while NCollection templates are always header-included.

Considerations about Forward Declarations from Google C++ Style Guide can be also helpful (although OCCT Rules are quite different from this):
https://google.github.io/styleguide/cppguide.html#Forward_Declarations

git

2019-04-10 11:52

administrator   ~0083599

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: 368e070baf765df107ef9748eea4796d56c0aacf


Detailed log of new commits:

Author: tiv
Date: Wed Apr 10 11:42:24 2019 +0300

    # Forward declaration of the NCollection_Vec3 class template is removed.
    # The code is fixed to prevent VC10 compile warnings

git

2019-04-10 11:52

administrator   ~0083600

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: b60e50788fb0998c8df07b9373ef2c628a65a20c

tizmaylo

2019-04-10 13:58

developer   ~0083602

Patch is ready for review: http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/ALL/

Main OCCT branch: CR30592_2

OCCT branch with squashed commits: CR30592_3

Branch in products: CR30592

git

2019-04-15 11:02

administrator   ~0083746

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: bc0d85a2e22ff98740bb2787acb0c76b7ba2095e

git

2019-04-15 11:02

administrator   ~0083747

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: d5289ad0d9f01221211c265ac23ef35a794f4307

kgv

2019-04-15 14:55

developer   ~0083755

+class Quantity_Color;
+
+class Quantity_ColorRGBA;
+
+class gp_Vec;
+
+class gp_Pnt;
+

Redundant empty lines.

+//! The key of the unnamed command option
+const std::size_t THE_UNNAMED_COMMAND_OPTION_KEY = (std::numeric_limits<std::size_t>::max)();
+
+//! The key of the help command option
+const std::size_t THE_HELP_COMMAND_OPTION_KEY = 0;

Unexpected unscoped variables in header file.

+  theCommands.Add ("vsetbg",
+                   "load image as background.\n"
+                   "This command is obsolete. Use vbackground instead.\n"
+                   "\n"

Please drop exhaustive description of deprecated commands - fit their help into 1-2 lines.

git

2019-04-15 17:46

administrator   ~0083760

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: 86fb89aa04b5d826369d1d714568c9b14c7221db


Detailed log of new commits:

Author: tiv
Date: Mon Apr 15 17:32:09 2019 +0300

    # Reviewer's remarks are taken into account:
    # * Redundant empty lines are removed.
    # * Global constants with some command option key values are made ViewerTest_CmdParser's class static data members.
    # * The exhaustive description of obsolete background commands is removed.
    # A bug with incorrect checking if a viewer is needed to perform a background changing operation is fixed.

git

2019-04-15 17:51

administrator   ~0083762

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 8b3e80f49255cda99ef09e1437f9b646abaa46f0

git

2019-04-15 19:00

administrator   ~0083765

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: 22617841c4432a5f27f429c2f770f3b43b396376

git

2019-04-15 19:00

administrator   ~0083766

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: e1eb8c77c5564f479cae8a46819a4ab8781a6346

git

2019-04-16 10:56

administrator   ~0083771

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: 4db7f60686aafd575e80220c6a47b17318ad3608

git

2019-04-16 10:57

administrator   ~0083772

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 446833199780c83d43a5eff3cc63f20462845c43

tizmaylo

2019-04-16 13:11

developer   ~0083785

Patch is ready for review: http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/ALL/

Main OCCT branch: CR30592_2

OCCT branch with squashed commits: CR30592_3

Branch in products: CR30592

git

2019-04-17 10:53

administrator   ~0083816

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: 77c0ff196220a24ce19604db97925e9ccb972c25


Detailed log of new commits:

Author: tiv
Date: Wed Apr 17 10:43:45 2019 +0300

    # Precision of floating-point color components is increased (from 3 digits after point to 6 digits). This change may probably resolve the problem with background gradient changes in tests.

git

2019-04-17 10:54

administrator   ~0083817

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 58d027d9f4860fdee9eb42ff5aada015841f6ba7

tizmaylo

2019-04-17 12:50

developer   ~0083823

Patch is ready for review: http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/ALL/

Main OCCT branch: CR30592_2
OCCT branch with squashed commits: CR30592_3

Main branch in products: CR30592
Products branch with squashed commits: CR30592_1

bugmaster

2019-04-17 18:57

administrator   ~0083833

Combination -
OCCT branch : CR30592_3
master SHA - 58d027d9f4860fdee9eb42ff5aada015841f6ba7
d67d4b811012eef8913d3c535c29654d0acf3c4c
Products branch : CR30592_1 SHA - f593563b50a15b38b3f595d1cfc0276255052844
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 16550.99000000005 / 16536.409999999894 [+0.09%]
Products
Total CPU difference: 10466.700000000035 / 10520.190000000048 [-0.51%]
Windows-64-VC14:
OCCT
Total CPU difference: 17989.8125 / 17951.921875 [+0.21%]
Products
Total CPU difference: 12008.28125 / 12011.875 [-0.03%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

bugmaster

2019-04-18 08:08

administrator   ~0083837

Error of compilation

http://jenkins-test-08.nnov.opencascade.com/view/IR-WEEK16_IR-WEEK16/view/OCCT%20compile/

git

2019-04-18 11:00

administrator   ~0083842

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 2fb962aaab149ff68722351a220dd5fe76099a06

git

2019-04-18 11:00

administrator   ~0083843

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: 29000c03fb49b376ff11176243be194a0cdf4a1d


Detailed log of new commits:

Author: tiv
Date: Thu Apr 18 10:49:53 2019 +0300

    # VC9, VC10, VC11 compilation errors are fixed.

tizmaylo

2019-04-18 13:03

developer   ~0083847

Patch is ready for review: http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/ALL/

Main OCCT branch: CR30592_2
OCCT branch with squashed commits: CR30592_3

Main branch in products: CR30592
Products branch with squashed commits: CR30592_1

kgv

2019-04-18 13:08

developer   ~0083848

+//! Old versions of Microsoft Visual Studio support explicit template instantiation declaration only as an extension
+//! or doesn't support using explicit template instantiation declaration and definition in one file.
+//! Full support of this C++ feature is available since MS VS2013.
+#if defined(_MSC_VER) && (_MSC_VER >= 1800)

Please just drop this code - it doesn't worth putting platform-dependent code in this place.

git

2019-04-18 13:28

administrator   ~0083849

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: 0f3a7bc20039994e7782aa8e591a05d0e9eb5765


Detailed log of new commits:

Author: tiv
Date: Thu Apr 18 13:19:36 2019 +0300

    # Explicit template instantiation declarations of ViewerTest_CmdParser template methods are removed.

git

2019-04-18 13:29

administrator   ~0083850

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 405b85bd7a51dd118c21c9764dba43518d85caa0

tizmaylo

2019-04-18 15:14

developer   ~0083852

Patch is ready for review (only compilation was performed without execution of any tests): http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/OCCT%20compile/

Main OCCT branch: CR30592_2
OCCT branch with squashed commits: CR30592_3

Main branch in products: CR30592
Products branch with squashed commits: CR30592_1

bugmaster

2019-04-19 08:11

administrator   ~0083861

Errors of compilation

http://jenkins-test-08.nnov.opencascade.com/view/IR-WEEK16_IR-WEEK16/view/OCCT%20compile/

tizmaylo

2019-04-19 11:28

developer   ~0083872

Last strange link error is caused by the bug in Microsoft Visual Studio 2013 and older versions: https://stackoverflow.com/q/31074546/3043539

git

2019-04-19 11:33

administrator   ~0083873

Branch CR30592_2 has been updated by tizmaylo.

SHA-1: b85cebc576fdd5f9aedcedeb7d717de7a34fccf9


Detailed log of new commits:

Author: tiv
Date: Fri Apr 19 10:22:14 2019 +0300

git

2019-04-19 11:33

administrator   ~0083874

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 0701961b65484d4e8547ab3e8679c9d70ac9c6e7

tizmaylo

2019-04-19 13:20

developer   ~0083877

Patch is ready for review (only compilation was performed without execution of any tests): http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/OCCT%20compile/

Main OCCT branch: CR30592_2
OCCT branch with squashed commits: CR30592_3

Main branch in products: CR30592
Products branch with squashed commits: CR30592_1

bugmaster

2019-04-21 10:54

administrator   ~0083893

Too many warnings

http://jenkins-test-08.nnov.opencascade.com/view/management/job/warnings_compare/Compare_Warnings_Report/

git

2019-04-22 11:43

administrator   ~0083923

Branch CR30592_2 has been updated forcibly by tizmaylo.

SHA-1: 35e3b07f66ce00ecba63413a6fad0a1a5913fe24

git

2019-04-22 11:43

administrator   ~0083924

Branch CR30592_3 has been updated forcibly by tizmaylo.

SHA-1: 9be5042c651e6c48f91cf8925a007d29dcbf65d6

tizmaylo

2019-04-22 13:47

developer   ~0083928

Patch is ready for review: http://jenkins-test-12.nnov.opencascade.com:8080/view/CR30592_3-master-TIV/view/OCCT%20compile/

Main OCCT branch: CR30592_2
OCCT branch with squashed commits: CR30592_3

Main branch in products: CR30592
Products branch with squashed commits: CR30592_1

bugmaster

2019-04-23 12:07

administrator   ~0083949

Warnings were eliminated

git

2019-04-27 13:08

administrator   ~0084029

Branch CR30592_3 has been deleted by inv.

SHA-1: 9be5042c651e6c48f91cf8925a007d29dcbf65d6

git

2019-04-27 13:08

administrator   ~0084030

Branch CR30592_2 has been deleted by inv.

SHA-1: 35e3b07f66ce00ecba63413a6fad0a1a5913fe24

git

2019-04-27 13:08

administrator   ~0084034

Branch CR30592_1 has been deleted by inv.

SHA-1: bece5b4107db758bca612ffd0fb7b368784c5745

git

2019-04-27 13:08

administrator   ~0084035

Branch CR30592 has been deleted by inv.

SHA-1: fb2e9c06569ed0016f5536495373a45c1e87d950

Related Changesets

occt: master 293211ae

2019-04-22 07:51:22

tiv


Committer: bugmaster Details Diff
0030592: Draw Harness, ViewerTest - provide vbackground command unifying vsetbg, vsetbgmode, vsetgradientbg, vsetgrbgmode, vsetcolorbg

A new command vbackground is created. Old background commands are made aliases for the newly created command (including vsetdefaultbg).
Tests are modified using newly added command vbackground.
Affected Issues
0030592
mod - samples/tcl/ANC101.tcl Diff File
mod - samples/tcl/dimensions.tcl Diff File
mod - samples/tcl/materials.tcl Diff File
mod - samples/tcl/MBBGehauseRohteil.tcl Diff File
mod - samples/tcl/pencil.tcl Diff File
mod - samples/tcl/Penrose.tcl Diff File
mod - samples/tcl/raytrace.tcl Diff File
mod - samples/tcl/snowflake.tcl Diff File
mod - src/ViewerTest/ViewerTest.cxx Diff File
mod - src/ViewerTest/ViewerTest_CmdParser.cxx Diff File
mod - src/ViewerTest/ViewerTest_CmdParser.hxx Diff File
mod - src/ViewerTest/ViewerTest_ViewerCommands.cxx Diff File
mod - tests/bugs/vis/bug1188 Diff File
mod - tests/bugs/vis/bug21747_1 Diff File
mod - tests/bugs/vis/bug21747_10 Diff File
mod - tests/bugs/vis/bug21747_11 Diff File
mod - tests/bugs/vis/bug21747_12 Diff File
mod - tests/bugs/vis/bug21747_13 Diff File
mod - tests/bugs/vis/bug21747_14 Diff File
mod - tests/bugs/vis/bug21747_15 Diff File
mod - tests/bugs/vis/bug21747_16 Diff File
mod - tests/bugs/vis/bug21747_17 Diff File
mod - tests/bugs/vis/bug21747_2 Diff File
mod - tests/bugs/vis/bug21747_3 Diff File
mod - tests/bugs/vis/bug21747_4 Diff File
mod - tests/bugs/vis/bug21747_5 Diff File
mod - tests/bugs/vis/bug21747_6 Diff File
mod - tests/bugs/vis/bug21747_7 Diff File
mod - tests/bugs/vis/bug21747_8 Diff File
mod - tests/bugs/vis/bug21747_9 Diff File
mod - tests/bugs/vis/bug22906 Diff File
mod - tests/bugs/vis/bug23102 Diff File
mod - tests/bugs/vis/bug23363 Diff File
mod - tests/bugs/vis/bug25475 Diff File
mod - tests/bugs/vis/bug25775 Diff File
mod - tests/bugs/vis/bug25778 Diff File
mod - tests/bugs/vis/bug26404 Diff File
mod - tests/bugs/vis/bug26599 Diff File
mod - tests/bugs/vis/bug27836 Diff File
mod - tests/bugs/vis/bug29787 Diff File
mod - tests/bugs/vis/bug29847 Diff File
mod - tests/v3d/glsl/interior2 Diff File
mod - tests/v3d/glsl/msaa Diff File
mod - tests/v3d/glsl/outline1 Diff File
mod - tests/v3d/glsl/outline2 Diff File
mod - tests/v3d/glsl/tiles Diff File
mod - tests/v3d/materials/bug24855 Diff File
mod - tests/v3d/raytrace/bug24130 Diff File
mod - tests/v3d/raytrace/bug24819 Diff File
mod - tests/v3d/raytrace/bug25201 Diff File
mod - tests/v3d/raytrace/bug26617 Diff File
mod - tests/v3d/raytrace/refraction Diff File
mod - tests/v3d/raytrace/textures Diff File
mod - tests/v3d/transparency/blend Diff File

Issue History

Date Modified Username Field Change
2019-03-18 20:32 kgv New Issue
2019-03-18 20:32 kgv Assigned To => kgv
2019-03-18 21:06 kgv Assigned To kgv => tizmaylo
2019-03-18 21:06 kgv Status new => assigned
2019-03-22 16:00 git Note Added: 0083198
2019-03-29 21:39 git Note Added: 0083300
2019-03-30 17:39 kgv Note Added: 0083319
2019-04-01 14:15 tizmaylo Relationship added parent of 0030623
2019-04-01 17:31 tizmaylo Note Added: 0083335
2019-04-01 17:31 tizmaylo Note View State: 0083335: private
2019-04-01 17:32 tizmaylo Note Edited: 0083335
2019-04-01 17:32 tizmaylo Note Edited: 0083335
2019-04-01 17:33 tizmaylo Note Edited: 0083335
2019-04-01 17:42 tizmaylo Note Edited: 0083335
2019-04-01 17:44 tizmaylo Note Edited: 0083335
2019-04-01 17:44 tizmaylo Note Edited: 0083335
2019-04-01 17:45 tizmaylo Note Edited: 0083335
2019-04-01 17:46 tizmaylo Note Edited: 0083335
2019-04-01 17:48 tizmaylo Note Edited: 0083335
2019-04-01 17:54 tizmaylo Note Edited: 0083335
2019-04-01 17:56 tizmaylo Note Edited: 0083335
2019-04-01 18:00 tizmaylo Note Edited: 0083335
2019-04-01 18:02 tizmaylo Note Edited: 0083335
2019-04-01 18:17 tizmaylo Note Edited: 0083335
2019-04-01 18:18 tizmaylo Note Edited: 0083335
2019-04-01 18:18 tizmaylo Note Edited: 0083335
2019-04-01 18:19 tizmaylo Note Edited: 0083335
2019-04-01 18:25 tizmaylo Note Edited: 0083335
2019-04-01 18:28 tizmaylo Note Edited: 0083335
2019-04-01 18:29 tizmaylo Note View State: 0083335: public
2019-04-02 11:07 tizmaylo Note Edited: 0083335
2019-04-02 11:11 tizmaylo Note Edited: 0083335
2019-04-02 11:11 tizmaylo Note Edited: 0083335
2019-04-02 19:05 git Note Added: 0083371
2019-04-02 20:37 git Note Added: 0083374
2019-04-04 11:38 git Note Added: 0083406
2019-04-04 12:51 git Note Added: 0083407
2019-04-04 12:53 kgv Note Added: 0083408
2019-04-04 12:56 kgv Note Added: 0083409
2019-04-05 17:31 git Note Added: 0083442
2019-04-08 12:19 git Note Added: 0083510
2019-04-08 15:55 git Note Added: 0083524
2019-04-09 19:18 git Note Added: 0083588
2019-04-09 19:18 git Note Added: 0083589
2019-04-10 10:34 tizmaylo Note Added: 0083593
2019-04-10 10:35 tizmaylo Assigned To tizmaylo => osa
2019-04-10 10:35 tizmaylo Status assigned => resolved
2019-04-10 10:35 tizmaylo Steps to Reproduce Updated
2019-04-10 10:46 kgv Note Added: 0083595
2019-04-10 10:46 kgv Assigned To osa => tizmaylo
2019-04-10 10:46 kgv Status resolved => assigned
2019-04-10 10:47 kgv Note Edited: 0083595
2019-04-10 10:47 kgv Note Edited: 0083595
2019-04-10 11:52 git Note Added: 0083599
2019-04-10 11:52 git Note Added: 0083600
2019-04-10 13:58 tizmaylo Note Added: 0083602
2019-04-10 14:00 tizmaylo Assigned To tizmaylo => osa
2019-04-10 14:00 tizmaylo Status assigned => resolved
2019-04-15 11:02 git Note Added: 0083746
2019-04-15 11:02 git Note Added: 0083747
2019-04-15 14:55 kgv Note Added: 0083755
2019-04-15 14:55 kgv Assigned To osa => tizmaylo
2019-04-15 14:55 kgv Status resolved => assigned
2019-04-15 17:46 git Note Added: 0083760
2019-04-15 17:51 git Note Added: 0083762
2019-04-15 19:00 git Note Added: 0083765
2019-04-15 19:00 git Note Added: 0083766
2019-04-16 10:56 git Note Added: 0083771
2019-04-16 10:57 git Note Added: 0083772
2019-04-16 13:11 tizmaylo Note Added: 0083785
2019-04-16 13:11 tizmaylo Assigned To tizmaylo => kgv
2019-04-16 13:11 tizmaylo Status assigned => resolved
2019-04-16 14:07 kgv Assigned To kgv => bugmaster
2019-04-16 14:07 kgv Status resolved => reviewed
2019-04-16 18:07 bugmaster Assigned To bugmaster => tizmaylo
2019-04-16 18:07 bugmaster Status reviewed => assigned
2019-04-17 10:53 git Note Added: 0083816
2019-04-17 10:54 git Note Added: 0083817
2019-04-17 12:50 tizmaylo Note Added: 0083823
2019-04-17 12:51 tizmaylo Assigned To tizmaylo => kgv
2019-04-17 12:51 tizmaylo Status assigned => resolved
2019-04-17 13:14 kgv Assigned To kgv => bugmaster
2019-04-17 13:14 kgv Status resolved => reviewed
2019-04-17 18:57 bugmaster Note Added: 0083833
2019-04-17 18:57 bugmaster Status reviewed => tested
2019-04-17 18:57 bugmaster Test case number => Not required
2019-04-18 08:08 bugmaster Note Added: 0083837
2019-04-18 08:08 bugmaster Assigned To bugmaster => tizmaylo
2019-04-18 08:08 bugmaster Status tested => assigned
2019-04-18 11:00 git Note Added: 0083842
2019-04-18 11:00 git Note Added: 0083843
2019-04-18 13:03 tizmaylo Note Added: 0083847
2019-04-18 13:03 tizmaylo Assigned To tizmaylo => kgv
2019-04-18 13:03 tizmaylo Status assigned => resolved
2019-04-18 13:08 kgv Note Added: 0083848
2019-04-18 13:09 kgv Assigned To kgv => tizmaylo
2019-04-18 13:09 kgv Status resolved => assigned
2019-04-18 13:28 git Note Added: 0083849
2019-04-18 13:29 git Note Added: 0083850
2019-04-18 15:14 tizmaylo Note Added: 0083852
2019-04-18 15:14 tizmaylo Assigned To tizmaylo => kgv
2019-04-18 15:14 tizmaylo Status assigned => resolved
2019-04-18 15:26 kgv Assigned To kgv => bugmaster
2019-04-18 15:26 kgv Status resolved => reviewed
2019-04-19 08:11 bugmaster Note Added: 0083861
2019-04-19 08:11 bugmaster Status reviewed => assigned
2019-04-19 10:10 tizmaylo Assigned To bugmaster => tizmaylo
2019-04-19 11:28 tizmaylo Note Added: 0083872
2019-04-19 11:33 git Note Added: 0083873
2019-04-19 11:33 git Note Added: 0083874
2019-04-19 13:20 tizmaylo Note Added: 0083877
2019-04-19 13:21 tizmaylo Assigned To tizmaylo => kgv
2019-04-19 13:21 tizmaylo Status assigned => resolved
2019-04-19 14:25 kgv Assigned To kgv => bugmaster
2019-04-19 14:25 kgv Status resolved => reviewed
2019-04-21 10:54 bugmaster Note Added: 0083893
2019-04-21 10:54 bugmaster Assigned To bugmaster => tizmaylo
2019-04-21 10:54 bugmaster Status reviewed => assigned
2019-04-22 11:43 git Note Added: 0083923
2019-04-22 11:43 git Note Added: 0083924
2019-04-22 13:47 tizmaylo Note Added: 0083928
2019-04-22 13:47 tizmaylo Assigned To tizmaylo => kgv
2019-04-22 13:47 tizmaylo Status assigned => resolved
2019-04-22 13:53 kgv Assigned To kgv => bugmaster
2019-04-22 13:53 kgv Status resolved => reviewed
2019-04-23 12:07 bugmaster Note Added: 0083949
2019-04-23 12:07 bugmaster Status reviewed => tested
2019-04-27 12:38 bugmaster Changeset attached => occt master 293211ae
2019-04-27 12:38 bugmaster Status tested => verified
2019-04-27 12:38 bugmaster Resolution open => fixed
2019-04-27 13:08 git Note Added: 0084029
2019-04-27 13:08 git Note Added: 0084030
2019-04-27 13:08 git Note Added: 0084034
2019-04-27 13:08 git Note Added: 0084035
2019-11-05 10:49 kgv Relationship added parent of 0031129
The file specified in $g_log_destination "/var/log/mantis/bugs/LDAP.log" is not writable.