View Issue Details

IDProjectCategoryView StatusLast Update
0030442CommunityOCCT:Meshpublic2022-09-19 14:24
Reportereryar Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status resolvedResolutionopen 
PlatformWindowsOSVC++ 2013 
Product Version7.3.0 
Target Version7.7.0 
Summary0030442: Mesh - broken triangulation on pipe shape
DescriptionBRepMesh broken for pipe shape, see the picture.


The points.txt data as follow:
3
3d
0 0 0
6000 6000 6000
9000 1000 3000

Steps To Reproduce
pload ALL

# 1. Approx a curve from points as a spine curve;
# 2. Make a circle as profile;
# 3. Pipe the circle along the spine;
# 4. Display the pipe in 3d viewer.

bsmooth aSmoothCurve 1.0 d:/points.txt

circle aCircle 0 0 0 1 1 1 20

mkedge aSpineEdge aSmoothCurve
mkedge aProfileEdge aCircle

wire aSpineWire aSpineEdge
wire aProfileWire aProfileEdge

pipe aPipe aSpineWire aProfileWire

vdisplay aPipe
vfit


TagsNo tags attached.
Test case number

Attached Files

  • pipe mesh broken.PNG (55,863 bytes)
  • points.txt (46 bytes)

Relationships

related to 0029641 resolvedbugmaster Community Mesher produce 'bad' result for extruded spline with given deviation coefficient 
related to 0032241 verifiedoan Community Mesh - wrong shading display of thrusections [regression since OCCT 7.4.0] 

Activities

eryar

2019-01-12 08:37

developer  

pipe mesh broken.PNG (55,863 bytes)

eryar

2019-01-12 08:38

developer  

points.txt (46 bytes)

oan

2022-09-16 18:39

developer   ~0111112

This issue should be automatically fixed in after integration of #31853 patch.
Corresponding test case is also created in context of #31853.

Please check and close.

Issue History

Date Modified Username Field Change
2019-01-12 08:37 eryar New Issue
2019-01-12 08:37 eryar Assigned To => oan
2019-01-12 08:37 eryar File Added: pipe mesh broken.PNG
2019-01-12 08:38 eryar File Added: points.txt
2019-09-04 15:43 abv Target Version 7.4.0 => 7.5.0
2020-08-28 15:51 oan Target Version 7.5.0 => 7.6.0
2020-10-23 19:26 kgv Summary BRepMesh broken for pipe shape => Mesh - broken triangulation on pipe shape
2020-10-23 19:26 kgv Description Updated
2020-10-23 19:26 kgv Steps to Reproduce Updated
2020-10-23 19:29 oan Relationship added related to 0029641
2021-03-23 12:48 oan Relationship added related to 0032241
2021-11-01 18:13 szy Target Version 7.6.0 => 7.7.0
2022-09-16 18:38 oan Assigned To oan => bugmaster
2022-09-16 18:39 oan Status new => assigned
2022-09-16 18:39 oan Note Added: 0111112
2022-09-19 14:24 oan Status assigned => resolved