MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030396Community[OCCT] OCCT:Shape Healingpublic2018-12-05 19:402018-12-24 11:02
Reporteraothms 
Assigned Togka 
PrioritynormalSeveritycrash 
StatusassignedResolutionopen 
PlatformVC++ 2017 64bitOSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0030396: Infinite recursion during ShapeFix after BRepAlgoAPI_Cut
DescriptionAttached is zip file with a cpp file and 7 shape serializations.

The cpp file loads a couple arguments for a boolean operation. A subsequent call to ShapeFix_Shape results in an infinite recursion.

The odd thing is that if the order in which the shapes are added to the list is changed (this order is also included in a code comment) the boolean op and shapefix call succeed and a visually correct result is obtained.
Steps To Reproducerestore [locate_data_file bug30396.brep] a
explode a

bfuzzyvalue 1e-2
bnondestructive 1
bclearobjects
bcleartools
baddobjects a_1
baddtools a_2 a_3 a_4 a_5 a_6 a_7
bfillds
bbop r 2

checknbshapes r -solid 1 -shell 1
checkshape r
# checkshape reports errors in version 7.3.0,
# and it is OK with current master

fixshape r1 r
# fixshape hangs on a couple of seconds and crashes the application,
# if result is get from the version 7.3.0
TagsNo tags attached.
Test case numberbugs modalg_7 bug30396_1, bug30396_2
Attached Fileszip file icon ifcopenshell_511.zip (6,704 bytes) 2018-12-05 19:40

- Relationships

-  Notes
(0081578)
git (administrator)
2018-12-20 17:19

Branch CR30396 has been created by msv.

SHA-1: 1b25c97fbc79b97d526440cc2ebd07375819b003


Detailed log of new commits:

Author: msv
Date: Thu Dec 20 17:10:00 2018 +0300

    Test for 0030396: Infinite recursion during ShapeFix after BRepAlgoAPI_Cut
    
    Two test cases are added. One for Boolean operation (it is good, because BO has been fixed already), and another for fixshape operation (it causes Draw crash).
(0081579)
msv (developer)
2018-12-20 17:24

The bug with BO is not reproduced in the master version.
However, the shape produced by the version 7.3 still crashes application during fixshape operation.
(0081581)
msv (developer)
2018-12-20 17:56

New test scripts have been created and pushed to the branch CR30396.

Dear Eugeny, please review the branch.

Results of new test scripts are here:
http://jenkins-test-12.nnov.opencascade.com/view/CR30396-master-msv/view/TESTING/job/CR30396-master-msv-OCCT-Debian80-64-opt-test-restart/HTML_20Report/ [^]
http://jenkins-test-12.nnov.opencascade.com/view/CR30396-master-msv/view/TESTING/job/CR30396-master-msv-OCCT-Windows-64-VC14-opt-test-restart/HTML_20Report/ [^]

Please do not close the bug after integration of the tests.
(0081583)
emv (developer)
2018-12-21 11:54

tests/bugs/modalg_7/bug30396_1:
- Please add checks for the area and volume properties of the result shapes.
- When operations complete, reset the options (fuzzy and safe mode) to default state.
- It will also be good to check other types of boolean operations in the same script.
(0081592)
git (administrator)
2018-12-21 15:44

Branch CR30396 has been updated by msv.

SHA-1: a6e65fe79f4a042a079193eb74ee228edf7aa830


Detailed log of new commits:

Author: msv
Date: Fri Dec 21 15:41:55 2018 +0300

    #correction following remarks

(0081593)
msv (developer)
2018-12-21 16:47

Remarks have been considered.
(0081594)
msv (developer)
2018-12-21 16:48

Please integrate and then assign again to me.

- Related Changesets
occt: master 4473e336
Timestamp: 2018-12-20 14:10:00
Author: msv
Committer: apn
Details ] Diff ]
0030396: Infinite recursion during ShapeFix after BRepAlgoAPI_Cut

Two test cases are added. One for Boolean operation (it is good, because BO has been fixed already), and another for fixshape operation (it causes Draw crash).
add - tests/bugs/modalg_7/bug30396_1 Diff ] File ]
add - tests/bugs/modalg_7/bug30396_2 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-12-05 19:40 aothms New Issue
2018-12-05 19:40 aothms Assigned To => msv
2018-12-05 19:40 aothms File Added: ifcopenshell_511.zip
2018-12-20 17:19 git Note Added: 0081578
2018-12-20 17:22 msv Status new => assigned
2018-12-20 17:24 msv Note Added: 0081579
2018-12-20 17:56 msv Note Added: 0081581
2018-12-20 17:56 msv Assigned To msv => emv
2018-12-20 17:56 msv Status assigned => feedback
2018-12-21 11:54 emv Note Added: 0081583
2018-12-21 11:54 emv Assigned To emv => msv
2018-12-21 11:54 emv Status feedback => assigned
2018-12-21 15:44 git Note Added: 0081592
2018-12-21 16:47 msv Note Added: 0081593
2018-12-21 16:47 msv Status assigned => resolved
2018-12-21 16:47 msv Steps to Reproduce Updated View Revisions
2018-12-21 16:48 msv Note Added: 0081594
2018-12-21 16:48 msv Assigned To msv => bugmaster
2018-12-21 16:48 msv Status resolved => reviewed
2018-12-21 16:51 apn Test case number => bugs modalg_7 bug30396_1, bug30396_2
2018-12-21 16:51 apn Status reviewed => tested
2018-12-22 14:32 apn Changeset attached => occt master 4473e336
2018-12-22 14:32 apn Assigned To bugmaster => apn
2018-12-22 14:32 apn Status tested => verified
2018-12-22 14:32 apn Resolution open => fixed
2018-12-22 14:35 apn Assigned To apn => msv
2018-12-22 14:35 apn Status verified => closed
2018-12-22 14:35 apn Resolution fixed => open
2018-12-22 14:35 apn Status closed => assigned
2018-12-24 11:01 msv Steps to Reproduce Updated View Revisions
2018-12-24 11:02 msv Assigned To msv => gka
2018-12-24 11:02 msv Category OCCT:Modeling Algorithms => OCCT:Shape Healing


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker