MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030366Open CASCADE[OCCT] OCCT:Codingpublic2018-11-13 09:522019-06-21 19:04
Reporternbv 
Assigned Tobugmaster 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 5.0.0 
Target Version[OCCT] 7.4.0Fixed in Version[OCCT] 7.4.0 
Summary0030366: Coding Rules - GeometryTest_API2dCommands.cxx seems to be excess
DescriptionCurrently the file GeometryTest_API2dCommands.cxx defines some DRAW-commands. However, names of these commands are duplicate of analogical commands in the file GeomliteTest_API2dCommands.cxx, which are actively used by current OCCT-version.

So, is the file GeometryTest_API2dCommands.cxx really usefull?

P.S.

Please note, that calling of the method GeometryTest::API2dCommands(...) is commented in the file GeometryTest.cxx.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0029679closedapn Community Draw Harness - Command 2dapprox works wrong when giving points in command line 

-  Notes
(0081992)
kgv (developer)
2019-02-01 17:49
edited on: 2019-02-01 17:56

This change was introduced in '1997.
> jpi 09/06/97 utilisation des commandes de GeomliteTest

(0081993)
git (administrator)
2019-02-01 17:54

Branch CR30366 has been created by kgv.

SHA-1: 1d574a318db6f63de8f588c398c09c3642c57bb5


Detailed log of new commits:

Author: kgv
Date: Fri Feb 1 17:49:08 2019 +0300

    0030366: Coding Rules - GeometryTest_API2dCommands.cxx seems to be excess
(0081994)
kgv (developer)
2019-02-01 17:55

Please take trivial patch.
(0082036)
bugmaster (administrator)
2019-02-05 14:05

tested in framework WEEK-6 branch


Combination -
OCCT branch : WEEK-6 SHA - 95c882e9d45466a9e296f33fb6a10289cf40332f
Products branch : WEEK-6 SHA - 72707298a0e5543f74709bf9d0186c8b8960ca25
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 16368.269999999928 / 16363.790000000015 [+0.03%]
Products
Total CPU difference: 7176.410000000036 / 7177.480000000016 [-0.01%]
Windows-64-VC14:
OCCT
Total CPU difference: 17772.359375 / 17773.921875 [-0.01%]
Products
Total CPU difference: 8601.046875 / 8604.828125 [-0.04%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0082626)
git (administrator)
2019-03-05 13:46

Branch CR30366 has been deleted by kgv.

SHA-1: 1d574a318db6f63de8f588c398c09c3642c57bb5

- Related Changesets
occt: master 98ae54f7
Timestamp: 2019-02-01 14:49:08
Author: kgv
Committer: bugmaster
Details ] Diff ]
0030366: Coding Rules - GeometryTest_API2dCommands.cxx seems to be excess
mod - src/GeometryTest/FILES Diff ] File ]
mod - src/GeometryTest/GeometryTest.cxx Diff ] File ]
mod - src/GeometryTest/GeometryTest.hxx Diff ] File ]
rm - src/GeometryTest/GeometryTest_API2dCommands.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-11-13 09:52 nbv New Issue
2018-11-13 09:52 nbv Assigned To => kgv
2019-02-01 17:26 kgv Relationship added related to 0028631
2019-02-01 17:46 kgv Relationship deleted related to 0028631
2019-02-01 17:46 kgv Summary The file GeometryTest_API2dCommands.cxx seems to be excess => Coding Rules - The file GeometryTest_API2dCommands.cxx seems to be excess
2019-02-01 17:47 kgv Summary Coding Rules - The file GeometryTest_API2dCommands.cxx seems to be excess => Coding Rules - GeometryTest_API2dCommands.cxx seems to be excess
2019-02-01 17:47 kgv Product Version => 5.0.0
2019-02-01 17:49 kgv Note Added: 0081992
2019-02-01 17:54 git Note Added: 0081993
2019-02-01 17:55 kgv Note Added: 0081994
2019-02-01 17:55 kgv Assigned To kgv => bugmaster
2019-02-01 17:55 kgv Severity minor => trivial
2019-02-01 17:55 kgv Status new => resolved
2019-02-01 17:55 kgv Status resolved => reviewed
2019-02-01 17:56 kgv Note Edited: 0081992 View Revisions
2019-02-04 15:08 bugmaster Test case number => Not needed
2019-02-05 14:05 bugmaster Note Added: 0082036
2019-02-05 14:05 bugmaster Status reviewed => tested
2019-02-10 19:36 bugmaster Changeset attached => occt master 98ae54f7
2019-02-10 19:36 bugmaster Status tested => verified
2019-02-10 19:36 bugmaster Resolution open => fixed
2019-03-02 22:47 kgv Relationship added has duplicate 0029679
2019-03-05 13:46 git Note Added: 0082626
2019-06-21 19:04 msv Relationship deleted has duplicate 0029679
2019-06-21 19:04 msv Relationship added related to 0029679


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker