MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030322Open CASCADE[OCCT] OCCT:Meshpublic2018-10-31 13:592018-11-04 14:08
Reporternbv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0030322: Remove DRAW-command "mesh" as useless
DescriptionIn fact, the DRAW-command "mesh" is duplicate of "incmesh".

The difference is that the "mesh" creates DRAW-object MeshTest_DrawableMesh. However, this object is currently not applicable (e.g. we cannot display it).
Steps To ReproduceTest case is not required.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
related to 0030305verifiedbugmaster Open CASCADE Strange logic in BRepMesh_Deflection::ComputeDeflection(...) method 

-  Notes
(0080557)
git (administrator)
2018-10-31 17:42

Branch CR30322 has been created by nbv.

SHA-1: 824dcaf861c717e0c6c5e6678dfed0c24c017d4c


Detailed log of new commits:

Author: nbv
Date: Wed Oct 31 14:29:28 2018 +0300

    0030322: Remove DRAW-command "mesh" as useless
    
    In fact, the DRAW-command "mesh" is duplicate of "incmesh".
    
    The difference is that the "mesh" creates DRAW-object MeshTest_DrawableMesh. However, this object is currently not applicable (e.g. we cannot display it).
    
    DRAW-commands "mesh", "addshape", "smooth", "edges", "vertices", "medge", "mvertex", "triangle", "dumpvertex", "dumpedge", "dumptriangle" and "onetriangulation" have been removed.
    
    The class MeshTest_DrawableMesh has been removed as useless.
    
    Testgrids "mesh standard_mesh" and "mesh advanced_mesh" have been removed.

Author: nbv
Date: Fri Oct 19 16:38:02 2018 +0300

    0030008: BRepMesh does not respect angular deflection in internal area of bspline surface
    
    1. Check whether the mesh satisfies the required angular deflection has been amended. Namely normals (to the surface) in the ends of any not "frontier" link are made collinear (with the given angular tolerance).
    
    2. New parameters AngleInterior and DeflectionInterior have been added in IMeshTools_Parameters structure.
    
    3. In case of thin long faces with internal edges, add points of internal edges to control parameters using grabParamsOfInternalEdges() in order to avoid aberrations on its ends. Disable addition of parameters from boundary edges in case of BSpline surface. Deviation can be controlled through the deflection parameter.
    
    4. Grab parameters from edges in case if there is just a single interval on BSpline surface along U and V direction.

Author: nbv
Date: Thu Oct 25 15:21:34 2018 +0300

    0030305: Strange logic in BRepMesh_Deflection::ComputeDeflection(...) method
    
    Before the fix, angular deflection was scaled to some coefficient in the method BRepMesh_Deflection::ComputeDeflection(...). Now, angular deflection is constant.

Author: oan
Date: Mon Oct 9 13:04:54 2017 +0300

    0026106: BRepMesh - revision of data model
    
    Removed tight connections between data structures, auxiliary tools and algorithms in order to create extensible solution, easy for maintenance and improvements;
    Code is separated on several functional units responsible for specific operation for the sake of simplification of debugging and readability;
    Introduced new data structures enabling possibility to manipulate discrete model of particular entity (edge, wire, face) in order to perform computations locally instead of processing an entire model.
    
    The workflow of updated component can be divided on six parts:
    * Creation of model data structure: source TopoDS_Shape passed to algorithm is analyzed and exploded on faces and edges. For each topological entity corresponding reflection is created in data model. Note that underlying algorithms use data model as input and access it via common interface which allows user to create custom data model with necessary dependencies between particular entities;
    * Discretize edges 3D & 2D curves: 3D curve as well as associated set of 2D curves of each model edge is discretized in order to create coherent skeleton used as a base in faces meshing process. In case if some edge of source shape already contains polygonal data which suites specified parameters, it is extracted from shape and stored to the model as is. Each edge is processed separately, adjacency is not taken into account;
(0080566)
nbv (developer)
2018-11-01 09:31

Dear Mikhail,

Please review CR30322 branch (for OCCT) and CR26106prod_final branch (for OCCT-products).

Test results are here: http://jenkins-test-12.nnov.opencascade.com/view/CR30322-CR26106_NBV/ [^]
(0080571)
msv (developer)
2018-11-01 12:08

tests/mesh/end
- Please update the script so that no mesh command at all.
(0080573)
git (administrator)
2018-11-01 13:09

Branch CR30322 has been updated by nbv.

SHA-1: 1657fa8380c21629a5dd3bdf12b378958809f92e


Detailed log of new commits:

Author: nbv
Date: Thu Nov 1 13:07:31 2018 +0300

    # Corrections according to remarks

(0080574)
nbv (developer)
2018-11-01 13:09
edited on: 2018-11-01 13:53

Dear Mikhail,

Please review CR30322_1 branch again.

(0080579)
git (administrator)
2018-11-01 13:53

Branch CR30322_1 has been created by nbv.

SHA-1: 4ae506fe9e353d23ec094a8a08a9a8896aa11827


Detailed log of new commits:

Author: nbv
Date: Wed Oct 31 14:29:28 2018 +0300

    0030322: Remove DRAW-command "mesh" as useless
    
    In fact, the DRAW-command "mesh" is duplicate of "incmesh".
    
    The difference is that the "mesh" creates DRAW-object MeshTest_DrawableMesh. However, this object is currently not applicable (e.g. we cannot display it).
    
    DRAW-commands "mesh", "addshape", "smooth", "edges", "vertices", "medge", "mvertex", "triangle", "dumpvertex", "dumpedge", "dumptriangle" and "onetriangulation" have been removed.
    
    The class MeshTest_DrawableMesh has been removed as useless.
    
    Testgrids "mesh standard_mesh" and "mesh advanced_mesh" have been removed.
(0080581)
msv (developer)
2018-11-01 14:58

Reviewed.
Please do not integrate before #26106.
(0080622)
bugmaster (administrator)
2018-11-02 14:33

Tested on WEEK-44

Combination -
OCCT branch : WEEK-44 SHA - 28ba266f89541152a33628babc066c381fc74d43
Products branch : WEEK-44 SHA - 4525a60ddf97fbcad482f1351d777d1e352a8307
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 16039.140000000109 / 16239.160000000287 [-1.23%]
Products
Total CPU difference: 7026.560000000032 / 7077.76000000003 [-0.72%]
Windows-64-VC14:
OCCT
Total CPU difference: 17510.3125 / 17699.515625 [-1.07%]
Products
Total CPU difference: 8514.828125 / 8596.328125 [-0.95%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0080692)
git (administrator)
2018-11-04 14:08

Branch CR30322_1 has been deleted by inv.

SHA-1: 4ae506fe9e353d23ec094a8a08a9a8896aa11827
(0080693)
git (administrator)
2018-11-04 14:08

Branch CR30322 has been deleted by inv.

SHA-1: 1657fa8380c21629a5dd3bdf12b378958809f92e

- Related Changesets
occt: master 4006ca98
Timestamp: 2018-10-31 11:29:28
Author: nbv
Committer: bugmaster
Details ] Diff ]
0030322: Remove DRAW-command "mesh" as useless

In fact, the DRAW-command "mesh" is duplicate of "incmesh".

The difference is that the "mesh" creates DRAW-object MeshTest_DrawableMesh. However, this object is currently not applicable (e.g. we cannot display it).

DRAW-commands "mesh", "addshape", "smooth", "edges", "vertices", "medge", "mvertex", "triangle", "dumpvertex", "dumpedge", "dumptriangle" and "onetriangulation" have been removed.

The class MeshTest_DrawableMesh has been removed as useless.

Testgrids "mesh standard_mesh" and "mesh advanced_mesh" have been removed.
mod - src/MeshTest/FILES Diff ] File ]
mod - src/MeshTest/MeshTest.cxx Diff ] File ]
rm - src/MeshTest/MeshTest_DrawableMesh.cxx Diff ] File ]
rm - src/MeshTest/MeshTest_DrawableMesh.hxx Diff ] File ]
rm - tests/mesh/advanced_mesh/begin Diff ] File ]
rm - tests/mesh/advanced_mesh/cases.list Diff ] File ]
mod - tests/mesh/end Diff ] File ]
mod - tests/mesh/grids.list Diff ] File ]
rm - tests/mesh/standard_mesh/begin Diff ] File ]
rm - tests/mesh/standard_mesh/cases.list Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-10-31 13:59 nbv New Issue
2018-10-31 13:59 nbv Assigned To => oan
2018-10-31 13:59 nbv Assigned To oan => nbv
2018-10-31 13:59 nbv Status new => assigned
2018-10-31 17:42 git Note Added: 0080557
2018-11-01 09:31 nbv Note Added: 0080566
2018-11-01 09:31 nbv Assigned To nbv => msv
2018-11-01 09:31 nbv Status assigned => resolved
2018-11-01 09:38 nbv Relationship added related to 0026106
2018-11-01 09:38 nbv Relationship added related to 0030008
2018-11-01 09:38 nbv Relationship added related to 0030305
2018-11-01 12:08 msv Note Added: 0080571
2018-11-01 12:08 msv Assigned To msv => nbv
2018-11-01 12:08 msv Status resolved => assigned
2018-11-01 13:09 git Note Added: 0080573
2018-11-01 13:09 nbv Note Added: 0080574
2018-11-01 13:09 nbv Assigned To nbv => msv
2018-11-01 13:09 nbv Status assigned => resolved
2018-11-01 13:53 git Note Added: 0080579
2018-11-01 13:53 nbv Note Edited: 0080574 View Revisions
2018-11-01 14:58 msv Note Added: 0080581
2018-11-01 14:58 msv Assigned To msv => bugmaster
2018-11-01 14:58 msv Status resolved => reviewed
2018-11-01 15:33 bugmaster Test case number => Not needed
2018-11-02 14:33 bugmaster Note Added: 0080622
2018-11-02 14:33 bugmaster Status reviewed => tested
2018-11-04 13:01 bugmaster Changeset attached => occt master 4006ca98
2018-11-04 13:01 bugmaster Status tested => verified
2018-11-04 13:01 bugmaster Resolution open => fixed
2018-11-04 14:08 git Note Added: 0080692
2018-11-04 14:08 git Note Added: 0080693


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker