MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030308Community[OCCT] OCCT:Samplespublic2018-10-26 10:342020-09-20 11:13
ReporterBenjaminBihler 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionreopened 
PlatformLinuxOSDebian 6.0OS Version64 bit
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0030308: Samples - Qt Tutorial Sample cannot be built on Linux
DescriptionThere are two problems when trying to build the Tutorial sample:

1. In my file .../bin/custom_gcc_64.sh the environment variables are set only condionally and the conditions are not true. If I comment out the lines

if [ "$1" == "d" ]; then
if [ "$2" == "64" ]; then


and the respective "fi" lines, then at least the environment variables are correctly set.

2. The file Tutorial.pro references the libraries freeimageplus, tbb and tbbmalloc which are not available here. Is this necessary?

After fixing both, the sample can be built.
Steps To ReproducePlease review
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships

-  Notes
(0081534)
apn (administrator)
2018-12-15 21:30

OCCT Qt samples can be successfully built in Release and Debug modes.

Following conditions in custom_gcc_64.sh
if [ "$1" == "d" ]; then
  if [ "$2" == "64" ]; then

OR

if [ "$1" == "" ]; then
  if [ "$2" == "64" ]; then

give opportunity to build and run OCCT in both modes from the same directory (folders bin and bind).
So if OCCT was build in Release mode, just run OCCT_SAMPLES_DIR/qt/Tutorial/make.sh (QTDIR should be defined).
For Debug version: "make.sh d" (and "run.sh d" to launch sample).
Paths to freeimageplus, tbb and tbbmalloc are defined in OCCT_DIR/bin/custom_gcc_64.sh.
(0081684)
BenjaminBihler (developer)
2019-01-07 12:03

Dear apn,

thank you. You are right with your first comment, adding "d" as argument solves the problem.

As for the second comment, I have seen the possibility to define the paths to freeimageplus, tbb and tbbmalloc. The problem is that the Tutorial sample on Unix systems is unconditionally linked to these libraries. But this is not necessary, the libraries seem to be not needed. If this impression is correct I would propose to remove this dependecy.

Benjamin
(0094700)
BenjaminBihler (developer)
2020-09-14 10:59

I wonder why the issue has been closed. The first problem is solved, but the second problem still remains. Wouldn't it be easy to remove the dependency on unused libraries?
(0094854)
git (administrator)
2020-09-15 16:13

Branch CR30308 has been created by inv.

SHA-1: 497614b74ad4f8021ffc3a73b1f383e269ab3d86


Detailed log of new commits:

Author: bugmaster
Date: Tue Sep 15 16:15:09 2020 +0300

    0030308: OCCT Qt Tutorial Sample Cannot Be Built on Linux
(0095070)
bugmaster (administrator)
2020-09-19 17:20

Combination -
OCCT branch : IR-2020-09-18
master SHA - b0b766826118f74b9857a932b8cec8c52a25c492
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-09-18 SHA - a6486d839da1ba1383ef6cc1a1a446a172f494c7
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17528.97000000011 / 17378.390000000145 [+0.87%]
Products
Total CPU difference: 12127.32000000009 / 12079.540000000095 [+0.40%]
Windows-64-VC14:
OCCT
Total CPU difference: 18862.703125 / 18898.921875 [-0.19%]
Products
Total CPU difference: 13314.828125 / 13329.21875 [-0.11%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0095119)
git (administrator)
2020-09-20 11:13

Branch CR30308 has been deleted by inv.

SHA-1: 497614b74ad4f8021ffc3a73b1f383e269ab3d86

- Related Changesets
occt: master 2fa0e902
Timestamp: 2020-09-15 13:15:09
Author: bugmaster
Details ] Diff ]
0030308: OCCT Qt Tutorial Sample Cannot Be Built on Linux
mod - samples/qt/Tutorial/Tutorial.pro Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-10-26 10:34 BenjaminBihler New Issue
2018-10-26 10:34 BenjaminBihler Assigned To => bugmaster
2018-11-26 12:52 bugmaster Assigned To bugmaster => apn
2018-11-26 12:52 bugmaster Status new => feedback
2018-12-15 21:30 apn Note Added: 0081534
2019-01-07 12:03 BenjaminBihler Note Added: 0081684
2019-07-19 18:59 apn Target Version 7.4.0 => 7.5.0
2020-09-11 16:35 utverdov Assigned To apn => inv
2020-09-11 16:45 utverdov Target Version 7.5.0 => 7.6.0*
2020-09-11 17:09 bugmaster Assigned To inv => bugmaster
2020-09-14 10:49 bugmaster Status feedback => closed
2020-09-14 10:49 bugmaster Resolution open => no change required
2020-09-14 10:59 BenjaminBihler Note Added: 0094700
2020-09-14 10:59 BenjaminBihler Status closed => feedback
2020-09-14 10:59 BenjaminBihler Resolution no change required => reopened
2020-09-15 16:13 git Note Added: 0094854
2020-09-15 16:14 bugmaster Assigned To bugmaster => kgv
2020-09-15 16:14 bugmaster Status feedback => resolved
2020-09-15 16:14 bugmaster Steps to Reproduce Updated View Revisions
2020-09-15 16:33 kgv Assigned To kgv => bugmaster
2020-09-15 16:33 kgv Severity major => minor
2020-09-15 16:33 kgv Status resolved => reviewed
2020-09-15 16:33 kgv Summary OCCT Qt Tutorial Sample Cannot Be Built on Linux => Samples - Qt Tutorial Sample cannot be built on Linux
2020-09-15 16:33 kgv Description Updated View Revisions
2020-09-15 16:33 kgv Target Version 7.6.0* => 7.5.0
2020-09-19 15:43 bugmaster Test case number => Not required
2020-09-19 17:20 bugmaster Note Added: 0095070
2020-09-19 17:20 bugmaster Status reviewed => tested
2020-09-20 10:55 bugmaster Changeset attached => occt master 2fa0e902
2020-09-20 10:55 bugmaster Status tested => verified
2020-09-20 11:13 git Note Added: 0095119


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker