MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030227Open CASCADE[OCCT] PRODUCTS:Point Cloud Renderingpublic2018-10-09 19:532019-02-04 12:32
Reportergka 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.4.0Fixed in Version[OCCT] 7.4.0 
Summary0030227: Point Cloud Rendering - Impossible to select separate point from point cloud
DescriptionAdded mode to select separate point of the point cloud instead of selection of the rectangular area (selection frustum) on the point cloud.
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
parent of 0030445closedbugmaster Point Cloud Rendering - add possibility to deselect already selected points within PointCloud_PointCloud 
child of 0030226closedbugmaster Point Cloud Rendering - Method PointCloud_PointCloud::GetSelected() returns pointer on a local variable 

-  Notes
(0079858)
kgv (developer)
2018-10-10 16:48

-  PointCloud_GlElement (const Handle(PointCloud_RasterRenderer)& theRenderer) : myRenderer (theRenderer) 
{}
+  PointCloud_GlElement(const Handle(PointCloud_RasterRenderer)& theRenderer) : myRenderer(theRenderer) 
{}
 
   //! Render object.
-  virtual void Render (const Handle(OpenGl_Workspace)& theWorkspace) const Standard_OVERRIDE
+  virtual void Render(const Handle(OpenGl_Workspace)& theWorkspace) const Standard_OVERRIDE

It looks like some merging issue - patch contains a lot of unrelated formatting changes.
(0081210)
gka (developer)
2018-11-22 14:00

Branch CR30227 is ready to be reviewed.
Results of tests can be found by path:
http://jenkins-test-12.nnov.opencascade.com/view/CR30227-master-gka/view/COMPARE/ [^]
(0081948)
kgv (developer)
2019-01-30 18:58

Please raise the patch in branch CR30227_2.
(0081971)
bugmaster (administrator)
2019-01-31 16:33

Fix has been tested with 30441
(0081998)
bugmaster (administrator)
2019-02-03 11:27

Fix has been integrated into master of occt-products repository

- Issue History
Date Modified Username Field Change
2018-10-09 19:53 gka New Issue
2018-10-09 19:53 gka Assigned To => gka
2018-10-10 10:07 gka Summary Added mode to select separate point of the point cloud instead of selection of the rectangular area on the point cloud => Addition of the selection mode for point clouds to select separate point of the point cloud
2018-10-10 10:10 gka Summary Addition of the selection mode for point clouds to select separate point of the point cloud => Impossible to select separate point from point cloud
2018-10-10 10:10 gka Description Updated View Revisions
2018-10-10 15:56 kgv Summary Impossible to select separate point from point cloud => Point Cloud Rendering - Impossible to select separate point from point cloud
2018-10-10 16:48 kgv Note Added: 0079858
2018-11-21 15:31 gka Status new => assigned
2018-11-22 13:55 gka Assigned To gka => abv
2018-11-22 13:55 gka Status assigned => resolved
2018-11-22 13:55 gka Steps to Reproduce Updated View Revisions
2018-11-22 13:58 gka Relationship added child of 0030226
2018-11-22 14:00 gka Note Added: 0081210
2018-11-22 14:00 gka Steps to Reproduce Updated View Revisions
2019-01-30 18:58 kgv Note Added: 0081948
2019-01-30 18:58 kgv Assigned To abv => bugmaster
2019-01-30 18:58 kgv Status resolved => reviewed
2019-01-30 19:28 kgv Relationship added parent of 0030445
2019-01-31 16:08 bugmaster Test case number => Not needed
2019-01-31 16:33 bugmaster Note Added: 0081971
2019-01-31 16:33 bugmaster Status reviewed => tested
2019-02-03 11:27 bugmaster Note Added: 0081998
2019-02-03 11:27 bugmaster Status tested => verified
2019-02-03 11:27 bugmaster Resolution open => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker