View Issue Details

IDProjectCategoryView StatusLast Update
0030160Open CASCADEOCCT:Modeling Algorithmspublic2022-06-28 06:37
Reporterjgv Assigned Toazv 
PrioritynormalSeverityminor 
Status verifiedResolutionfixed 
Product Version7.3.0 
Target Version7.7.0 
Summary0030160: DBRep_IsoBuilder builds wrong isolines for planar faces
DescriptionDBRep_IsoBuilder builds wrong isolines for planar faces. Two planar faces are covers of the pipe, they are bounded by closed BSpline curves.
Steps To Reproduce
MODELING
restore [locate_data_file OCC1477_bsplinewire_c0.brep] sp
restore [locate_data_file OCC1477_profile1_circle.brep] pr 
wire pr pr

mksweep sp
addsweep pr -T -R
buildsweep result -R -S

explode result f
isos result_4 50
isos result_5 50
donly result_4 result_5
fit
TagsNo tags attached.
Test case numberbugs/modalg_8/bug30160

Attached Files

  • iso720_KO.png (6,901 bytes)
  • iso730_KO.png (3,455 bytes)
  • iso750_OK.png (4,156 bytes)

Relationships

related to 0031688 closedbugmaster Visualization - Wrong ISO lines for a face created from BSpline 

Activities

emv

2018-09-25 16:39

developer   ~0079398

Last edited: 2018-09-26 09:28

The problem comes from the incorrect classification of the point (through Geom2dHatch_Classifier) relatively the face. The classification is incorrect due to incorrect intersection of two 2d curves - classification ray intersects the pcurve of the face. In this intersection one intersection point is missing.

Here is the draw script to reproduce the problem with 2d intersection:
pcurve result_4
dump result_4_1

line ray 0.0 -16.288656886901943 -0.13150161507367475 0.99131595630909475
trim ray ray 0.0 15.299078275810480

2dintersect ray result_4_1 -tol 1.e-9
# only one intersection point


Note, that saving the ray, restoring it and making intersection with restored one will lead to two intersection points. So, it looks like the problem is connected to floating point precision instability.
It has to be investigated further.

git

2022-04-05 08:55

administrator   ~0107617

Branch CR30160 has been created by azv.

SHA-1: ac73ce36766df9dfb173eeb94b9955910a580589


Detailed log of new commits:

Author: azv
Date: Tue Apr 5 08:55:29 2022 +0300

    0030160: DBRep_IsoBuilder builds wrong isolines for planar faces
    
    Add test case

azv

2022-04-05 10:55

administrator   ~0107630

Mikhail,

The issue is not reproduced on the current OCCT master branch. Test case has been added.

Please, review following branches:
OCCT: CR30160
Products: NOT
Test results: http://jenkins-test-occt/view/CR30160-master-AZV/ - some tests are failed or improved due to instability.

git

2022-04-05 13:23

administrator   ~0107638

Branch CR30160 has been updated forcibly by azv.

SHA-1: fd3cbde307788762828fb9071aae16296a917b61

smoskvin

2022-04-09 09:49

administrator   ~0107787

Combination -
OCCT branch : IR-2022-04-08
master SHA - 7021de2fe7a69d4c788ccf43b8b096dbcc8597c8
49e51745631c52b6c452c65adae4d6dfa21a1b1e
Products branch : IR-2022-04-08 SHA - e16d959d441765c483049307ba7293173532103a
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 18452.87000000039 / 18490.94000000032 [-0.21%]
Products
Total CPU difference: 11761.310000000152 / 11719.920000000124 [+0.35%]
Windows-64-VC14:
OCCT
Total CPU difference: 20539.828125 / 20552.71875 [-0.06%]
Products
Total CPU difference: 13248.21875 / 13242.609375 [+0.04%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention

git

2022-04-10 10:48

administrator   ~0107811

Branch CR30160 has been deleted by mnt.

SHA-1: fd3cbde307788762828fb9071aae16296a917b61

kgv

2022-04-12 10:18

developer   ~0107881

iso720_KO.png (6,901 bytes)
iso730_KO.png (3,455 bytes)
iso750_OK.png (4,156 bytes)

Related Changesets

occt: master ad3825f8

2022-04-05 08:55:29

azv


Committer: smoskvin Details Diff
0030160: DBRep_IsoBuilder builds wrong isolines for planar faces

Add test case
Affected Issues
0030160
mod - tests/bugs/grids.list Diff File
add - tests/bugs/modalg_8/bug30160 Diff File

Issue History

Date Modified Username Field Change
2018-09-25 11:10 jgv New Issue
2018-09-25 11:10 jgv Assigned To => msv
2018-09-25 11:44 msv Assigned To msv => emv
2018-09-25 11:44 msv Status new => assigned
2018-09-25 16:39 emv Note Added: 0079398
2018-09-26 09:13 emv Note Edited: 0079398
2018-09-26 09:28 emv Note Edited: 0079398
2019-08-12 17:59 emv Target Version 7.4.0 => 7.5.0
2020-07-24 18:04 kgv Relationship added related to 0031688
2020-08-28 13:25 emv Target Version 7.5.0 => 7.6.0
2021-08-29 18:51 msv Target Version 7.6.0 => 7.7.0
2022-04-05 08:55 git Note Added: 0107617
2022-04-05 10:55 azv Assigned To emv => msv
2022-04-05 10:55 azv Status assigned => resolved
2022-04-05 10:55 azv Note Added: 0107630
2022-04-05 13:23 git Note Added: 0107638
2022-04-05 13:26 msv Assigned To msv => bugmaster
2022-04-05 13:26 msv Status resolved => reviewed
2022-04-09 09:49 smoskvin Status reviewed => tested
2022-04-09 09:49 smoskvin Note Added: 0107787
2022-04-09 09:54 smoskvin Test case number => bugs/modalg_8/bug30160
2022-04-10 10:42 smoskvin Changeset attached => occt master ad3825f8
2022-04-10 10:42 azv Assigned To bugmaster => azv
2022-04-10 10:42 azv Status tested => verified
2022-04-10 10:42 azv Resolution open => fixed
2022-04-10 10:48 git Note Added: 0107811
2022-04-12 10:10 kgv Product Version => 7.3.0
2022-04-12 10:10 kgv Steps to Reproduce Updated
2022-04-12 10:17 kgv Steps to Reproduce Updated
2022-04-12 10:18 kgv Note Added: 0107881
2022-04-12 10:18 kgv File Added: iso720_KO.png
2022-04-12 10:18 kgv File Added: iso730_KO.png
2022-04-12 10:18 kgv File Added: iso750_OK.png
2022-04-12 10:18 kgv Target Version 7.7.0 => 7.5.4
2022-06-28 06:37 azv Target Version => 7.7.0