View Issue Details

IDProjectCategoryView StatusLast Update
0030099Open CASCADEOCCT:Modeling Algorithmspublic2019-08-15 17:50
Reporteremv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version7.3.0 
Target Version7.4.0Fixed in Version7.4.0 
Summary0030099: Modeling Algorithms - ShapeUpgrade_UnifySameDomain produces invalid result
DescriptionShapeUpgrade_UnifySameDomain produces invalid result when trying to unify the cylindrical faces.

The problem has been discovered while working on the issue 0030094.
Steps To Reproducerestore [locate_data_file bug30099.brep] s
checkshape s
unifysamedom r s
checkshape r
TagsNo tags attached.
Test case numberNot required

Relationships

related to 0030094 closedbugmaster Open CASCADE Modeling Algorithms - Defeaturing does not work on the attached shape due to incorrect extension of the torus 
related to 0029504 closedbugmaster Open CASCADE ShapeUpgrade_UnifySameDomain produces invalid shape and ShapeFix_Shape is unable to fix it 

Activities

msv

2019-07-17 11:42

developer   ~0085696

This bug tends to be fixed by #30534.

msv

2019-08-12 17:11

developer   ~0086205

This bug is fixed with #30534. Please close it.

Issue History

Date Modified Username Field Change
2018-08-31 08:40 emv New Issue
2018-08-31 08:40 emv Assigned To => msv
2018-08-31 08:40 emv Relationship added related to 0030094
2018-08-31 08:41 emv Steps to Reproduce Updated
2018-08-31 10:48 emv Relationship added related to 0029504
2019-07-17 11:42 msv Note Added: 0085696
2019-08-12 17:11 msv Note Added: 0086205
2019-08-12 17:11 msv Assigned To msv => bugmaster
2019-08-12 17:11 msv Status new => feedback
2019-08-13 16:31 bugmaster Status feedback => verified
2019-08-13 16:31 bugmaster Resolution open => fixed
2019-08-15 17:50 bugmaster Test case number => Not required