MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030071Open CASCADE[OCCT] OCCT:Testspublic2018-08-16 14:422018-09-03 16:54
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformWindowsOSVC++ 2015OS Version64 bit
Product Version[OCCT] 6.7.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0030071: Tests - locate_data_file does not skip .git folders
Descriptionlocate_data_file command has an error in definition leading to .git folders not being filtered:
                # skip directories starting with dot
                if { [regexp {^[.]} $name] } { continue }

The problem is that $name is not a subfolder name but the full path to it.

As result, tests might fail with the following awkward error:
Test boolean bopfuse_complex L8

CASE boolean bopfuse_complex L8: FAILED (exception)

Draw[1]> Executing c:/OCCT/tests/boolean/begin...
pload TOPTEST 
cpulimit 300 
dset SCALE 100 
100
protect SCALE 
SCALE 
Executing c:/OCCT/tests/boolean/bopfuse_complex/L8...
brestore C:/occt_tests_data/private/.git/objects/b1 n 
Cannot open file for reading : C:/occt_tests_data/private/.git/objects/b1
Tcl Exception: Cannot open file for reading : C:/occt_tests_data/private/.git/objects/b1


Notice that in proper configuration there is no issue with .git folder, because normally it has Hidden flag and implicitly filtered by glob Tcl command:
eval lappend dir [glob -nocomplain -directory $name -type d *]
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships
child of 0023970closedabv Ignore dot-paths when searching for data files 

-  Notes
(0078650)
git (administrator)
2018-08-16 14:44

Branch CR30071 has been created by kgv.

SHA-1: ccdcf115c0ef62ce014ebf250a3db14e6b621d26


Detailed log of new commits:

Author: kgv
Date: Thu Aug 16 14:42:30 2018 +0300

    0030071: Tests - locate_data_file does not skip .git folders
    
    Regexp is now applied to subfolder name to filter folders starting with dot.
(0078651)
kgv (developer)
2018-08-16 14:49

Patch is ready for review.
(0078653)
abv (manager)
2018-08-16 16:55

No remarks, please integrate
(0078777)
git (administrator)
2018-08-26 17:43

Branch CR30071 has been deleted by inv.

SHA-1: ccdcf115c0ef62ce014ebf250a3db14e6b621d26

- Related Changesets
occt: master 343f7e4d
Timestamp: 2018-08-16 11:42:30
Author: kgv
Committer: bugmaster
Details ] Diff ]
0030071: Tests - locate_data_file does not skip .git folders

Regexp is now applied to subfolder name to filter folders starting with dot.
mod - src/DrawResources/TestCommands.tcl Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-08-16 14:42 kgv New Issue
2018-08-16 14:42 kgv Assigned To => apn
2018-08-16 14:44 git Note Added: 0078650
2018-08-16 14:46 kgv Relationship added child of 0023970
2018-08-16 14:48 kgv Product Version 7.3.0 => 6.7.0
2018-08-16 14:49 kgv Note Added: 0078651
2018-08-16 14:49 kgv Status new => resolved
2018-08-16 16:55 abv Note Added: 0078653
2018-08-16 16:55 abv Assigned To apn => bugmaster
2018-08-16 16:55 abv Status resolved => reviewed
2018-08-20 18:26 bugmaster Status reviewed => tested
2018-08-26 17:36 bugmaster Changeset attached => occt master 343f7e4d
2018-08-26 17:36 bugmaster Status tested => verified
2018-08-26 17:36 bugmaster Resolution open => fixed
2018-08-26 17:43 git Note Added: 0078777
2018-09-03 16:54 bugmaster Test case number => Not needed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker