MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0030053Community[OCCT] OCCT:Data Exchangepublic2018-08-09 20:572020-09-13 11:47
Reporterthomhong 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformWindowsOSVC++ 2015OS Version64 bit
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.5.0Fixed in Version 
Summary0030053: STEP read fails due to comment string
DescriptionIf a comment contains an odd number of ' characters, reading in the STEP file fails. Succeeds if there is an even number of ' characters.
Steps To ReproduceAttempt to load attached file into the ImportExport sample (Debug x64 tested). Comment string as shown.

ISO-10303-21;
HEADER;
/***
 * ' ' '
 */
FILE_DESCRIPTION(('a Product shape'),'1');
TagsNo tags attached.
Test case numberNot required
Attached Files? file icon screw-e.step (88,569 bytes) 2018-08-09 20:57

- Relationships

-  Notes
(0093441)
git (administrator)
2020-08-07 10:17

Branch CR30053 has been created by dpasukhi.

SHA-1: 554d33c8f2d24d5d2e7e6f0603116a07b48d03b1


Detailed log of new commits:

Author: dpasukhi
Date: Fri Aug 7 00:30:29 2020 +0300

    0030053: STEP read fails due to comment string
    
    Added checking for the presence of an apostrophe in comments.
(0093654)
git (administrator)
2020-08-26 20:13

Branch CR30053 has been updated forcibly by dpasukhi.

SHA-1: 3639df3ce959620e8863c6e056fc2d0d66691463
(0093744)
git (administrator)
2020-08-31 08:50

Branch CR30053 has been updated forcibly by dpasukhi.

SHA-1: 711667ca516863d862f4dbefdabdb4ccbf4660c9
(0093766)
git (administrator)
2020-08-31 15:45

Branch CR30053 has been updated by dpasukhi.

SHA-1: 53f8c121a99c1e88eea00d331c06afc1881376c6


Detailed log of new commits:

Author: dpasukhi
Date: Mon Aug 31 15:47:50 2020 +0300

    0030053: STEP read fails due to comment string
    
    - add pattern for '\r'
    - try to use non global array

(0094369)
abv (manager)
2020-09-10 13:07

Fix included in branch CR30848_3 is reviewed, tested, and should be integrated together with #30848.
(0094549)
bugmaster (administrator)
2020-09-13 11:06

Combination -
OCCT branch : IR-2020-09-11
master SHA - d1b25684e9402d995dafec22fb98f83957d5fb76
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : IR-2020-09-11 SHA - a7e55a291cf6642cb4af945a999deeeb5f91272a
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17333.360000000142 / 17325.800000000123 [+0.04%]
Products
Total CPU difference: 12056.720000000096 / 12079.64000000011 [-0.19%]
Windows-64-VC14:
OCCT
Total CPU difference: 18817.921875 / 18792.46875 [+0.14%]
Products
Total CPU difference: 13294.09375 / 13274.75 [+0.15%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0094605)
git (administrator)
2020-09-13 11:47

Branch CR30053 has been deleted by inv.

SHA-1: 53f8c121a99c1e88eea00d331c06afc1881376c6

- Related Changesets
occt: master 183c99ca
Timestamp: 2020-09-09 10:00:15
Author: abv
Committer: abv
Details ] Diff ]
0030053: STEP read fails due to comment string

- Update .step scanner:
  - add rules to read anything within the comment
  - add a function to initialize of lexical scanner
  - add states for Commit & End instead of global variables modcom & modend
mod - src/StepFile/lex.step.c Diff ] File ]
mod - src/StepFile/recfile.pc Diff ] File ]
mod - src/StepFile/step.lex Diff ] File ]
add - tests/bugs/step/bug30053 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-08-09 20:57 thomhong New Issue
2018-08-09 20:57 thomhong Assigned To => gka
2018-08-09 20:57 thomhong File Added: screw-e.step
2020-04-15 15:21 gka Assigned To gka => dpasukhi
2020-04-15 15:21 gka Status new => assigned
2020-08-07 10:17 git Note Added: 0093441
2020-08-26 20:13 git Note Added: 0093654
2020-08-31 08:50 git Note Added: 0093744
2020-08-31 15:45 git Note Added: 0093766
2020-09-10 13:07 abv Assigned To dpasukhi => abv
2020-09-10 13:07 abv Status assigned => resolved
2020-09-10 13:07 abv Note Added: 0094369
2020-09-10 13:07 abv Assigned To abv => bugmaster
2020-09-10 13:07 abv Status resolved => reviewed
2020-09-11 17:48 abv Target Version => 7.5.0
2020-09-13 11:06 bugmaster Note Added: 0094549
2020-09-13 11:06 bugmaster Status reviewed => tested
2020-09-13 11:19 bugmaster Test case number => Not required
2020-09-13 11:24 abv Changeset attached => occt master 183c99ca
2020-09-13 11:24 abv Assigned To bugmaster => abv
2020-09-13 11:24 abv Status tested => verified
2020-09-13 11:24 abv Resolution open => fixed
2020-09-13 11:47 git Note Added: 0094605


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker