View Issue Details

IDProjectCategoryView StatusLast Update
0030013CommunityOCCT:Data Exchangepublic2022-10-24 10:38
Reporterkamal Assigned Tobugmaster  
PrioritynormalSeveritycrash 
Status feedbackResolutionno change required 
PlatformWindowsOSVC++ 2015 
Product Version7.3.0 
Target Version7.8.0 
Summary0030013: Data Exchange - errors occur on Step file import STEPControl_Reader::ReadFile
DescriptionSTEPControl_Reader::ReadFile throws exception on attached file import
Steps To ReproduceSimple STEPControl_Reader::ReadFile fails with attached step file.
Additional information
and documentation updates
Received the following messages.

*** ERR StepReaderData *** Pour Entite #628902
    Type:ORIENTED_EDGE Param.n0 4: #2147483647 Non trouve
*** ERR StepReaderData *** Pour Entite #633297
    Type:ORIENTED_EDGE Param.n0 4: #2147483647 Non trouve
Report : 354 unknown entities.
TagsNo tags attached.
Test case number

Attached Files

  • 1.zip (9,646,228 bytes)

Activities

kamal

2018-08-03 13:40

reporter  

1.zip (9,646,228 bytes)

kamal

2018-08-03 14:00

reporter   ~0078353

Problem occurs in TransferRoot.

Please refer the following code:
    STEPControl_Reader aReader;
    IFSelect_ReturnStatus status = aReader.ReadFile(this->strStepFileName.c_str());
    if (status != IFSelect_RetDone)
        return nullptr;

    aReader.WS()->TransferReader()->TransientProcess()->SetTraceLevel(2); // increase default trace level

    Standard_Boolean failsonly = Standard_False;
    aReader.PrintCheckLoad(failsonly, IFSelect_ItemsByEntity);

    // Root transfers
    Standard_Integer nbr = aReader.NbRootsForTransfer();
    aReader.PrintCheckTransfer(failsonly, IFSelect_ItemsByEntity);
    for (Standard_Integer n = 1; n <= nbr; n++) {
        Standard_Boolean ok = aReader.TransferRoot(n); // Error Occurs
    }

ssafarov

2021-12-14 12:56

developer   ~0105970

The file is invalid, because some oriented edges contain a non-existent reference to EDGE_CURVE - nothing can be done about this, I suggest closing the bug.

An example of an incorrectly oriented edge: ORIENTED_EDGE ( 'NONE', *, *, #18446744073709551615, .T. )

ssafarov

2021-12-14 13:57

developer   ~0105973

Dear ika, please check my findings and confirm.

ika

2021-12-14 14:12

developer   ~0105974

Dear bugmaster,

I totally agree with ssafarov's problem description.

Please close the issue.

Issue History

Date Modified Username Field Change
2018-08-03 13:40 kamal New Issue
2018-08-03 13:40 kamal Assigned To => gka
2018-08-03 13:40 kamal File Added: 1.zip
2018-08-03 14:00 kamal Note Added: 0078353
2021-12-09 11:01 ika Assigned To gka => ssafarov
2021-12-09 11:01 ika Status new => assigned
2021-12-09 11:22 kgv Target Version => 7.7.0
2021-12-09 11:22 kgv Summary Crash occurs on Step file import STEPControl_Reader::ReadFile => Data Exchange - Crash occurs on Step file import STEPControl_Reader::ReadFile
2021-12-14 12:56 ssafarov Note Added: 0105970
2021-12-14 13:03 kgv Steps to Reproduce Updated
2021-12-14 13:03 kgv Steps to Reproduce Updated
2021-12-14 13:04 kgv Summary Data Exchange - Crash occurs on Step file import STEPControl_Reader::ReadFile => Data Exchange - errors occur on Step file import STEPControl_Reader::ReadFile
2021-12-14 13:57 ssafarov Note Added: 0105973
2021-12-14 13:57 ssafarov Assigned To ssafarov => ika
2021-12-14 13:57 ssafarov Status assigned => resolved
2021-12-14 13:57 ssafarov Steps to Reproduce Updated
2021-12-14 14:12 ssafarov Resolution open => no change required
2021-12-14 14:12 ika Note Added: 0105974
2021-12-14 14:12 ika Assigned To ika => bugmaster
2021-12-14 14:12 ika Status resolved => reviewed
2021-12-14 14:13 kgv Status reviewed => feedback
2022-10-24 10:38 szy Target Version 7.7.0 => 7.8.0