MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029976Community[OCCT] OCCT:Modeling Datapublic2018-07-20 10:402018-10-29 13:13
Reportersraymond 
Assigned Tobugmaster 
PrioritynormalSeveritymajor 
StatusclosedResolutionunable to reproduce 
PlatformMacOSOSOS VersionX
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0029976: Regession from 7.2.0 on osx Faces created from gp_Cir have incorrect location
DescriptionWith the included code (case 0), face position is incorrect as shown on picture.
The issue can't be reproduced on windows os.
The issue can't be reproduced on osx with occt 7.2

BRepPrimAPI_MakeCylinder reproduce the same issue.

The use of gp_Elips gives correct position.

Thje error seems to be only on X coordinate
Steps To Reproduce    TopoDS_Solid aSolid;
    TopoDS_Face circleF;
    int solidBuild = 0;
    switch (solidBuild) {
    case 0:{
        gp_Ax2 anAx2(gp_Pnt(0.5,-0.5,0.5),gp_Dir(0.,1.,0.));
        gp_Circ aCirc(anAx2,0.25);
        TopoDS_Edge EdCircle = BRepBuilderAPI_MakeEdge(aCirc);
        TopoDS_Wire circleW = BRepBuilderAPI_MakeWire(EdCircle);
        circleF = BRepBuilderAPI_MakeFace(circleW,true);
        aSolid = TopoDS::Solid(BRepPrimAPI_MakePrism(circleF,gp_Vec(0.,2.,0.)));
        break;
    }
    case 1:{
        gp_Ax2 anAx2(gp_Pnt(0.5,-0.5,0.5),gp_Dir(0.,1.,0.));
        aSolid = BRepPrimAPI_MakeCylinder(anAx2,0.25,2.).Solid();
        break;
    }
    case 2:{
        gp_Ax2 anAx2(gp_Pnt(0.5,-0.5,0.5),gp_Dir(0.,1.,0.));
        gp_Elips aCirc(anAx2,0.25,0.1);
        TopoDS_Edge EdCircle = BRepBuilderAPI_MakeEdge(aCirc);
        TopoDS_Wire circleW = BRepBuilderAPI_MakeWire(EdCircle);
        circleF = BRepBuilderAPI_MakeFace(circleW,true);
        aSolid = TopoDS::Solid(BRepPrimAPI_MakePrism(circleF,gp_Vec(0.,2.,0.)));
            break;
        }
        default:
            break;
    }
TagsNo tags attached.
Test case number
Attached Filespng file icon bug2.png (272,189 bytes) 2018-07-20 10:40

- Relationships
related to 0029978verifiedbugmaster Open CASCADE Foundation Classes, macOS - the result of reading some entity from STEP looks odd 

-  Notes
(0079832)
abv (manager)
2018-10-09 22:16

@sraymond

The problem seems to be the same as in 0029978, can you please try to apply the fix made for that issue and see whether it helps?
(0079884)
sraymond (developer)
2018-10-11 13:31

@abv

I tried to run the code with a freshly compiled version of oc, using master branch.

The problem is fixed.

Thanks
(0079991)
sraymond (developer)
2018-10-16 08:24

@abv

I tried to run the code with a freshly compiled version of oc, using master branch.

The problem is fixed.

Thanks
(0079994)
msv (developer)
2018-10-16 09:57

Dear bugmaster, please close this bug.

- Issue History
Date Modified Username Field Change
2018-07-20 10:40 sraymond New Issue
2018-07-20 10:40 sraymond Assigned To => msv
2018-07-20 10:40 sraymond File Added: bug2.png
2018-10-09 22:12 abv Relationship added related to 0029978
2018-10-09 22:16 abv Note Added: 0079832
2018-10-09 22:16 abv Assigned To msv => sraymond
2018-10-09 22:16 abv Status new => feedback
2018-10-11 13:31 sraymond Note Added: 0079884
2018-10-16 08:24 sraymond Note Added: 0079991
2018-10-16 08:24 sraymond Assigned To sraymond => msv
2018-10-16 08:24 sraymond Status feedback => resolved
2018-10-16 09:57 msv Note Added: 0079994
2018-10-16 09:57 msv Assigned To msv => bugmaster
2018-10-16 09:57 msv Status resolved => feedback
2018-10-16 09:58 msv Resolution open => unable to reproduce
2018-10-29 13:13 bugmaster Status feedback => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker