MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029904Open CASCADE[OCCT] OCCT:Codingpublic2018-06-29 10:582018-07-14 12:42
Reporterbugmaster 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionduplicate 
PlatformOSOS Version
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0029904: Coding - GCC compiler warnings in OCCT on Fedora 26 64 bit
Descriptiongcc (GCC) 7.3.1 20180130 (Red Hat 7.3.1-2)

IFSelect_ShareOut.cxx:308, GNU C Compiler 4 (gcc), Priority: Normal
'%d' directive writing between 1 and 10 bytes into a region of size 8 [-Wformat-overflow=]

IGESData_IGESWriter.cxx:472, GNU C Compiler 4 (gcc), Priority: Normal
'%7.7d' directive writing between 7 and 10 bytes into a region of size 8 [-Wformat-overflow=]

IGESData_IGESWriter.cxx:472, GNU C Compiler 4 (gcc), Priority: Normal
' T0000001' directive writing 48 bytes into a region of size between 33 and 49 [-Wformat-overflow=]

IGESData_IGESWriter.cxx:472, GNU C Compiler 4 (gcc), Priority: Normal
'%7.7d' directive writing between 7 and 10 bytes into a region of size between 0 and 8 [-Wformat-overflow=]
Steps To ReproduceBuild with GCC7.3
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0029834verifiedbugmaster Coding Rules - eliminate GCC compiler warnings -Wformat-overflow in IGESData_IGESWriter 

-  Notes
(0077247)
git (administrator)
2018-07-04 00:59

Branch CR29904 has been created by abv.

SHA-1: 0ff6e08a85186bd08c38c7120274015d73ecf961


Detailed log of new commits:

Author: abv
Date: Wed Jul 4 00:54:46 2018 +0300

    0029904: Coding - GCC compiler warnings in OCCT on Fedora 26 64 bit
    
    String buffers are increased to be sufficient to accommodate result of sprintf() for any possible values of integer values being printed.
(0077248)
abv (manager)
2018-07-04 01:01

Fix pushed to CR29904, please review. I suppose that testing is not needed, but we need to check that the warnings disappeared (I could not).
(0077250)
kgv (developer)
2018-07-04 08:04

> I suppose that testing is not needed,
> but we need to check that the warnings disappeared (I could not).
Looks OK, only -Warray-bounds warning remains:
http://jenkins-test-12.nnov.opencascade.com/view/CR29904-master-KGV/ [^]
(0077253)
kgv (developer)
2018-07-04 10:05

Please close duplicate.
(0077387)
bugmaster (administrator)
2018-07-09 11:00

Problem has been fixed in framework 0029834
(0077622)
git (administrator)
2018-07-14 12:42

Branch CR29904 has been deleted by inv.

SHA-1: 0ff6e08a85186bd08c38c7120274015d73ecf961

- Issue History
Date Modified Username Field Change
2018-06-29 10:58 bugmaster New Issue
2018-06-29 10:58 bugmaster Assigned To => kgv
2018-06-29 10:59 bugmaster Status new => assigned
2018-06-29 11:03 kgv Relationship added duplicate of 0029834
2018-06-29 11:03 kgv Resolution open => duplicate
2018-06-29 11:39 bugmaster Summary Coding - GCC compiler warnings on Fedora 26 64 bit => Coding - GCC compiler warnings in OCCT on Fedora 26 64 bit
2018-07-03 15:21 kgv Assigned To kgv => abv
2018-07-03 15:21 kgv Product Version => 7.3.0
2018-07-04 00:59 git Note Added: 0077247
2018-07-04 01:01 abv Note Added: 0077248
2018-07-04 01:01 abv Assigned To abv => kgv
2018-07-04 01:01 abv Status assigned => resolved
2018-07-04 01:01 abv Steps to Reproduce Updated View Revisions
2018-07-04 08:04 kgv Note Added: 0077250
2018-07-04 08:04 kgv Assigned To kgv => bugmaster
2018-07-04 08:04 kgv Status resolved => reviewed
2018-07-04 10:05 kgv Note Added: 0077253
2018-07-04 10:05 kgv Status reviewed => feedback
2018-07-09 11:00 bugmaster Note Added: 0077387
2018-07-09 11:00 bugmaster Status feedback => verified
2018-07-14 12:42 git Note Added: 0077622


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker