MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029811Open CASCADE[OCCT] OCCT:Testspublic2018-05-24 12:422018-06-29 21:18
Reporterkgv 
Assigned Toabv 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.1.0 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0029811: Tests - unstable tests demo\draw\binpersist_* due to usage of the same temporary file name
DescriptionTest cases binpersist_1, binpersist_2 and binpersist_3 specify the same file name for a temporary file with test case suffix:
> set file binpersist.bin

This leads to collisions while executing these tests in parallel processes.

CR29621_2-master-KGV-OCCT-Debian70-64-opt-test-compare - Build # 1 - Failure:

pload TOPTEST 
brestore /dn62/occt_tests_data/public/brep/bug23849_segment_2.brep n 
binsave b binpersist.bin 
binrestore binpersist.bin bb 
Tcl Exception: error deleting "binpersist.bin": no such file or directory
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0076223)
git (administrator)
2018-05-24 12:47

Branch CR29811 has been created by kgv.

SHA-1: 7c5fd420f4f5718fd0330d47c7a956796edbbc0d


Detailed log of new commits:

Author: kgv
Date: Thu May 24 12:47:28 2018 +0300

    0029811: Tests - unstable tests demo\draw\binpersist_* due to usage of the same temporary file name
(0076224)
kgv (developer)
2018-05-24 12:53
edited on: 2018-05-24 13:47

Patch is ready for review.

http://jenkins-test-11.nnov.opencascade.com/view/CR29811-master-KGV/ [^]

(0076244)
abv (manager)
2018-05-24 17:00

Reviewed, please integrate
(0076245)
bugmaster (administrator)
2018-05-24 17:44

Combination -
OCCT branch : CR29811 SHA - 7c5fd420f4f5718fd0330d47c7a956796edbbc0d
Products branch : master SHA - 300cf879a836fb8a5c4636713070ca9cf544749f
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian70-64:
OCCT
Total CPU difference: 18213.369999999846 / 18243.73999999987 [-0.17%]
Products
Total CPU difference: 7499.340000000043 / 7502.690000000051 [-0.04%]
Windows-64-VC10:
OCCT
Total CPU difference: 18088.331550098454 / 18049.78370299853 [+0.21%]
Products
Total CPU difference: 8235.214789499867 / 8222.282306599882 [+0.16%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0076961)
git (administrator)
2018-06-23 13:56

Branch CR29811 has been deleted by kgv.

SHA-1: 7c5fd420f4f5718fd0330d47c7a956796edbbc0d

- Related Changesets
occt: master c9ebb2dd
Timestamp: 2018-05-24 09:47:28
Author: abv
Committer: abv
Details ] Diff ]
0029811: Tests - unstable tests demo\draw\binpersist_* due to usage of the same temporary file name
mod - tests/demo/draw/binpersist_1 Diff ] File ]
mod - tests/demo/draw/binpersist_2 Diff ] File ]
mod - tests/demo/draw/binpersist_3 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-05-24 12:42 kgv New Issue
2018-05-24 12:42 kgv Assigned To => apn
2018-05-24 12:47 kgv Summary Tests - unstable tests demo\draw\binpersist_* due to usage of the same name => Tests - unstable tests demo\draw\binpersist_* due to usage of the same temporary file name
2018-05-24 12:47 git Note Added: 0076223
2018-05-24 12:48 kgv Relationship added child of 0027245
2018-05-24 12:48 kgv Product Version 7.3.0 => 7.1.0
2018-05-24 12:53 kgv Note Added: 0076224
2018-05-24 12:53 kgv Assigned To apn => abv
2018-05-24 12:53 kgv Status new => resolved
2018-05-24 13:47 kgv Note Edited: 0076224 View Revisions
2018-05-24 13:56 kgv Description Updated View Revisions
2018-05-24 17:00 abv Note Added: 0076244
2018-05-24 17:00 abv Assigned To abv => bugmaster
2018-05-24 17:00 abv Status resolved => reviewed
2018-05-24 17:44 bugmaster Note Added: 0076245
2018-05-24 17:44 bugmaster Status reviewed => tested
2018-05-24 17:44 bugmaster Test case number => Not needed
2018-05-29 12:33 abv Changeset attached => occt master c9ebb2dd
2018-05-29 12:33 abv Assigned To bugmaster => abv
2018-05-29 12:33 abv Status tested => verified
2018-05-29 12:33 abv Resolution open => fixed
2018-06-23 13:56 git Note Added: 0076961
2018-06-29 21:13 user533 Fixed in Version => 7.3.0
2018-06-29 21:18 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker