MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029803Community[OCCT] OCCT:Data Exchangepublic2018-05-23 01:332020-03-30 18:11
Reporterthomhong 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformWindowsOSVC++ 2015OS Version64 bit
Product Version[OCCT] 7.1.0 
Target VersionFixed in Version 
Summary0029803: STEP Import: Units (inch) not applied to entity possessing GEOMETRIC_REPRESENTATION_CONTEXT
DescriptionWhen importing the attached STEP model, the AXIS2_PLACEMENT_3D entities (#1729, #1736) are imported with the GEOMETRIC_REPRESENTATION_CONTEXT (#1750), but the context's units (INCH) are not applied and the coordinates are not converted to inch.

In the same file, the MANIFOLD_SOLID_BREP (#1719) shape is imported using the same context (#1750) and the context units are properly applied so coordinates are converted to inch.

Tested under 7.1.0 and 7.3.0-beta.
Steps To ReproduceImport the attached file using STEP. Set breakpoint on import of AXIS2_PLACEMENT_3D entities where the entity name equals "CSW".

Location coordinate has Z=-1.64 when expected coordinate has Z=-41.66.
TagsNo tags attached.
Test case numberbugs/step/bug29803
Attached Files? file icon Tool1.stp (137,200 bytes) 2018-05-23 01:33

- Relationships

-  Notes
(0090289)
gka (developer)
2020-02-04 15:14

Please note that mentioned in the issue entities #1729 and #1736 are a part of entity :
#1752 (CONSTRUCTIVE_GEOMETRY_REPRESENTATION('supplemental geometry',(#1729,#1736),#1750);.

This entity is read from file in the model but it does not translated by OCCT STEP translator. Therefore entities AXIS2_PLACEMENT_3D that containing in this entity are not translated and units written in the file are not applied to them.
(0090582)
git (administrator)
2020-02-18 10:27

Branch CR29803 has been created by gka.

SHA-1: f2b1498dc6be3088c4448f867565642e58d872de


Detailed log of new commits:

Author: gka
Date: Mon Feb 17 20:24:59 2020 +0300

    0029803: STEP Import: Units (inch) not applied to entity possessing GEOMETRIC_REPRESENTATION_CONTEXT
    
    Translation of the entities AXIS2_PLACEMENT_3D including in the entity CONSTRUCTIVE_GEOMETRY_REPRESENTATION was added.
    Entity AXIS2_PLACEMENT_3D is translated to the planar face with axis equal to AXIS2_PLACEMENT_3D
    Translation AXIS2_PLACEMENT_3D including in the entity CONSTRUCTIVE_GEOMETRY_REPRESENTATION is performed by parameter "read.step.constructivegeom.relationship" (by default it is OFF)
(0090586)
git (administrator)
2020-02-18 12:49

Branch CR29803 has been updated by gka.

SHA-1: 864e05cb7b5451481eca3f826320e23d38ef35a5


Detailed log of new commits:

Author: gka
Date: Tue Feb 18 12:49:13 2020 +0300

    0029803: STEP Import: Units (inch) not applied to entity possessing GEOMETRIC_REPRESENTATION_CONTEXT
    
    Remove debug printing

(0090729)
git (administrator)
2020-02-28 18:50

Branch CR29803 has been updated forcibly by gka.

SHA-1: b98ce9b8c2ad9a91c12b22e402c2927021491baf
(0090754)
git (administrator)
2020-03-02 11:51

Branch CR29803 has been updated forcibly by gka.

SHA-1: 652653b2709dac7b79db0458d38397c6cc9545e6
(0090777)
gka (developer)
2020-03-02 17:03

Results of testing can be find by path:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR29803-master-gka/view/COMPARE/ [^]
(0090779)
gka (developer)
2020-03-02 17:21

Branch CR29803 is ready to be reviewed.

This fix added translation of AXIS2_PLACEMENT_3D entities that are part of the CONSTRUCTIVE_GEOMETRY_REPRESENTATION entity. The AXIS2_PLACEMENT_3D entity is translated to a flat face with an axis equal to AXIS2_PLACEMENT_3D The translation of AXIS2_PLACEMENT_3D included in the CONSTRUCTIVE_GEOMETRY_REPRESENTATION entity is performed using the new parameter "read.step.constructivegeom.relationship" (by default it is OFF).
(0090991)
abv (manager)
2020-03-17 18:05

Please provide documentation of the new parameter in STEP User Guide, if possible with explanation when and how it is useful
(0091030)
git (administrator)
2020-03-18 14:58

Branch CR29803 has been updated by gka.

SHA-1: 8396d6c306eeee29bb9617e1c0f403d0300ad297


Detailed log of new commits:

Author: gka
Date: Wed Mar 18 14:59:01 2020 +0300

    Modified documentation for issue 0029803

(0091031)
gka (developer)
2020-03-18 15:00

Documentation stet.md was modified.
Branch CR29803 is ready to be reviewed
(0091083)
gka (developer)
2020-03-20 14:33

Please note that in according with "Recommended Practices
for Supplemental Geometry" Release 1.1 August 23, 2019 Art 5:
"The basic idea behind the definition of Supplemental Geometry is to handle it not as a portion of the part shape, but as a separate “shape”, which is intended to provide additional information related to the part shape.
The definition of the supplemental geometry itself follows the usual pattern, with the notable difference that unbound geometric elements (such as an infinite planes) are allowed."
(0091095)
git (administrator)
2020-03-20 19:58

Branch CR29803 has been updated forcibly by gka.

SHA-1: 902609e26fab929b02bf7712248ede8577144a6c
(0091194)
git (administrator)
2020-03-23 14:20

Branch CR29803 has been updated forcibly by gka.

SHA-1: ab1ffb4ee3556d3a2ea3b1b198f7eac34ab02190
(0091200)
gka (developer)
2020-03-23 18:26

Please find results of test by path:
http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR29803-master-gka/view/COMPARE/ [^]

Please note that in the last commit was added correspondence between AXIS2_PLACEMENT_3D belonging to CONSTRUCTIVE_GEOMETRY_REPRESENTATION and result planar face.

Obtained after reading planar face can be obtained with following code:

 Handle(Transfer_Binder) binder = TP->Find(axis);
 Handle(TransferBRep_ShapeBinder) shbinder = Handle(TransferBRep_ShapeBinder)::DownCast(binder);
 const TopoDS_Shape& aFace = shbinder->Result();


In the Test Harness it is possible to use commands "tpdraw" or "fromshape" and "entity".

For example:
Draw[7]> param read.step.constructivegeom.relationship ON
     FORMER STATUS of Static Parameter read.step.constructivegeom.relationship
Value : OFF
New demanded value : ON OK

Draw[8]> new model
Draw[9]> stepread File1.stp a *


Draw[10]> tpdraw #1729
Entite de modele, n0 1555
 ent.n0 1555, item transfert n0 284 -> 1 DRAW Shape: tp_1555
(0091204)
git (administrator)
2020-03-24 11:12

Branch CR29803_1 has been created by abv.

SHA-1: 529f94c40043e543a42649d13aa4b302be679e55


Detailed log of new commits:

Author: gka
Date: Mon Feb 17 20:24:59 2020 +0300

    0029803: STEP Import: Units (inch) not applied to entity possessing GEOMETRIC_REPRESENTATION_CONTEXT
    
    Translation of the entities AXIS2_PLACEMENT_3D including in the entity CONSTRUCTIVE_GEOMETRY_REPRESENTATION_RELATIONSHIP was added.
    Entity AXIS2_PLACEMENT_3D is translated to the planar face with axis equal to AXIS2_PLACEMENT_3D.
    New parameter "read.step.constructivegeom.relationship" is added to enable this translation (by default it is OFF).
(0091226)
git (administrator)
2020-03-25 00:48

Branch CR29803_1 has been updated forcibly by abv.

SHA-1: f3069582e6178ffec5cc67301dbf2838507ab4df
(0091229)
git (administrator)
2020-03-25 07:37

Branch CR29803_1 has been updated forcibly by abv.

SHA-1: 881488ce0a5c322d67bbc795e8827b9b54b27212
(0091231)
abv (manager)
2020-03-25 07:51

Reviewed, with update of documentation; test added. Tests are OK, see Jenkins job CR29803-master-gka, except that new test bugs step bug29803 is SKIPPED because of lack of data file. Please put file Tool1.stp attached to this issue into the test data repository under the name "bug29803.stp".

Branch to be integrated:
OCCT: CR29803_1 at 881488ce0a5c322d67bbc795e8827b9b54b27212
Products: none
(0091264)
bugmaster (administrator)
2020-03-26 12:45

Combination -
OCCT branch : WEEK-13
master SHA - 89180f98222651faa3f1cffe9f6d5a9abae8a4e8
fe4497f3246e6bc1ced97ac331c148f0809ded15
Products branch : WEEK-13 SHA - f10b867b449ebfa55e0a3c8cb276ae511f9cf7f2
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 16843.850000000195 / 16846.320000000138 [-0.01%]
Products
Total CPU difference: 11298.030000000097 / 11306.210000000074 [-0.07%]
Windows-64-VC14:
OCCT
Total CPU difference: 18288.453125 / 18268.796875 [+0.11%]
Products
Total CPU difference: 13126.15625 / 13110.609375 [+0.12%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0091323)
git (administrator)
2020-03-28 13:46

Branch CR29803_1 has been deleted by inv.

SHA-1: 881488ce0a5c322d67bbc795e8827b9b54b27212
(0091325)
git (administrator)
2020-03-28 13:46

Branch CR29803 has been deleted by inv.

SHA-1: ab1ffb4ee3556d3a2ea3b1b198f7eac34ab02190

- Related Changesets
occt: master 89180f98
Timestamp: 2020-02-17 17:24:59
Author: gka
Committer: bugmaster
Details ] Diff ]
0029803: STEP Import: Units (inch) not applied to entity possessing GEOMETRIC_REPRESENTATION_CONTEXT

Translation of the entities AXIS2_PLACEMENT_3D including in the entity CONSTRUCTIVE_GEOMETRY_REPRESENTATION_RELATIONSHIP was added.
Entity AXIS2_PLACEMENT_3D is translated to the planar face with axis equal to AXIS2_PLACEMENT_3D.
New parameter "read.step.constructivegeom.relationship" is added to enable this translation (by default it is OFF).

Added test bugs step bug29803
mod - dox/user_guides/step/step.md Diff ] File ]
mod - src/STEPControl/STEPControl_ActorRead.cxx Diff ] File ]
mod - src/STEPControl/STEPControl_ActorRead.hxx Diff ] File ]
mod - src/STEPControl/STEPControl_Controller.cxx Diff ] File ]
add - tests/bugs/step/bug29803 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-05-23 01:33 thomhong New Issue
2018-05-23 01:33 thomhong Assigned To => gka
2018-05-23 01:33 thomhong File Added: Tool1.stp
2020-02-04 15:14 gka Note Added: 0090289
2020-02-18 10:27 git Note Added: 0090582
2020-02-18 12:49 git Note Added: 0090586
2020-02-28 18:50 git Note Added: 0090729
2020-03-02 11:51 git Note Added: 0090754
2020-03-02 17:03 gka Note Added: 0090777
2020-03-02 17:21 gka Note Added: 0090779
2020-03-02 17:21 gka Assigned To gka => abv
2020-03-02 17:21 gka Status new => resolved
2020-03-17 18:05 abv Note Added: 0090991
2020-03-17 18:05 abv Assigned To abv => gka
2020-03-17 18:05 abv Status resolved => assigned
2020-03-18 14:58 git Note Added: 0091030
2020-03-18 15:00 gka Note Added: 0091031
2020-03-18 15:00 gka Status assigned => resolved
2020-03-20 11:00 gka Assigned To gka => abv
2020-03-20 14:33 gka Note Added: 0091083
2020-03-20 19:58 git Note Added: 0091095
2020-03-23 14:20 git Note Added: 0091194
2020-03-23 18:26 gka Note Added: 0091200
2020-03-24 11:12 git Note Added: 0091204
2020-03-25 00:48 git Note Added: 0091226
2020-03-25 07:37 git Note Added: 0091229
2020-03-25 07:51 abv Note Added: 0091231
2020-03-25 07:51 abv Assigned To abv => bugmaster
2020-03-25 07:51 abv Status resolved => reviewed
2020-03-26 12:45 bugmaster Note Added: 0091264
2020-03-26 12:45 bugmaster Status reviewed => tested
2020-03-26 12:45 bugmaster Test case number => bugs/step/bug29803
2020-03-28 13:36 bugmaster Changeset attached => occt master 89180f98
2020-03-28 13:36 bugmaster Status tested => verified
2020-03-28 13:36 bugmaster Resolution open => fixed
2020-03-28 13:46 git Note Added: 0091323
2020-03-28 13:46 git Note Added: 0091325
2020-03-30 18:11 gka Relationship added parent of 0031472


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker