MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029750Open CASCADE[OCCT] OCCT:Samplespublic2018-05-10 10:192020-12-26 14:52
Reporternds 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusverifiedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.5.0 
Target Version[OCCT] 7.6.0*Fixed in Version 
Summary0029750: Samples - function arrows are not updated by moving a node in FuncDemo qt sample
DescriptionFuncDemo compiled with Qt 5.10.1 has not updated links as shown on attached picture.
Steps To ReproduceNatasha, could you review please?

The tests passed well: http://vm-jenkins-test-12.nnov.opencascade.com:8080/view/CR29750_1-master-vro/view/COMPARE/ [^]

For bugmaster:
a sample Qt/FuncDemo in the branch CR29750_1.
TagsNo tags attached.
Test case numberNot required
Attached Filespng file icon FuncDemo_Sh_node_moved.png (84,691 bytes) 2018-05-10 10:19

- Relationships

-  Notes
(0097005)
git (administrator)
2020-11-23 11:41

Branch CR29750 has been created by vro.

SHA-1: 973ef894cd390f2c75262b67bcbb1ab287475ca0


Detailed log of new commits:

Author: Vlad Romashko
Date: Mon Nov 23 11:41:59 2020 +0300

    0029750: Samples - function arrows are not updated by moving a node in FuncDemo qt sample
    
    The visual links between functions are recovers.
    The demo is synchronized with a corresponding demo from Qt (qt486-vc10-32\examples\graphicsview\elasticnodes). It may be successfully compiled by any further versions of Qt including 5.10.1
(0097055)
git (administrator)
2020-11-25 10:42

Branch CR29750_1 has been created by vro.

SHA-1: 943d7f611c785a04979079908fb781620b14e178


Detailed log of new commits:

Author: Vlad Romashko
Date: Wed Nov 25 10:42:20 2020 +0300

    0029750: Samples - function arrows are not updated by moving a node in FuncDemo qt sample
    
    The visual links between functions are recovers.
    The demo is synchronized with a corresponding demo from Qt (qt486-vc10-32\examples\graphicsview\elasticnodes). It may be successfully compiled by any further versions of Qt including 5.10.1
    Also, because Open CASCADE (and OCAF in particular) is improved for usage in multi-threading mode, usage of mutexes is added in this sample (for access to the sharing TNaming_UsedShapes attribute, for example).
(0097092)
kgv (developer)
2020-11-26 12:15

Vlad,

+//! [0]

what is the purpose for these new confusing comment blocks?
Could them be replaced by simple description?
(0097624)
nds (developer)
2020-12-16 10:37

Dear Vlad,
could you please correct Kirill's remark.
(0097652)
vro (developer)
2020-12-17 08:45

Hello Kirill, hello Natasha! These comments come from Qt's sample. All headers in the sample are kept as in Qt sample and all the code, except several lines dedicated to Function Demo.
I suppose the questionable comment comes from a tutorial in Qt. Should we remove these lines? Indeed, we don't need them, but if we remove them, we will introduce more difference to the Qt's sample.
I have no own opinion... If you think it worth removing the lines, I will do it. Just let me know please.
(0097662)
nds (developer)
2020-12-17 11:24

Kirill, please check.

It looks reasonable.
(0097664)
kgv (developer)
2020-12-17 11:29

OK.
(0097665)
nds (developer)
2020-12-17 11:38

Dear Vlad,

It's Ok, please cherry pick it on the current master and relaunch tests.
Please give details for Igor which branch is.

Best regards, Natalia
(0097666)
kgv (developer)
2020-12-17 11:43

Vlad, could you please also correct git commit author to match common style using acronyms?
(0097673)
git (administrator)
2020-12-17 13:17

Branch CR29750_2 has been created by vro.

SHA-1: 953c28fb10494dd095b997258bc5199bf6ec42ef


Detailed log of new commits:

Author: vro
Date: Thu Dec 17 13:17:46 2020 +0300

    0029750: Samples - function arrows are not updated by moving a node in FuncDemo qt sample
    
    The visual links between functions are recovered.
    The demo is synchronized with a corresponding demo from Qt (qt486-vc10-32\examples\graphicsview\elasticnodes). It may be successfully compiled by any further versions of Qt including 5.10.1
    Also, because Open CASCADE (and OCAF in particular) is improved for usage in multi-threading mode, usage of mutexes is added in this sample (for access to the sharing TNaming_UsedShapes attribute, for example).
(0097695)
vro (developer)
2020-12-17 20:06

Updated to current master.
(0097919)
bugmaster (administrator)
2020-12-26 12:16

Combination -
OCCT branch : WEEK-52
master SHA - 41046145c4a15f5cedf5f3c5877952ee00d568b4
a206de37fbfa0bf71bd534ae47192bbec23b8522
Products branch : WEEK-52 SHA - 290e5c74e8fef71947cadf90acb8e43c81ed10a1
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian80-64:
OCCT
Total CPU difference: 17722.770000000193 / 17710.950000000055 [+0.07%]
Products
Total CPU difference: 12416.490000000109 / 12412.520000000126 [+0.03%]
Windows-64-VC14:
OCCT
Total CPU difference: 19321.5625 / 19274.6875 [+0.24%]
Products
Total CPU difference: 13844.421875 / 13853.046875 [-0.06%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0097924)
git (administrator)
2020-12-26 14:52

Branch CR29750 has been deleted by inv.

SHA-1: 973ef894cd390f2c75262b67bcbb1ab287475ca0
(0097925)
git (administrator)
2020-12-26 14:52

Branch CR29750_1 has been deleted by inv.

SHA-1: 943d7f611c785a04979079908fb781620b14e178
(0097926)
git (administrator)
2020-12-26 14:52

Branch CR29750_2 has been deleted by inv.

SHA-1: 953c28fb10494dd095b997258bc5199bf6ec42ef

- Related Changesets
occt: master 894133a5
Timestamp: 2020-12-17 10:17:46
Author: vro
Committer: bugmaster
Details ] Diff ]
0029750: Samples - function arrows are not updated by moving a node in FuncDemo qt sample

The visual links between functions are recovered.
The demo is synchronized with a corresponding demo from Qt (qt486-vc10-32\examples\graphicsview\elasticnodes). It may be successfully compiled by any further versions of Qt including 5.10.1
Also, because Open CASCADE (and OCAF in particular) is improved for usage in multi-threading mode, usage of mutexes is added in this sample (for access to the sharing TNaming_UsedShapes attribute, for example).
mod - samples/qt/FuncDemo/custom.bat Diff ] File ]
mod - samples/qt/FuncDemo/src/BaseDriver.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/BaseDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/CircleDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/ConeDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/CylinderDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/edge.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/edge.h Diff ] File ]
mod - samples/qt/FuncDemo/src/FThread.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/FThread.h Diff ] File ]
mod - samples/qt/FuncDemo/src/graphwidget.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/graphwidget.h Diff ] File ]
mod - samples/qt/FuncDemo/src/mainwindow.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/node.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/node.h Diff ] File ]
mod - samples/qt/FuncDemo/src/PointDriver.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/PointDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/PrismDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/ShapeSaverDriver.cpp Diff ] File ]
mod - samples/qt/FuncDemo/src/ShapeSaverDriver.h Diff ] File ]
mod - samples/qt/FuncDemo/src/SimpleDriver.h Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-05-10 10:19 nds New Issue
2018-05-10 10:19 nds Assigned To => vro
2018-05-10 10:19 nds File Added: FuncDemo_Sh_node_moved.png
2018-07-05 10:06 abv Category OCCT:Samples => OCCT:Inspectors
2019-09-04 15:36 abv Target Version 7.4.0 => 7.5.0
2020-10-26 11:14 nds Category OCCT:Inspectors => OCCT:Samples
2020-10-26 11:14 nds Summary Samples - Inspector tool - function arrows are not updated by moving a node in FuncDemo qt sample => Samples - function arrows are not updated by moving a node in FuncDemo qt sample
2020-10-26 11:17 vro Target Version 7.5.0 => 7.6.0*
2020-11-23 11:41 git Note Added: 0097005
2020-11-23 11:44 kgv Product Version => 7.5.0
2020-11-25 10:42 git Note Added: 0097055
2020-11-25 14:06 vro Assigned To vro => nds
2020-11-25 14:06 vro Status new => resolved
2020-11-25 14:06 vro Steps to Reproduce Updated View Revisions
2020-11-26 12:15 kgv Note Added: 0097092
2020-12-16 10:37 nds Note Added: 0097624
2020-12-16 10:37 nds Assigned To nds => vro
2020-12-16 10:37 nds Status resolved => assigned
2020-12-17 08:45 vro Note Added: 0097652
2020-12-17 11:24 nds Note Added: 0097662
2020-12-17 11:24 nds Assigned To vro => kgv
2020-12-17 11:24 nds Status assigned => resolved
2020-12-17 11:29 kgv Note Added: 0097664
2020-12-17 11:29 kgv Assigned To kgv => nds
2020-12-17 11:38 nds Note Added: 0097665
2020-12-17 11:38 nds Assigned To nds => vro
2020-12-17 11:38 nds Status resolved => reviewed
2020-12-17 11:43 kgv Note Added: 0097666
2020-12-17 13:17 git Note Added: 0097673
2020-12-17 20:06 vro Note Added: 0097695
2020-12-17 20:06 vro Assigned To vro => bugmaster
2020-12-17 20:06 vro Status reviewed => feedback
2020-12-25 15:07 vro Status feedback => resolved
2020-12-25 16:57 bugmaster Status resolved => reviewed
2020-12-26 12:16 bugmaster Note Added: 0097919
2020-12-26 12:16 bugmaster Status reviewed => tested
2020-12-26 12:22 bugmaster Test case number => Not required
2020-12-26 14:40 bugmaster Changeset attached => occt master 894133a5
2020-12-26 14:40 bugmaster Status tested => verified
2020-12-26 14:40 bugmaster Resolution open => fixed
2020-12-26 14:52 git Note Added: 0097924
2020-12-26 14:52 git Note Added: 0097925
2020-12-26 14:52 git Note Added: 0097926


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker