MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029733Open CASCADE[OCCT] OCCT:Inspectorspublic2018-04-28 17:022018-07-05 10:09
Reporterszy 
Assigned Toabv 
PrioritynormalSeveritycrash 
StatusclosedResolutionfixed 
PlatformWindowsOSVC++ 2010OS Version64 bit
Product Version[OCCT] 7.2.0 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0029733: TInspector can't open several cbf files
DescriptionDuring attempt to open cbf file TInspector raises exception.
TagsNo tags attached.
Test case numberNot needed
Attached Filespng file icon Capture.PNG (40,086 bytes) 2018-04-28 17:04
? file icon bug29733.cbf (17,704 bytes) 2018-05-08 15:39
? file icon bug29743.cbf (163,277 bytes) 2018-05-08 15:39

- Relationships
related to 0029743closedabv Samples - Inspector tool - crash by selecting TNaming_UsedShapes tree item 

-  Notes
(0075886)
git (administrator)
2018-05-08 15:33

Branch CR29733 has been created by nds.

SHA-1: 6a3c7f74acb46a023a280f31cbab7136f6640cf4


Detailed log of new commits:

Author: nds
Date: Tue May 8 15:33:20 2018 +0300

    0029733: TInspector can't open several cbf files
    
    The issue is not reproduced anymore. The integration contains DRAW test for described functionality.
(0075890)
nds (developer)
2018-05-08 15:37

ttt_1.cbf is renamed to bug29743.cbf (and used for checking the issue also)
ttt_2.cbf is renamed to bug29733.cbf

The problem has been already fixed during implementation of improvements in Inspector after the 7.2.0 release.

This issue integration contains test case to check the described functionality.
(0075891)
nds (developer)
2018-05-08 15:37

Please, review modifications
(0075892)
szy (developer)
2018-05-08 16:29

Reviewed.
(0076136)
bugmaster (administrator)
2018-05-23 10:56

Adding test case only
(0076270)
git (administrator)
2018-05-24 18:13

Branch CR29733 has been deleted by kgv.

SHA-1: 6a3c7f74acb46a023a280f31cbab7136f6640cf4

- Related Changesets
occt: master 72e4db54
Timestamp: 2018-05-08 12:33:20
Author: abv
Committer: abv
Details ] Diff ]
0029733: TInspector can't open several cbf files

The issue is not reproduced anymore. The integration contains DRAW test for described functionality.
add - tests/tools/dfbrowser/A8 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-04-28 17:02 szy New Issue
2018-04-28 17:02 szy Assigned To => mpv
2018-04-28 17:02 szy File Added: ttt_1.cbf
2018-04-28 17:04 szy File Added: ttt_2.cbf
2018-04-28 17:04 szy File Added: Capture.PNG
2018-04-28 17:06 mpv Assigned To mpv => nds
2018-05-08 14:42 nds Relationship added related to 0029743
2018-05-08 14:42 nds Status new => resolved
2018-05-08 15:33 git Note Added: 0075886
2018-05-08 15:37 nds Note Added: 0075890
2018-05-08 15:37 nds Note Added: 0075891
2018-05-08 15:37 nds Assigned To nds => szy
2018-05-08 15:37 nds Target Version 7.4.0* => 7.3.0
2018-05-08 15:38 nds File Deleted: ttt_1.cbf
2018-05-08 15:38 nds File Deleted: ttt_2.cbf
2018-05-08 15:39 nds File Added: bug29733.cbf
2018-05-08 15:39 nds File Added: bug29743.cbf
2018-05-08 16:29 szy Note Added: 0075892
2018-05-08 16:29 szy Assigned To szy => bugmaster
2018-05-08 16:29 szy Status resolved => reviewed
2018-05-23 10:56 bugmaster Note Added: 0076136
2018-05-23 10:56 bugmaster Status reviewed => tested
2018-05-23 12:28 bugmaster Test case number => Not needed
2018-05-24 16:02 abv Changeset attached => occt master 72e4db54
2018-05-24 16:02 abv Assigned To bugmaster => abv
2018-05-24 16:02 abv Status tested => verified
2018-05-24 16:02 abv Resolution open => fixed
2018-05-24 18:13 git Note Added: 0076270
2018-06-29 21:13 user533 Fixed in Version => 7.3.0
2018-06-29 21:19 user533 Status verified => closed
2018-07-05 10:09 abv Category OCCT:Application Framework => OCCT:Inspectors


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker