MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029680Open CASCADE[OCCT] OCCT:Testspublic2018-04-08 18:482018-06-29 21:19
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 7.0.0 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0029680: Tests - command checkprops does not work for negative values
DescriptionCheck of mass (volume, area, length) properties performed by DRAW command checkprops always passes without error if specified reference value is negative.

Note: apparently the problem has been discovered and fixed during analysis of visual differences after fix of #28903, initially within patch for #29663
Steps To Reproducepload MODELING
box b 10 10 10
# the following command gives no error in OCCT 7.2.0
checkprops b -v -10
TagsNo tags attached.
Test case numberoffset faces_type_i E5
Attached Files

- Relationships

-  Notes
(0075232)
git (administrator)
2018-04-08 19:02

Branch CR29680 has been created by abv.

SHA-1: 5ee45510486e7fd6b236e9a888db7603c0162862


Detailed log of new commits:

Author: abv
Date: Sun Apr 8 18:52:31 2018 +0300

    0029680: Tests - command checkprops does not work for negative values
    
    DRAW command checkprops is corrected to handle properly negative reference values.
    
    Test case offset faces_face_i E5 is corrected (improvement due to #28903)
(0075234)
git (administrator)
2018-04-08 21:25

Branch CR29680 has been updated forcibly by abv.

SHA-1: 44d6f595f3993db6ad02421d669666b517160e5b
(0075236)
git (administrator)
2018-04-09 07:20

Branch CR29680 has been updated forcibly by abv.

SHA-1: 4669a4a01870a7fb090000da273ed8f30ca4d61f
(0075237)
abv (manager)
2018-04-09 08:28

Fix pushed to CR29680, please review.

The test results are in Jenkins job CR29680-master-abv. Note that failure of test offset faces_face_i E5 was due to remaining extra TODO statement due to incorrect rebase, this is corrected in the last version of the branch. Image differences in OCCT tests and failures on Products tests are apparently due to other changes in the IR_WEEK12 branch on which CR29680 is based.
(0075238)
nbv (developer)
2018-04-09 09:43

Reviewed.

Dear Bugmaster,

Please exclude the file "CheckCommands.tcl" from remotes/origin/CR29663_2 branch because its functionality is a duplicate of this fix.
(0075239)
nbv (developer)
2018-04-09 09:52

> Please exclude the file "CheckCommands.tcl" from remotes/origin/CR29663_2 branch because its functionality is a duplicate of this fix.

I am sorry.

It is already done in the branch CR29663_3.
(0075244)
bugmaster (administrator)
2018-04-09 13:20

OCCT branch : IR-WEEK12 SHA - a23e23b5e5e56f10d15e85518195162b347d5ac4
Products branch : IR-WEEK12 SHA - 8471189e8649026d76950924f8ec2b4878cba528
was compiled on Linux, MacOS and Windows platforms and tested in optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
Debian70-64:
OCCT
Total CPU difference: 18180.84999999974 / 18135.489999999976 [+0.25%]
Products
Total CPU difference: 7464.190000000011 / 7435.139999999992 [+0.39%]
Windows-64-VC10:
OCCT
Total CPU difference: 17769.964709298587 / 17864.39211459853 [-0.53%]
Products
Total CPU difference: 8154.078669399982 / 8129.77371359997 [+0.30%]


Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0075351)
git (administrator)
2018-04-11 11:00

Branch CR29680 has been deleted by kgv.

SHA-1: 4669a4a01870a7fb090000da273ed8f30ca4d61f

- Related Changesets
occt: master 9b74e207
Timestamp: 2018-04-08 15:52:31
Author: abv
Committer: bugmaster
Details ] Diff ]
0029680: Tests - command checkprops does not work for negative values

DRAW command checkprops is corrected to handle properly negative reference values.

Test case offset faces_face_i E5 is corrected (improvement due to #28903)
mod - src/DrawResources/CheckCommands.tcl Diff ] File ]
mod - tests/offset/faces_type_i/E5 Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-04-08 18:48 abv New Issue
2018-04-08 18:48 abv Assigned To => apn
2018-04-08 18:52 abv Relationship added related to 0028903
2018-04-08 18:52 abv Relationship added related to 0029663
2018-04-08 19:02 git Note Added: 0075232
2018-04-08 21:25 git Note Added: 0075234
2018-04-09 07:20 git Note Added: 0075236
2018-04-09 08:28 abv Note Added: 0075237
2018-04-09 08:28 abv Status new => resolved
2018-04-09 08:28 abv Assigned To apn => nbv
2018-04-09 09:43 nbv Note Added: 0075238
2018-04-09 09:43 nbv Assigned To nbv => bugmaster
2018-04-09 09:43 nbv Status resolved => reviewed
2018-04-09 09:52 nbv Note Added: 0075239
2018-04-09 13:20 bugmaster Note Added: 0075244
2018-04-09 13:20 bugmaster Status reviewed => tested
2018-04-11 07:49 bugmaster Changeset attached => occt master 9b74e207
2018-04-11 07:49 bugmaster Status tested => verified
2018-04-11 07:49 bugmaster Resolution open => fixed
2018-04-11 11:00 git Note Added: 0075351
2018-04-11 12:05 bugmaster Test case number => offset faces_type_i E5
2018-06-29 21:14 user533 Fixed in Version => 7.3.0
2018-06-29 21:19 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker