MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029636Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2018-03-23 15:402018-04-11 14:46
Reporterjgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0029636: Wrong detection of closedness of face in method BRepOffset_Tool::EnLargeFace
DescriptionWhen a closed face lies on periodic surface and its parametric origin differs from the surface parametric origin, detection of closedness is wrong.
Steps To ReproduceNo.
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0074833)
git (administrator)
2018-03-23 16:08

Branch CR29636 has been created by jgv.

SHA-1: 3db07a9b2aae53b6024cd3f86d77b777d0257aaa


Detailed log of new commits:

Author: jgv
Date: Fri Mar 23 16:08:11 2018 +0300

    0029636: Wrong detection of closedness of face in method BRepOffset_Tool::EnLargeFace
    
    Add method BRepOffset_Tool::DetectClosedness that sets values of flags "uclosed" and "vclosed".
(0074924)
git (administrator)
2018-03-26 14:44

Branch CR29636_1 has been created by jgv.

SHA-1: daea2ad3116adfb4864d5d3c57153a9cb4f8405b


Detailed log of new commits:

Author: jgv
Date: Mon Mar 26 14:39:56 2018 +0300

    Change usage of infinite values in enlargement of surface.

Author: jgv
Date: Fri Mar 23 16:08:11 2018 +0300

    0029636: Wrong detection of closedness of face in method BRepOffset_Tool::EnLargeFace
    
    Add method BRepOffset_Tool::DetectClosedness that sets values of flags "uclosed" and "vclosed".

Author: jgv
Date: Thu Mar 22 19:15:26 2018 +0300

    Next version

Author: jgv
Date: Tue Mar 20 16:39:43 2018 +0300

    Delete a comment

Author: jgv
Date: Thu Feb 1 10:59:18 2018 +0300

    Modify test case

Author: jgv
Date: Wed Jan 31 14:06:31 2018 +0300

    Fix of regressions

Author: jgv
Date: Tue Jan 30 14:09:12 2018 +0300

    Correction according to the remarks

Author: jgv
Date: Fri Jan 26 15:56:01 2018 +0300

    Modify test cases

Author: jgv
Date: Thu Jan 25 14:48:39 2018 +0300

    Fix of regressions

Author: jgv
Date: Tue Jan 23 18:26:15 2018 +0300

    Add test case.

Author: jgv
Date: Tue Jan 23 17:54:06 2018 +0300

    0028903: BRepOffset_MakeOffset produces invalid shape (thickshell) in Intersection mode
    
    1. Method BRepOffset_Tool::Inter3D is modified: now selection of proper edges is performed here, they are not concatenated into one edge if they go through a vertex on a boundary.
    
    2. Method BRepOffset_Inter3d::ConnexIntByInt is modified: selection of edges is eliminated.
    
    3. Method BRepOffset_Inter2d::ConnexIntByInt is corrected to be able to process seam edges correct.
(0074958)
git (administrator)
2018-03-27 14:49

Branch CR29636_1 has been updated by jgv.

SHA-1: 3446f9f55d2477b23fa1ec9ce330d01f93718f97


Detailed log of new commits:

Author: jgv
Date: Tue Mar 27 14:48:39 2018 +0300

    Add new parameter "UseInfini" to method BRepOffset_Tool::EnLargeFace

(0074976)
jgv (developer)
2018-03-27 21:59

Please review the branch CR29636_1.
(0074986)
emv (developer)
2018-03-28 10:25

Dear Julia, please squash the commits and provide the proper commit message for the fix.
Please rebase also the patch on the current master or if necessary on the actual patch for the issue #28903.
(0075033)
git (administrator)
2018-03-29 17:08

Branch CR29636_2 has been created by jgv.

SHA-1: 9b69aa3e596ae3ac5d33d34fc485e6665ce8e0d3


Detailed log of new commits:

Author: jgv
Date: Fri Mar 23 16:08:11 2018 +0300

    0029636: Wrong detection of closedness of face in method BRepOffset_Tool::EnLargeFace
    
    Add method BRepOffset_Tool::DetectClosedness that sets values of flags "uclosed" and "vclosed".
(0075055)
emv (developer)
2018-03-30 14:09

The branch has not been reviewed yet.
(0075056)
emv (developer)
2018-03-30 14:46

src/BRepOffset/BRepOffset_Tool.hxx
- Add comments for the new method and new parameter of EnLargeFace method.

src/BRepOffset/BRepOffset_Tool.cxx
- What is the purpose of the repetition of the comment in lines 3137-3145?
- line 3093: stop the loop if both theUclosed and theVclosed are set to true;
- line 2702: the flag name "UseInfini" does not seem to be appropriate.

Please explain the following differences in images:
IMAGE bugs modalg_6 bug26288
IMAGE bugs modalg_2 bug5805_41

Performance degradation on both Linux and Windows platforms:
CPU bugs modalg_2 bug5805_18: 1.3728088 / 0.7332047 [+87.23%]
(0075060)
git (administrator)
2018-03-30 16:18

Branch CR29636_2 has been updated by jgv.

SHA-1: 0765dd917f4cc7a483fe910032f8b25c3c9c3141


Detailed log of new commits:

Author: jgv
Date: Fri Mar 30 16:18:08 2018 +0300

    Correction according to the remarks.

(0075061)
jgv (developer)
2018-03-30 16:20

Please have a look at modified CR29636_2 before I launch testing.
(0075065)
emv (developer)
2018-03-30 16:38

Please explain the meaning of the ExtensionMode:
1 - analytical faces will be extended as large as possible, non-analytical on the fourth of the face U and V extension;
0 - analytical faces will be extended on ten times of the face U and V extension, non-analytical on the face U and V extension.
(0075127)
msv (developer)
2018-04-02 18:33

Please close this as a duplicate of #29591.
(0075364)
git (administrator)
2018-04-11 11:04

Branch CR29636 has been deleted by kgv.

SHA-1: 3db07a9b2aae53b6024cd3f86d77b777d0257aaa
(0075365)
git (administrator)
2018-04-11 11:04

Branch CR29636_1 has been deleted by kgv.

SHA-1: 3446f9f55d2477b23fa1ec9ce330d01f93718f97
(0075366)
git (administrator)
2018-04-11 11:04

Branch CR29636_2 has been deleted by kgv.

SHA-1: 0765dd917f4cc7a483fe910032f8b25c3c9c3141

- Issue History
Date Modified Username Field Change
2018-03-23 15:40 jgv New Issue
2018-03-23 15:40 jgv Assigned To => msv
2018-03-23 15:41 jgv Assigned To msv => jgv
2018-03-23 15:41 jgv Status new => assigned
2018-03-23 16:08 git Note Added: 0074833
2018-03-26 14:44 git Note Added: 0074924
2018-03-27 14:49 git Note Added: 0074958
2018-03-27 21:59 jgv Note Added: 0074976
2018-03-27 21:59 jgv Assigned To jgv => msv
2018-03-27 21:59 jgv Status assigned => resolved
2018-03-27 21:59 jgv Steps to Reproduce Updated View Revisions
2018-03-28 09:49 msv Assigned To msv => emv
2018-03-28 10:25 emv Note Added: 0074986
2018-03-28 10:25 emv Assigned To emv => jgv
2018-03-28 10:25 emv Status resolved => assigned
2018-03-29 17:08 git Note Added: 0075033
2018-03-30 13:48 jgv Assigned To jgv => msv
2018-03-30 13:48 jgv Status assigned => resolved
2018-03-30 13:48 jgv Assigned To msv => bugmaster
2018-03-30 13:48 jgv Status resolved => reviewed
2018-03-30 14:09 emv Note Added: 0075055
2018-03-30 14:09 emv Status reviewed => assigned
2018-03-30 14:09 emv Assigned To bugmaster => emv
2018-03-30 14:09 emv Status assigned => resolved
2018-03-30 14:46 emv Note Added: 0075056
2018-03-30 14:46 emv Assigned To emv => jgv
2018-03-30 14:46 emv Status resolved => assigned
2018-03-30 15:32 msv Relationship added related to 0028903
2018-03-30 15:46 emv Relationship added related to 0029591
2018-03-30 16:18 git Note Added: 0075060
2018-03-30 16:20 jgv Note Added: 0075061
2018-03-30 16:20 jgv Assigned To jgv => msv
2018-03-30 16:20 jgv Status assigned => resolved
2018-03-30 16:38 emv Note Added: 0075065
2018-04-02 17:28 msv Assigned To msv => jgv
2018-04-02 17:28 msv Status resolved => assigned
2018-04-02 18:20 jgv Relationship replaced duplicate of 0029591
2018-04-02 18:33 msv Note Added: 0075127
2018-04-02 18:33 msv Assigned To jgv => bugmaster
2018-04-02 18:33 msv Status assigned => feedback
2018-04-03 10:45 bugmaster Status feedback => closed
2018-04-03 10:45 bugmaster Resolution open => fixed
2018-04-11 11:04 git Note Added: 0075364
2018-04-11 11:04 git Note Added: 0075365
2018-04-11 11:04 git Note Added: 0075366
2018-04-11 14:46 bugmaster Resolution fixed => duplicate


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker