MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029515Open CASCADE[OCCT] OCCT:Foundation Classespublic2018-02-19 21:502018-06-29 21:21
Reporteribs 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformMacOSiOS OS Version11.2
Product Version[OCCT] 7.3.0 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0029515: Foundation Classes, OSD - 'Spawn' contains function that isn't available on iOS
Description'system' function of OSD_Process::Spawn isn't available on iOS
Steps To ReproduceBuild OCCT on iOS
TagsNo tags attached.
Test case numberNot needed
Attached Files

- Relationships

-  Notes
(0074457)
abv (manager)
2018-03-14 09:23

So how it was possible to build OCCT on iOS before??
(0074468)
git (administrator)
2018-03-14 13:56

Branch CR29515 has been created by abv.

SHA-1: 5b1a76df8a7bbcbc87a6322b0b0c74c7c710f33c


Detailed log of new commits:

Author: abv
Date: Wed Mar 14 11:02:10 2018 +0300

    0029515: Foundation Classes, OSD - 'Spawn' contains function that isn't available on iOS
    
    Method OSD_Process::Spawn() is removed as useless (not used across OCCT or products).
    Note that on Linux, macOS, and Windows standard C function "system()" can be used directly instead, while iOS apparently does not support spawning separate processes at all.
(0074469)
abv (manager)
2018-03-14 13:58

Fix pushed to CR29515, please review. I suppose that testing is not needed, since the removed function has not been used.
(0074472)
kgv (developer)
2018-03-14 14:35

Please integrate.
(0074609)
git (administrator)
2018-03-19 10:05

Branch CR29515 has been deleted by kgv.

SHA-1: 5b1a76df8a7bbcbc87a6322b0b0c74c7c710f33c

- Related Changesets
occt: master 97e96609
Timestamp: 2018-03-14 08:02:10
Author: abv
Committer: bugmaster
Details ] Diff ]
0029515: Foundation Classes, OSD - 'Spawn' contains function that isn't available on iOS

Method OSD_Process::Spawn() is removed as useless (not used across OCCT or products).
Note that on Linux, macOS, and Windows standard C function "system()" can be used directly instead, while iOS apparently does not support spawning separate processes at all.
mod - src/OSD/OSD_Process.cxx Diff ] File ]
mod - src/OSD/OSD_Process.hxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-02-19 21:50 ibs New Issue
2018-02-19 21:50 ibs Assigned To => abv
2018-03-14 01:19 kgv Target Version 7.4.0* => 7.3.0
2018-03-14 09:23 abv Note Added: 0074457
2018-03-14 09:23 abv Assigned To abv => ibs
2018-03-14 09:23 abv Status new => feedback
2018-03-14 13:56 git Note Added: 0074468
2018-03-14 13:58 abv Note Added: 0074469
2018-03-14 13:58 abv Assigned To ibs => kgv
2018-03-14 13:58 abv Status feedback => resolved
2018-03-14 13:58 abv Steps to Reproduce Updated View Revisions
2018-03-14 14:35 kgv Note Added: 0074472
2018-03-14 14:35 kgv Assigned To kgv => bugmaster
2018-03-14 14:35 kgv Status resolved => reviewed
2018-03-14 16:12 bugmaster Test case number => Not needed
2018-03-14 16:32 bugmaster Status reviewed => tested
2018-03-18 13:21 bugmaster Changeset attached => occt master 97e96609
2018-03-18 13:21 bugmaster Status tested => verified
2018-03-18 13:21 bugmaster Resolution open => fixed
2018-03-19 10:05 git Note Added: 0074609
2018-06-29 21:16 user533 Fixed in Version => 7.3.0
2018-06-29 21:21 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker