View Issue Details

IDProjectCategoryView StatusLast Update
0029501Open CASCADEOCCT:Modeling Algorithmspublic2020-11-16 15:25
ReporternbvAssigned Tomsv  
PrioritynormalSeverityminor 
Status assignedResolutionopen 
Target VersionUnscheduled 
Summary0029501: Modeling Algorithms - Intersection algorithm produces the curve with loop
DescriptionSee Steps To Reproduce and "loopCurve.PNG" attached picture

P.S.

Please pay attention to the fact that this curve is out of surfaces' boundaries
Steps To ReproduceTest bugs modalg_5 bug24472

pload ALL
restore [locate_data_file bug24472_Pipe_1.brep] b1

explode b1 f
copy b1_2 f1
copy b1_3 f2
copy b1_6 f3
mksurface s1 f1
mksurface s2 f2
mksurface s3 f3

intersect i s1 s2

don i_22
TagsNo tags attached.
Test case number

Attached Files

  • loopCurve.PNG (9,121 bytes)

Relationships

related to 0031941 newapn Open CASCADE Tests - some test cases in lowalgos/intss are wrong 

Activities

nbv

2018-02-13 10:44

developer  

loopCurve.PNG (9,121 bytes)

nbv

2018-02-13 10:45

developer   ~0073953

This problem is reproduced on the current MASTER and has been detected while fixing bug #29494

git

2018-10-26 16:31

administrator   ~0080389

Branch CR29501 has been created by nbv.

SHA-1: b886479bb34bcad1359b93c7a84b0d8d15f6db3e


Detailed log of new commits:

Author: nbv
Date: Fri Oct 26 16:29:48 2018 +0300

    0029501: Intersection algorithm produces the curve with loop
    
    Test case lowalgos/intss/bug24472 has been modified in order to check loops of the resulting intersection curves.
    
    No fix is needed because the issue is not reproduced on MASTER.

git

2018-10-29 11:08

administrator   ~0080442

Branch CR29501 has been updated forcibly by nbv.

SHA-1: 5895e4e9cc75cdec706ced6c2ed8d52dcaeb2645

nbv

2018-10-29 13:09

developer   ~0080449

Dear Mikhail,

Please review the current state of CR29501 branch.

Test results are here: http://jenkins-test-12.nnov.opencascade.com/view/CR29501-master_NBV/

msv

2018-10-29 19:28

developer   ~0080484

tests/lowalgos/intss/begin
- Why the character "\n" is used instead of direct new line in the comments?
- help checkarea - is this intended here?

Can the test bug28493 be updated to use the new command CheckLoops?

git

2018-10-30 09:57

administrator   ~0080491

Branch CR29501 has been updated by nbv.

SHA-1: 80dd6a050c138f821a4ebda488bdd21979ce9ad5


Detailed log of new commits:

Author: nbv
Date: Tue Oct 30 09:54:25 2018 +0300

    # Corrections according to remarks

nbv

2018-10-30 10:32

developer   ~0080496

I am sorry.

This bug is sstill reproduced on MASTER version. Steps To Reproduce has been updated.

Nevertheless, updated test case should be integrated.

msv

2018-10-30 12:13

developer   ~0080509

Correct the commit message.

git

2018-10-30 12:17

administrator   ~0080510

Branch CR29501 has been updated forcibly by nbv.

SHA-1: 78db688e70bfff39516330d9c8aca94eea3e297c

nbv

2018-10-30 12:17

developer   ~0080511

Done.

git

2018-10-30 12:23

administrator   ~0080512

Branch CR29501 has been deleted by nbv.

SHA-1: 78db688e70bfff39516330d9c8aca94eea3e297c

msv

2018-10-30 12:25

developer   ~0080513

As the bug is not fixed, I leave it open.

Issue History

Date Modified Username Field Change
2018-02-13 10:44 nbv New Issue
2018-02-13 10:44 nbv Assigned To => msv
2018-02-13 10:44 nbv File Added: loopCurve.PNG
2018-02-13 10:45 nbv Note Added: 0073953
2018-02-13 11:26 nbv Description Updated
2018-10-26 13:37 nbv Assigned To msv => nbv
2018-10-26 13:37 nbv Status new => assigned
2018-10-26 16:31 git Note Added: 0080389
2018-10-29 11:08 git Note Added: 0080442
2018-10-29 13:09 nbv Note Added: 0080449
2018-10-29 13:09 nbv Assigned To nbv => msv
2018-10-29 13:09 nbv Status assigned => resolved
2018-10-29 19:28 msv Note Added: 0080484
2018-10-29 19:28 msv Assigned To msv => nbv
2018-10-29 19:28 msv Status resolved => assigned
2018-10-30 09:57 git Note Added: 0080491
2018-10-30 10:30 nbv Steps to Reproduce Updated
2018-10-30 10:32 nbv Note Added: 0080496
2018-10-30 12:13 msv Note Added: 0080509
2018-10-30 12:17 git Note Added: 0080510
2018-10-30 12:17 nbv Note Added: 0080511
2018-10-30 12:17 nbv Assigned To nbv => msv
2018-10-30 12:17 nbv Status assigned => resolved
2018-10-30 12:23 git Note Added: 0080512
2018-10-30 12:25 msv Note Added: 0080513
2018-10-30 12:25 msv Assigned To msv => nbv
2018-10-30 12:25 msv Status resolved => assigned
2019-08-12 19:08 msv Assigned To nbv => msv
2019-08-12 19:16 msv Target Version 7.4.0 => Unscheduled
2019-09-04 12:11 kgv Summary Intersection algorithm produces the curve with loop => Modeling Algorithms - Intersection algorithm produces the curve with loop
2020-11-16 15:25 ifv Relationship added related to 0031941