View Issue Details

IDProjectCategoryView StatusLast Update
0029450Open CASCADEOCCT:Testspublic2019-03-05 10:09
Reportermsv Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Product Version7.2.0 
Target Version7.4.0 
Summary0029450: Constantly repeated difference in images of tests "v3d raytrace"
DescriptionThe following test cases always generate images that differ from run to run:

IMAGE v3d raytrace dof_stereo: dof_stereo.png differs
IMAGE v3d raytrace sample_ball: sample_ball_iss_iss_256.png differs
IMAGE v3d raytrace sample_ball: sample_ball_iss.png differs
IMAGE v3d raytrace sample_ball: sample_ball_iss_iss_64.png differs
IMAGE v3d raytrace sample_ball: sample_ball_iss_iss_1024.png differs
IMAGE v3d raytrace dof_mono: dof_mono.png differs
IMAGE v3d raytrace sample_ball_iss: sample_ball_iss.png differs
IMAGE v3d raytrace sample_ball_iss: sample_ball_iss_iss_256.png differs
IMAGE v3d raytrace sample_ball_iss: sample_ball_iss_iss_64.png differs
IMAGE v3d raytrace sample_ball_iss: sample_ball_iss_iss_1024.png differs
IMAGE v3d raytrace tone_mapping: tone_mapping.png differs

If the algorithm cannot provide the same image on each run then we should avoid generating such images and their comparison.
TagsNo tags attached.
Test case number

Relationships

duplicate of 0030476 closedapn Visualization, Path Tracing - Adaptive Screen Sampling leads to unstable results 

Activities

kgv

2019-03-03 00:30

developer   ~0082547

Please close as duplicate of 0030476.

Issue History

Date Modified Username Field Change
2018-01-25 15:44 msv New Issue
2018-01-25 15:44 msv Assigned To => apn
2019-03-03 00:29 kgv Relationship added duplicate of 0030476
2019-03-03 00:30 kgv Note Added: 0082547
2019-03-03 00:30 kgv Assigned To apn => bugmaster
2019-03-03 00:30 kgv Status new => feedback
2019-03-03 00:30 kgv Resolution open => duplicate
2019-03-05 10:09 bugmaster Status feedback => closed