View Issue Details

IDProjectCategoryView StatusLast Update
0029316Open CASCADEOCCT:Meshpublic2019-02-14 12:03
Reporteraml Assigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version7.2.0 
Target Version7.4.0Fixed in Version7.4.0 
Summary0029316: Test case bugs mesh bug25806 works unstable
DescriptionThe problem was detected in the scope of the 25104 issue. Execution time is unstable:

TOTAL CPU TIME: 26.234375 sec
TOTAL CPU TIME: 28.765625 sec
TOTAL CPU TIME: 28.625 sec
TOTAL CPU TIME: 36.046875 sec
TOTAL CPU TIME: 27.59375 sec
Steps To Reproducetest bugs mesh bug25806
TagsNo tags attached.
Test case numberNot needed

Relationships

related to 0025104 closedbugmaster Community Prism from BSpline curve can not be chamfered 
related to 0026106 closedbugmaster Open CASCADE BRepMesh - revision of data model 

Activities

oan

2017-11-13 11:23

developer   ~0072205

DC,

the test case has became stable regarding execution time after 0026106 patch.
Here are the results:

TOTAL CPU TIME: 27.2845749 sec
TOTAL CPU TIME: 27.300175 sec
TOTAL CPU TIME: 27.8929788 sec
TOTAL CPU TIME: 27.0817736 sec
TOTAL CPU TIME: 26.9725729 sec

IMHO, it seems that this is the best time to review and integrate it, because it already solves too many problems existing in Mantis.

BR,
Oleg.

oan

2018-11-02 16:06

developer   ~0080640

Dear bugmaster,

please check after integration of 0026106.

nbv

2018-11-07 16:06

developer   ~0080839

Last edited: 2018-11-07 16:08

Test case is already exists: bug25806.

So, please check its stability.

E.g.

Result on WINDOWS: http://occt-tests/IR-2018-11-02-OCCT/Windows-64-VC14/bugs/mesh/bug25806.html

Result on Linux: http://occt-tests/IR-2018-11-02-OCCT/Debian80-64/bugs/mesh/bug25806.html

Issue History

Date Modified Username Field Change
2017-11-13 10:57 aml New Issue
2017-11-13 10:57 aml Assigned To => msv
2017-11-13 10:57 aml Relationship added related to 0025104
2017-11-13 11:23 oan Note Added: 0072205
2017-11-13 11:23 oan Relationship added related to 0026106
2017-11-13 11:25 msv Assigned To msv => oan
2017-11-13 11:25 msv Category OCCT:Modeling Algorithms => OCCT:Mesh
2018-11-02 16:06 oan Note Added: 0080640
2018-11-02 16:06 oan Assigned To oan => bugmaster
2018-11-02 16:06 oan Status new => feedback
2018-11-07 16:06 nbv Note Added: 0080839
2018-11-07 16:08 nbv Note Edited: 0080839
2018-11-08 13:05 bugmaster Status feedback => verified
2018-11-08 13:05 bugmaster Resolution open => fixed
2019-01-09 17:50 bugmaster Test case number => Not needed
2019-02-14 12:03 bugmaster Project Internal => Open CASCADE