View Issue Details

IDProjectCategoryView StatusLast Update
0029242Open CASCADEOCCT:Data Exchangepublic2022-06-14 13:52
ReporterikaAssigned Tobugmaster  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Product Version7.2.0 
Target Version7.7.0Fixed in Version7.3.0 
Summary0029242: Data Exchange - Crash during reading STEP file.
DescriptionThis issue is from DMU_Reviewer project.

The problem in these entities:
# 46=DIMENSIONAL_LOCATION('linear distance',$,# 109,# 110);
# 625=EDGE_CURVE('',# 742,# 742,# 830,.T.);
during dimension attaching this curve is found in translation map, but not found in result document.
The possible cause is that the given curve is splitted during Shape Healing and translation map is not updated correctly by Shape Healing history.

Steps To ReproduceReadStep Doc 796972_PMI_NX.stp

Draw[4]> ReadStep D 796972_PMI_NX.stp
An exception was caught 000001C2406F5E80 : Standard_NullObject: A null Label has no attribute.
** Exception ** 000001C2406F5E80 : Standard_NullObject: A null Label has no attribute.
TagsNo tags attached.
Test case number

Attached Files

  • 796972_PMI_NX.stp (427,673 bytes)

Activities

ika

2017-10-18 17:45

developer  

796972_PMI_NX.stp (427,673 bytes)

ichesnokova

2021-11-21 21:40

developer   ~0105322

Analyzing

ichesnokova

2021-11-24 11:07

developer   ~0105389

This issue is not reproducible on current master.

kgv

2021-11-24 11:27

developer   ~0105390

I guess the issue is a duplicate of #0029362 fixed in OCCT 7.3.0.

ika

2021-11-24 12:17

developer   ~0105391

Dear bugmaster,

as mentioned above, the issue is not reproduced, and everything is translated correctly now.
Could you please close the issue?

Issue History

Date Modified Username Field Change
2017-10-18 17:45 ika New Issue
2017-10-18 17:45 ika Assigned To => gka
2017-10-18 17:45 ika File Added: 796972_PMI_NX.stp
2017-10-18 17:46 ika Description Updated
2017-10-18 17:57 ika Severity minor => feature
2017-10-18 17:57 ika Severity feature => minor
2019-09-04 13:04 abv Target Version 7.4.0 => 7.5.0
2020-09-14 12:18 gka Target Version 7.5.0 => 7.6.0
2021-10-18 14:02 kgv Target Version 7.6.0 => 7.7.0
2021-11-18 19:01 ika Assigned To gka => ichesnokova
2021-11-18 19:01 ika Status new => assigned
2021-11-21 21:40 ichesnokova Note Added: 0105322
2021-11-24 11:07 ichesnokova Note Added: 0105389
2021-11-24 11:07 ichesnokova Assigned To ichesnokova => ika
2021-11-24 11:07 ichesnokova Status assigned => feedback
2021-11-24 11:18 kgv Description Updated
2021-11-24 11:18 kgv Steps to Reproduce Updated
2021-11-24 11:18 kgv Fixed in Version => 7.3.0
2021-11-24 11:27 kgv Note Added: 0105390
2021-11-24 11:27 kgv Resolution open => duplicate
2021-11-24 12:17 ika Note Added: 0105391
2021-11-24 12:17 ika Assigned To ika => bugmaster
2022-06-14 13:52 azv Status feedback => closed