MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0029214Open CASCADE[OCCT] OCCT:Application Frameworkpublic2017-10-12 11:302018-06-29 21:19
Reporterkgv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version[OCCT] 5.2.2 
Target Version[OCCT] 7.3.0Fixed in Version[OCCT] 7.3.0 
Summary0029214: Application Framework - TPrsStd_AISPresentation::AISUpdate() should not implicitly redraw 3D Viewer
DescriptionAll places within TPrsStd_AISPresentation::AISUpdate() modify presentation without redrawing 3D Viewer, except one place:
void TPrsStd_AISPresentation::AISUpdate()
{
  ...
  aContext->Remove (myAIS, Standard_True);


This makes XShow command executing ages on big model due to viewer redraw on each root in the Document.

It looks like a bug in TPrsStd_AISPresentation::AISUpdate() implementation.
Steps To ReproduceN/A
TagsNo tags attached.
Test case numberNot required
Attached Files

- Relationships
child of 0028088closedkgv Visualization, AIS_InteractiveContext - drop default value for Update Viewer parameter 

-  Notes
(0071362)
git (administrator)
2017-10-12 11:32

Branch CR29214 has been created by kgv.

SHA-1: fabb900c5e58b858fc889fcbda7decd9b78008fe


Detailed log of new commits:

Author: kgv
Date: Thu Oct 12 11:31:41 2017 +0300

    0029214: Application Framework - TPrsStd_AISPresentation::AISUpdate() should not implicitly redraw 3D Viewer
(0071363)
kgv (developer)
2017-10-12 11:32

Patch is ready for review.
(0071510)
mpv (developer)
2017-10-16 09:41

Dear VRO,

Could you review this fix, since you have wider experience of working with AIS.
(0071513)
vro (developer)
2017-10-16 10:10

I agree, it was a mistake to redraw the view on AISUpdate().
(0071538)
bugmaster (administrator)
2017-10-16 15:08

Combination -
OCCT branch : CR29214 SHA-1: fabb900c5e58b858fc889fcbda7decd9b78008fe
Products branch : master
was compiled on Linux, MacOS and Windows platforms and tested on optimize mode.

Number of compiler warnings:
No new/fixed warnings

Regressions/Differences/Improvements:
No regressions/differences

CPU differences:
No differences that require special attention

Image differences :
No differences that require special attention

Memory differences :
No differences that require special attention
(0072071)
git (administrator)
2017-11-08 18:24

Branch CR29214 has been deleted by kgv.

SHA-1: fabb900c5e58b858fc889fcbda7decd9b78008fe

- Related Changesets
occt: master f6c2b39a
Timestamp: 2017-10-12 08:31:41
Author: kgv
Committer: bugmaster
Details ] Diff ]
0029214: Application Framework - TPrsStd_AISPresentation::AISUpdate() should not implicitly redraw 3D Viewer
mod - src/TPrsStd/TPrsStd_AISPresentation.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-10-12 11:30 kgv New Issue
2017-10-12 11:30 kgv Assigned To => mpv
2017-10-12 11:32 git Note Added: 0071362
2017-10-12 11:32 kgv Note Added: 0071363
2017-10-12 11:32 kgv Status new => resolved
2017-10-12 11:34 kgv Product Version 7.2.0 => 5.2.2
2017-10-16 09:40 mpv Assigned To mpv => vro
2017-10-16 09:41 mpv Note Added: 0071510
2017-10-16 10:10 vro Note Added: 0071513
2017-10-16 10:10 vro Assigned To vro => bugmaster
2017-10-16 10:10 vro Status resolved => reviewed
2017-10-16 15:06 bugmaster Test case number => Not required
2017-10-16 15:08 bugmaster Note Added: 0071538
2017-10-16 15:08 bugmaster Status reviewed => tested
2017-10-27 09:54 bugmaster Changeset attached => occt master f6c2b39a
2017-10-27 09:54 bugmaster Status tested => verified
2017-10-27 09:54 bugmaster Resolution open => fixed
2017-11-02 09:56 kgv Relationship added child of 0028088
2017-11-08 18:24 git Note Added: 0072071
2018-02-17 19:03 abv Target Version 7.4.0* => 7.3.0
2018-06-29 21:15 user533 Fixed in Version => 7.3.0
2018-06-29 21:19 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker