MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0028998Open CASCADE[OCCT] OCCT:Releasepublic2017-08-15 15:142017-09-29 16:29
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version[OCCT] 7.2.0Fixed in Version[OCCT] 7.2.0 
Summary0028998: OCCT installer on Windows 10 creates unusable content in Start menu
DescriptionWhen installed on Windows, OCCT fills Start menu by several groups of items:
- Links to Release Notes, Overview (chm and html), Reference Manual, DRAW
- Sub-folder containing links to sample applications
- Sub-folder containing links to PDF docs

On Windows 10, this does not work any more as expected: instead of showing these items in hierarchy as they are created, it shows them in plain list, likely sorted alphabetically. This produces unusable mess.

We need to modify the installer to provide more usable content on Windows 10. I propose the following:

a) Remove link to Overview.chm -- this format is obsolete anyway
b) Instead of creating sub-menus containing links to PDFs and samples in Start menu, try creating folders with such links, and add only links to these folders to Start menu
c) If (b) is not feasible, create only links to Overview, Reference Manual, Release Notes, and DRAW launcher
Steps To ReproduceNot required
TagsNo tags attached.
Test case number
Attached Files

- Relationships

-  Notes
(0070020)
abv (manager)
2017-08-28 20:22

Seems to be OK now, thank you!

- Issue History
Date Modified Username Field Change
2017-08-15 15:14 abv New Issue
2017-08-15 15:14 abv Assigned To => bugmaster
2017-08-15 17:19 bugmaster Status new => feedback
2017-08-27 16:40 bugmaster Assigned To bugmaster => abv
2017-08-27 16:40 bugmaster Status feedback => resolved
2017-08-27 16:40 bugmaster Steps to Reproduce Updated View Revisions
2017-08-28 20:22 abv Note Added: 0070020
2017-08-28 20:22 abv Assigned To abv => bugmaster
2017-08-28 20:22 abv Status resolved => reviewed
2017-08-29 10:09 bugmaster Status reviewed => verified
2017-08-29 10:09 bugmaster Resolution open => fixed
2017-09-29 16:17 user533 Fixed in Version => 7.2.0
2017-09-29 16:29 user533 Status verified => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker